]> git.pld-linux.org Git - packages/ruby-rb-fsevent.git/blob - ruby-rb-fsevent.spec
b39dcbf4c06c1770fe71087d3a511944d625ad49
[packages/ruby-rb-fsevent.git] / ruby-rb-fsevent.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define pkgname rb-fsevent
6 Summary:        Very simple & usable FSEvents API
7 Name:           ruby-%{pkgname}
8 Version:        0.9.4
9 Release:        1
10 License:        MIT
11 Group:          Development/Languages
12 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
13 # Source0-md5:  47456c473a7e3e347c0d20ebda7bbad4
14 URL:            http://rubygems.org/gems/rb-fsevent
15 BuildRequires:  rpm-rubyprov
16 BuildRequires:  rpmbuild(macros) >= 1.656
17 %if %{with tests}
18 BuildRequires:  ruby-bundler < 2
19 BuildRequires:  ruby-bundler >= 1.0
20 BuildRequires:  ruby-guard-rspec < 5
21 BuildRequires:  ruby-guard-rspec >= 4.2
22 BuildRequires:  ruby-rspec < 3
23 BuildRequires:  ruby-rspec >= 2.11
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 FSEvents API with Signals catching (without RubyCocoa)
30
31 %prep
32 %setup -q -n %{pkgname}-%{version}
33
34 %build
35 # write .gemspec
36 %__gem_helper spec
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir}}
41 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
42 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %doc README.md LICENSE.txt
50 %{ruby_vendorlibdir}/rb-fsevent.rb
51 %{ruby_vendorlibdir}/rb-fsevent
52 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
This page took 0.03945 seconds and 2 git commands to generate.