]> git.pld-linux.org Git - packages/ruby-pry.git/blob - ruby-pry.spec
5eef44a585c3c6096f2285d6512ffb3ae702f7c2
[packages/ruby-pry.git] / ruby-pry.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define pkgname pry
6 Summary:        An IRB alternative and runtime developer console
7 Name:           ruby-%{pkgname}
8 Version:        0.9.12
9 Release:        1
10 License:        MIT
11 Group:          Development/Languages
12 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
13 # Source0-md5:  -
14 URL:            http://pry.github.com
15 BuildRequires:  rpm-rubyprov
16 BuildRequires:  rpmbuild(macros) >= 1.656
17 BuildRequires:  sed >= 4.0
18 %if %{with tests}
19 BuildRequires:  ruby-bacon < 2
20 BuildRequires:  ruby-bacon >= 1.2
21 BuildRequires:  ruby-bond < 0.5
22 BuildRequires:  ruby-bond >= 0.4.2
23 BuildRequires:  ruby-guard < 1.4
24 BuildRequires:  ruby-guard >= 1.3.2
25 BuildRequires:  ruby-mocha < 0.14
26 BuildRequires:  ruby-mocha >= 0.13.1
27 BuildRequires:  ruby-open4 < 2
28 BuildRequires:  ruby-open4 >= 1.3
29 BuildRequires:  ruby-rake < 1
30 BuildRequires:  ruby-rake >= 0.9
31 %endif
32 Requires:       ruby-coderay < 1.1
33 Requires:       ruby-coderay >= 1.0.5
34 Requires:       ruby-method_source < 1
35 Requires:       ruby-method_source >= 0.8
36 Requires:       ruby-slop < 4
37 Requires:       ruby-slop >= 3.4
38 BuildArch:      noarch
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 An IRB alternative and runtime developer console
43
44 %package doc
45 Summary:        Documentation for %{name}
46 Group:          Documentation
47 Requires:       %{name} = %{version}-%{release}
48
49 %description doc
50 Documentation for %{name}.
51
52 %prep
53 %setup -q -n %{pkgname}-%{version}
54 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
55
56 %if %{with tests}
57 bacon -Ispec -q spec/*_spec.rb
58 %endif
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir},%{_mandir}/man1}
63 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
64 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
65 cp -a man/pry.1 $RPM_BUILD_ROOT%{_mandir}/man1
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc README.markdown LICENSE CHANGELOG CONTRIBUTORS
73 %attr(755,root,root) %{_bindir}/pry
74 %{_mandir}/man1/pry.1*
75 %{ruby_vendorlibdir}/pry.rb
76 %{ruby_vendorlibdir}/pry
This page took 0.02657 seconds and 2 git commands to generate.