]> git.pld-linux.org Git - packages/ruby-polyglot.git/blob - ruby-polyglot.spec
de6d4a85dfac5f6b98d357dd5bdba60b36d55bbc
[packages/ruby-polyglot.git] / ruby-polyglot.spec
1 %define pkgname polyglot
2 Summary:        Allows custom language loaders for specified file extensions to be hooked into require
3 Name:           ruby-%{pkgname}
4 Version:        0.3.0
5 Release:        2
6 License:        MIT/Ruby License
7 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
8 # Source0-md5:  a2d132bd4f445a4bd104a74b3316e029
9 Group:          Development/Languages
10 URL:            http://rubyforge.org/projects/.../
11 BuildRequires:  rpmbuild(macros) >= 1.484
12 BuildRequires:  ruby >= 1:1.8.6
13 BuildRequires:  ruby-modules
14 %{?ruby_mod_ver_requires_eq}
15 #BuildArch:     noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 # nothing to be placed there. we're not noarch only because of ruby packaging
19 %define         _enable_debug_packages  0
20
21 %description
22 Allows custom language loaders for specified file
23 extensions to be hooked into require.
24
25 %package rdoc
26 Summary:        HTML documentation for %{pkgname}
27 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla %{pkgname}
28 Group:          Documentation
29 Requires:       ruby >= 1:1.8.7-4
30
31 %description rdoc
32 HTML documentation for %{pkgname}.
33
34 %description rdoc -l pl.UTF-8
35 Dokumentacja w formacie HTML dla %{pkgname}.
36
37 %package ri
38 Summary:        ri documentation for %{pkgname}
39 Summary(pl.UTF-8):      Dokumentacja w formacie ri dla %{pkgname}
40 Group:          Documentation
41 Requires:       ruby
42
43 %description ri
44 ri documentation for %{pkgname}.
45
46 %description ri -l pl.UTF-8
47 Dokumentacji w formacie ri dla %{pkgname}.
48
49 %prep
50 %setup -q -c
51 %{__tar} xf %{SOURCE0} -O data.tar.gz | %{__tar} xz
52 find -newer README.txt -o -print | xargs touch --reference %{SOURCE0}
53
54 %build
55 rdoc --ri --op ri lib
56 rdoc --op rdoc lib
57 rm -r ri/Kernel
58 rm ri/created.rid
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 install -d $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{ruby_ridir},%{ruby_rdocdir}}
63
64 cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
65 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
66 cp -a rdoc $RPM_BUILD_ROOT%{ruby_rdocdir}/%{name}-%{version}
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc History.txt README.txt
74 %{ruby_rubylibdir}/%{pkgname}.rb
75 %{ruby_rubylibdir}/%{pkgname}
76
77 %files rdoc
78 %defattr(644,root,root,755)
79 %{ruby_rdocdir}/%{name}-%{version}
80
81 %files ri
82 %defattr(644,root,root,755)
83 %{ruby_ridir}/Polyglot
This page took 0.151432 seconds and 2 git commands to generate.