]> git.pld-linux.org Git - packages/ruby-omnibus.git/blob - ruby-omnibus.spec
9bfe636f93457ae013f60b151bebc5664aec89d7
[packages/ruby-omnibus.git] / ruby-omnibus.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define pkgname omnibus
6 Summary:        Omnibus helps you build self-installing, full-stack software builds
7 Name:           ruby-%{pkgname}
8 Version:        1.0.4
9 Release:        1
10 License:        Apache v2.0
11 Group:          Development/Languages
12 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
13 # Source0-md5:  4ae9235161a1553a87abca21f6672414
14 Patch0:         makeself-path.patch
15 Patch1:         omnibus-pld.patch
16 URL:            https://github.com/opscode/omnibus-ruby
17 BuildRequires:  rpm-rubyprov
18 BuildRequires:  rpmbuild(macros) >= 1.656
19 BuildRequires:  sed >= 4.0
20 %if %{with tests}
21 BuildRequires:  ruby-rspec
22 BuildRequires:  ruby-rspec_junit_formatter
23 %endif
24 Requires:       ruby-fpm < 0.5
25 Requires:       ruby-fpm >= 0.4.33
26 Requires:       ruby-mixlib-config < 1.2
27 Requires:       ruby-mixlib-config >= 1.1.2
28 Requires:       ruby-mixlib-shellout < 2
29 Requires:       ruby-mixlib-shellout >= 1.0
30 Requires:       ruby-ohai >= 0.6.12
31 Requires:       ruby-rake >= 0.9
32 Requires:       ruby-thor >= 0.16.0
33 Requires:       ruby-uber-s3
34 BuildArch:      noarch
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Omnibus helps you build self-installing, full-stack software builds.
39
40 %prep
41 %setup -q -n %{pkgname}-%{version}
42 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
43 %patch0 -p1
44 %patch1 -p1
45
46 # move these to libdir, so they don't clobber system bin dir
47 chmod a-x bin/makeself*
48 mv bin/makeself* lib/%{pkgname}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir}}
53 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
54 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %attr(755,root,root) %{_bindir}/omnibus
62 %{ruby_vendorlibdir}/%{pkgname}.rb
63 %{ruby_vendorlibdir}/%{pkgname}
This page took 0.073416 seconds and 2 git commands to generate.