]> git.pld-linux.org Git - packages/ruby-net-ssh.git/blob - ruby-net-ssh.spec
- P:ruby-Net-SSH
[packages/ruby-net-ssh.git] / ruby-net-ssh.spec
1 # TODO:
2 # - what to do with net subdir?
3 Summary:        Net::SSH - a pure-Ruby implementation of the SSH2 client protocol
4 Summary(pl.UTF-8):      Net::SSH - implementacja protokołu klienckiego SSH2 w czystym Rubym
5 Name:           ruby-net-ssh
6 Version:        2.0.15
7 Release:        1
8 License:        Ruby License
9 Source0:        http://rubyforge.org/frs/download.php/63138/net-ssh-%{version}.tgz
10 # Source0-md5:  bef3bc238f0ba1988c9ca12698cc4e35
11 Group:          Development/Languages
12 URL:            http://rubyforge.org/projects/net-ssh/
13 BuildRequires:  rpmbuild(macros) >= 1.484
14 BuildRequires:  ruby >= 1:1.8.6
15 BuildRequires:  ruby-modules
16 %{?ruby_mod_ver_requires_eq}
17 Obsoletes:      ruby-Net-SSH
18 Provides:       ruby-Net-SSH
19 #BuildArch:     noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 # nothing to be placed there. we're not noarch only because of ruby packaging
23 %define         _enable_debug_packages  0
24
25 %description
26 Net::SSH is a pure-Ruby implementation of the SSH2 client protocol.
27
28 %description -l pl.UTF-8
29 Net::SSH to implementacja protokołu klienckiego SSH2 w czystym Rubym.
30
31 %package rdoc
32 Summary:        Documentation files for net-ssh library
33 Summary(pl.UTF-8):      Pliki dokumentacji do biblioteki net-ssh
34 Group:          Documentation
35 Requires:       ruby >= 1:1.8.7-4
36
37 %description rdoc
38 Documentation files for net-ssh library.
39
40 %description rdoc -l pl.UTF-8
41 Pliki dokumentacji do biblioteki net-ssh.
42
43 %prep
44 %setup -q -n net-ssh-%{version}
45
46 %build
47 rdoc --ri --op ri lib
48 rdoc --op rdoc lib
49
50 rm -rf ri/OpenSSL
51 rm -rf ri/String
52 rm -f ri/Net/cdesc-Net.yaml
53 rm -f ri/created.rid
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{ruby_ridir},%{ruby_rdocdir}}
58 cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
59 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
60 cp -a rdoc $RPM_BUILD_ROOT%{ruby_rdocdir}/%{name}-%{version}
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc CHANGELOG.rdoc README.rdoc THANKS.rdoc
68 # XXX?
69 %dir %{ruby_rubylibdir}/net
70 %{ruby_rubylibdir}/net/._ssh.rb
71 %{ruby_rubylibdir}/net/ssh.rb
72 %{ruby_rubylibdir}/net/ssh
73
74 %files rdoc
75 %defattr(644,root,root,755)
76 %{ruby_rdocdir}/%{name}-%{version}
77 # XXX ?
78 %dir %{ruby_ridir}/Net
79 %{ruby_ridir}/Net/SSH
This page took 0.071622 seconds and 3 git commands to generate.