]> git.pld-linux.org Git - packages/ruby-net-ssh.git/blob - ruby-net-ssh.spec
5621238c0fb062e23750df3bdd21789212b0da17
[packages/ruby-net-ssh.git] / ruby-net-ssh.spec
1 # TODO:
2 # - what to do with net subdir?
3 %define pkgname net-ssh
4 Summary:        Net::SSH - a pure-Ruby implementation of the SSH2 client protocol
5 Summary(pl.UTF-8):      Net::SSH - implementacja protokołu klienckiego SSH2 w czystym Rubym
6 Name:           ruby-%{pkgname}
7 Version:        2.0.20
8 Release:        3
9 License:        Ruby License
10 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
11 # Source0-md5:  68fbaa033678be355fb93422d6062f79
12 Group:          Development/Languages
13 URL:            http://github.com/net-ssh/net-ssh
14 BuildRequires:  rpmbuild(macros) >= 1.484
15 BuildRequires:  ruby >= 1:1.8.6
16 BuildRequires:  ruby-modules
17 %{?ruby_mod_ver_requires_eq}
18 Provides:       ruby-Net-SSH
19 Obsoletes:      ruby-Net-SSH
20 #BuildArch:     noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 # nothing to be placed there. we're not noarch only because of ruby packaging
24 %define         _enable_debug_packages  0
25
26 %description
27 Net::SSH is a pure-Ruby implementation of the SSH2 client protocol.
28
29 %description -l pl.UTF-8
30 Net::SSH to implementacja protokołu klienckiego SSH2 w czystym Rubym.
31
32 %package rdoc
33 Summary:        HTML documentation for %{pkgname}
34 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla %{pkgname}
35 Group:          Documentation
36 Requires:       ruby >= 1:1.8.7-4
37
38 %description rdoc
39 HTML documentation for %{pkgname}.
40
41 %description rdoc -l pl.UTF-8
42 Dokumentacja w formacie HTML dla %{pkgname}.
43
44 %package ri
45 Summary:        ri documentation for %{pkgname}
46 Summary(pl.UTF-8):      Dokumentacja w formacie ri dla %{pkgname}
47 Group:          Documentation
48 Requires:       ruby
49
50 %description ri
51 ri documentation for %{pkgname}.
52
53 %description ri -l pl.UTF-8
54 Dokumentacji w formacie ri dla %{pkgname}.
55
56 %prep
57 %setup -q -c
58 %{__tar} xf %{SOURCE0} -O data.tar.gz | %{__tar} xz
59 find -newer README.rdoc -o -print | xargs touch --reference %{SOURCE0}
60
61 %build
62 rdoc --ri --op ri lib
63 rdoc --op rdoc lib
64 rm -r ri/{OpenSSL,String}
65 rm ri/created.rid
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 install -d $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{ruby_ridir},%{ruby_rdocdir}}
70
71 cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
72 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
73 cp -a rdoc $RPM_BUILD_ROOT%{ruby_rdocdir}/%{name}-%{version}
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc CHANGELOG.rdoc README.rdoc THANKS.rdoc
81 # XXX?
82 %dir %{ruby_rubylibdir}/net
83 %{ruby_rubylibdir}/net/ssh.rb
84 %{ruby_rubylibdir}/net/ssh
85
86 %files rdoc
87 %defattr(644,root,root,755)
88 %{ruby_rdocdir}/%{name}-%{version}
89
90 %files ri
91 %defattr(644,root,root,755)
92 # XXX?
93 %dir %{ruby_ridir}/Net
94 %{ruby_ridir}/Net/SSH
This page took 0.092781 seconds and 3 git commands to generate.