]> git.pld-linux.org Git - packages/ruby-mustache.git/blob - ruby-mustache.spec
- release 2 (by relup.sh)
[packages/ruby-mustache.git] / ruby-mustache.spec
1 %define pkgname mustache
2 Summary:        Logic-less templates
3 Summary(pl.UTF-8):      Szablony bez logiki
4 Name:           ruby-%{pkgname}
5 Version:        1.1.1
6 Release:        2
7 License:        MIT
8 #Source0Download: https://github.com/mustache/mustache/releases
9 Source0:        https://github.com/mustache/mustache/archive/v%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  73be40dd1b7a1fefe06dbf94845aac01
11 Group:          Development/Languages
12 URL:            http://mustache.github.io/
13 BuildRequires:  rpm-rubyprov
14 BuildRequires:  rpmbuild(macros) >= 1.665
15 BuildRequires:  ruby >= 1:2.0
16 BuildRequires:  ruby-rdoc >= 4.1
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Inspired by ctemplate and et, Mustache is a framework-agnostic way to
22 render logic-free views.
23
24 As ctemplates says, "It emphasizes separating logic from presentation:
25 it is impossible to embed application logic in this template
26 language."
27
28 %description -l pl.UTF-8
29 Mustache to zainspirowany przez ctemplate oraz et, niezależny od
30 szkieletu sposób renderowania widoków bez logiki.
31
32 Podobnie jak ctemplate, "podkreśla oddzielenie logiki od prezentacji;
33 niemożliwe jest osadzenie logiki aplikacji w tym języku szablonów".
34
35 %package -n mustache
36 Summary:        Logic-less templates processor
37 Summary(pl.UTF-8):      Procesor szablonów bez logiki
38 Group:          Applications/Publishing
39 Requires:       %{name} = %{version}-%{release}
40
41 %description -n mustache
42 Inspired by ctemplate and et, Mustache is a framework-agnostic way to
43 render logic-free views.
44
45 As ctemplates says, "It emphasizes separating logic from presentation:
46 it is impossible to embed application logic in this template
47 language."
48
49 %description -n mustache -l pl.UTF-8
50 Mustache to zainspirowany przez ctemplate oraz et, niezależny od
51 szkieletu sposób renderowania widoków bez logiki.
52
53 Podobnie jak ctemplate, "podkreśla oddzielenie logiki od prezentacji;
54 niemożliwe jest osadzenie logiki aplikacji w tym języku szablonów".
55
56 %package rdoc
57 Summary:        HTML documentation for %{pkgname}
58 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla pakietu %{pkgname}
59 Group:          Documentation
60 Requires:       ruby >= 1:2.0
61
62 %description rdoc
63 HTML documentation for %{pkgname}.
64
65 %description rdoc -l pl.UTF-8
66 Dokumentacja w formacie HTML dla pakietu %{pkgname}.
67
68 %package ri
69 Summary:        ri documentation for %{pkgname}
70 Summary(pl.UTF-8):      Dokumentacja w formacie ri dla pakietu %{pkgname}
71 Group:          Documentation
72 Requires:       ruby >= 1:2.0
73
74 %description ri
75 ri documentation for %{pkgname}.
76
77 %description ri -l pl.UTF-8
78 Dokumentacji w formacie ri dla pakietu %{pkgname}.
79
80 %prep
81 %setup -q -n mustache-%{version}
82
83 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
84
85 %build
86 # make gemspec self-contained
87 ruby -r rubygems -e 'spec = eval(File.read("%{pkgname}.gemspec"))
88         File.open("%{pkgname}-%{version}.gemspec", "w") do |file|
89         file.puts spec.to_ruby_for_cache
90 end'
91
92 rdoc --ri --op ri lib
93 rdoc --op rdoc lib
94 %{__rm} ri/created.rid
95 %{__rm} ri/cache.ri
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir},%{_bindir},%{_mandir}/man{1,5},%{ruby_ridir},%{ruby_rdocdir}}
100
101 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
102 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
103 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
104 cp -a rdoc $RPM_BUILD_ROOT%{ruby_rdocdir}/%{name}-%{version}
105 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
106
107 install -d $RPM_BUILD_ROOT
108 cp -a man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
109 cp -a man/*.5 $RPM_BUILD_ROOT%{_mandir}/man5
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %files
115 %defattr(644,root,root,755)
116 %doc HISTORY.md LICENSE README.md
117 %{ruby_vendorlibdir}/mustache.rb
118 %{ruby_vendorlibdir}/mustache
119 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
120
121 %files -n mustache
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{_bindir}/mustache
124 %{_mandir}/man1/mustache.1*
125 %{_mandir}/man5/mustache.5*
126
127 %files rdoc
128 %defattr(644,root,root,755)
129 %{ruby_rdocdir}/%{name}-%{version}
130
131 %files ri
132 %defattr(644,root,root,755)
133 %{ruby_ridir}/Mustache
This page took 0.081182 seconds and 3 git commands to generate.