]> git.pld-linux.org Git - packages/ruby-mixlib-log.git/blob - ruby-mixlib-log.spec
- release 4 (by relup.sh)
[packages/ruby-mixlib-log.git] / ruby-mixlib-log.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 %define         pkgname mixlib-log
6 Summary:        Ruby mix-in for log functionality
7 Name:           ruby-%{pkgname}
8 Version:        1.6.0
9 Release:        4
10 License:        Apache v2.0
11 Group:          Development/Languages
12 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
13 # Source0-md5:  98bafe9409a72fd24782d77794b5adf5
14 URL:            http://github.com/opscode/mixlib-log
15 BuildRequires:  rpm-rubyprov
16 BuildRequires:  rpmbuild(macros) >= 1.665
17 %if %{with tests}
18 BuildRequires:  ruby-cucumber
19 BuildRequires:  ruby-rake
20 BuildRequires:  ruby-rspec < 3
21 BuildRequires:  ruby-rspec >= 2.10
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 A gem that provides a simple mix-in for log functionality.
28
29 %package doc
30 Summary:        Documentation for %{name}
31 Group:          Documentation
32 Requires:       %{name} = %{version}-%{release}
33
34 %description doc
35 This package contains documentation for %{name}.
36
37 %prep
38 %setup -q
39
40 %build
41 %__gem_helper spec
42
43 %if %{with tests}
44 # need RSpec2
45 rspec
46 %endif
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir}}
51 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
52 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc README.rdoc NOTICE
60 %{ruby_vendorlibdir}/mixlib/log.rb
61 %{ruby_vendorlibdir}/mixlib/log
62 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
63
64 # FIXME, who owns the dir?
65 %dir %{ruby_vendorlibdir}/mixlib
66
67 %if 0
68 %files doc
69 %defattr(644,root,root,755)
70 %endif
This page took 0.149522 seconds and 3 git commands to generate.