]> git.pld-linux.org Git - packages/ruby-ldap.git/blob - ruby-ldap.spec
dde3a01bfef7572992d911d0781061d159b0942b
[packages/ruby-ldap.git] / ruby-ldap.spec
1 %define pkgname ldap
2 Summary:        LDAP API (RFC1823) library module for Ruby
3 Summary(pl.UTF-8):      Moduł języka Ruby dostępu do bibliotek API LDAP (RFC1823)
4 Name:           ruby-%{pkgname}
5 Version:        0.9.16
6 Release:        2
7 License:        Redistributable
8 Group:          Development/Libraries
9 Source0:        http://rubygems.org/downloads/%{name}-%{version}.gem
10 # Source0-md5:  5987d115aac49343b29240d291164f7a
11 URL:            http://github.com/alexey-chebotar/ruby-ldap
12 BuildRequires:  openldap-devel >= 2.4.6
13 BuildRequires:  openssl-devel
14 BuildRequires:  rpm-rubyprov
15 BuildRequires:  rpmbuild(macros) >= 1.665
16 BuildRequires:  ruby >= 1:1.8.6
17 BuildRequires:  ruby-devel
18 BuildRequires:  ruby-modules
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Ruby/LDAP is an extension module for Ruby. It provides the interface
23 to some LDAP libraries (for example, OpenLDAP, UMich LDAP, Netscape
24 SDK and ActiveDirectory). The common API for application development
25 is described in RFC1823 and most libraries comply with it. Ruby/LDAP
26 supports those libraries.
27
28 %description -l pl.UTF-8
29 Ruby/LDAP jest modułem rozszerzającym dla języka Ruby. Dostarcza on
30 interfejs do niektórych bibliotek LDAP (np. OpenLDAP, Netscape SDK i
31 ActiveDirectory). Wspólne API dla rozwoju aplikacji jest opisane w
32 RFC1823 i większość bibliotek go przestrzega. Ruby/LDAP wspiera te
33 biblioteki.
34
35 %package rdoc
36 Summary:        HTML documentation for %{name}
37 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla %{name}
38 Group:          Documentation
39 Requires:       ruby >= 1:1.8.7-4
40
41 %description rdoc
42 HTML documentation for %{name}.
43
44 %description rdoc -l pl.UTF-8
45 Dokumentacja w formacie HTML dla %{name}.
46
47 %package ri
48 Summary:        ri documentation for %{name}
49 Summary(pl.UTF-8):      Dokumentacja w formacie ri dla %{name}
50 Group:          Documentation
51 Requires:       ruby
52
53 %description ri
54 ri documentation for %{name}.
55
56 %description ri -l pl.UTF-8
57 Dokumentacji w formacie ri dla %{name}.
58
59 %prep
60 %setup -q -n %{pkgname}-%{version}
61
62 %build
63 ruby extconf.rb \
64         --vendor \
65         --with-openldap2
66 %{__make}
67
68 rdoc --ri --op ri lib
69 rdoc --op rdoc lib
70 rm ri/created.rid
71 rm ri/cache.ri
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir}/%{pkgname},%{ruby_ridir},%{ruby_rdocdir}}
76
77 %{__make} install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
81 cp -a rdoc $RPM_BUILD_ROOT%{ruby_rdocdir}/%{name}-%{version}
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %doc ChangeLog FAQ NOTES README TODO test
89 %attr(755,root,root) %{ruby_vendorarchdir}/ldap.so
90 %{ruby_vendorlibdir}/ldap
91
92 %files rdoc
93 %defattr(644,root,root,755)
94 %{ruby_rdocdir}/%{name}-%{version}
95
96 %files ri
97 %defattr(644,root,root,755)
98 %{ruby_ridir}/LDAP
This page took 0.043286 seconds and 2 git commands to generate.