]> git.pld-linux.org Git - packages/ruby-i18n.git/blob - ruby-i18n.spec
544a7285d567f49b763ff8330106925b5ffb1076
[packages/ruby-i18n.git] / ruby-i18n.spec
1 %define pkgname i18n
2 Summary:        Add Internationalization support to your Ruby application
3 Name:           ruby-%{pkgname}
4 Version:        0.6.0
5 Release:        1
6 License:        MIT/Ruby License
7 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
8 # Source0-md5:  fb94282dab8aadb7de15db134f8133ff
9 URL:            http://rails-i18n.org/
10 Group:          Development/Languages
11 BuildRequires:  rpmbuild(macros) >= 1.484
12 BuildRequires:  ruby >= 1:1.8.6
13 BuildRequires:  ruby-modules
14 %{?ruby_mod_ver_requires_eq}
15 #BuildArch:     noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 # nothing to be placed there. we're not noarch only because of ruby packaging
19 %define         _enable_debug_packages  0
20
21 %description
22 Add Internationalization support to your Ruby application.
23
24 %package rdoc
25 Summary:        HTML documentation for %{pkgname}
26 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla %{pkgname}
27 Group:          Documentation
28 Requires:       ruby >= 1:1.8.7-4
29
30 %description rdoc
31 HTML documentation for %{pkgname}.
32
33 %description rdoc -l pl.UTF-8
34 Dokumentacja w formacie HTML dla %{pkgname}.
35
36 %package ri
37 Summary:        ri documentation for %{pkgname}
38 Summary(pl.UTF-8):      Dokumentacja w formacie ri dla %{pkgname}
39 Group:          Documentation
40 Requires:       ruby
41
42 %description ri
43 ri documentation for %{pkgname}.
44
45 %description ri -l pl.UTF-8
46 Dokumentacji w formacie ri dla %{pkgname}.
47
48 %prep
49 %setup -q -c
50 %{__tar} xf %{SOURCE0} -O data.tar.gz | %{__tar} xz
51 find -newer README.textile -o -print | xargs touch --reference %{SOURCE0}
52
53 %build
54 rdoc --ri --op ri lib
55 rdoc --op rdoc lib
56 rm -r ri/{Hash,KeyError,String}
57 rm ri/created.rid
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 install -d $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{ruby_ridir},%{ruby_rdocdir}}
62
63 cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
64 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
65 cp -a rdoc $RPM_BUILD_ROOT%{ruby_rdocdir}/%{name}-%{version}
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc CHANGELOG.textile README.textile
73 %{ruby_rubylibdir}/%{pkgname}.rb
74 %{ruby_rubylibdir}/%{pkgname}
75
76 %files rdoc
77 %defattr(644,root,root,755)
78 %{ruby_rdocdir}/%{name}-%{version}
79
80 %files ri
81 %defattr(644,root,root,755)
82 %{ruby_ridir}/I18n
This page took 0.047598 seconds and 2 git commands to generate.