]> git.pld-linux.org Git - packages/ruby-gnome2.git/blob - ruby-gnome2.spec
- don't try to install rpms at build time
[packages/ruby-gnome2.git] / ruby-gnome2.spec
1 # TODO: update ri subpackage files
2 #
3 # Conditional build:
4 %bcond_without  gtk3            # GTK+ 3.x based packages too
5 %bcond_without  doc                     # don't build ri/rdoc
6 %bcond_without  gtksourceview3  # GKTSourceView 3.x binding
7 %bcond_without  vte3            # VTE 3.x binding
8
9 %if %{without gtk3}
10 %undefine       with_vte3
11 %endif
12 Summary:        GNOME 2 libraries for Ruby
13 Summary(pl.UTF-8):      Biblioteki GNOME 2 dla języka Ruby
14 Name:           ruby-gnome2
15 Version:        3.1.9
16 Release:        1
17 License:        LGPL v2.1
18 Group:          Development/Languages
19 Source0:        http://downloads.sourceforge.net/ruby-gnome2/%{name}-all-%{version}.tar.gz
20 # Source0-md5:  670bfe3d7606ac39770c2e6123dbb0b6
21 Patch0:         no-native-package-install.patch
22 Patch1:         missing-gem-import.patch
23 URL:            http://ruby-gnome2.sourceforge.jp/
24 BuildRequires:  atk-devel >= 1:1.12.0
25 BuildRequires:  cairo-devel >= 1.10.0
26 BuildRequires:  cairo-gobject-devel >= 1.12.10
27 BuildRequires:  clutter-devel
28 BuildRequires:  clutter-gst-devel
29 BuildRequires:  clutter-gtk-devel
30 BuildRequires:  gdk-pixbuf2-devel >= 2
31 BuildRequires:  glib2-devel >= 1:2.16.0
32 BuildRequires:  gobject-introspection-devel >= 1.35.4
33 BuildRequires:  gstreamer-devel >= 0.10.35
34 BuildRequires:  gtk+2-devel >= 2:2.12.0
35 %{?with_gtk3:BuildRequires:     gtk+3-devel >= 3.4.2}
36 BuildRequires:  gtksourceview2-devel >= 2
37 BuildRequires:  libgsf-devel
38 BuildRequires:  librsvg-devel >= 2.8
39 BuildRequires:  pango-devel >= 1:1.14.0
40 BuildRequires:  pkgconfig
41 BuildRequires:  poppler-glib-devel >= 0.12.0
42 BuildRequires:  rpm-rubyprov
43 BuildRequires:  rpmbuild(macros) >= 1.277
44 BuildRequires:  ruby-devel >= 1.9
45 %{?with_gtk3:BuildRequires:     ruby-devel >= 1.9.2}
46 BuildRequires:  ruby-pkg-config
47 BuildRequires:  ruby-rcairo-devel
48 BuildRequires:  ruby-rubygems
49 BuildRequires:  sed >= 4.0
50 BuildRequires:  vte0-devel >= 0.12.1
51 %{?with_vte3:BuildRequires:     vte2.90-devel >= 0.32.2}
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 GNOME 2 libraries for Ruby.
56
57 %description -l pl.UTF-8
58 Biblioteki GNOME 2 dla języka Ruby.
59
60 %package -n ruby-glib2
61 Summary:        Ruby/Glib2 - Ruby binding of GLib 2.x
62 Summary(pl.UTF-8):      Ruby/Glib2 - wiązanie języka Ruby do biblioteki GLib 2.x
63 Group:          Development/Languages
64 Requires:       glib2 >= 1:2.16.0
65 Requires:       ruby >= 1.9
66 Obsoletes:      ruby-gnome2
67 Obsoletes:      ruby-goocanvas < 2.2.1
68
69 %description -n ruby-glib2
70 Ruby/Glib2 is a Ruby binding of GLib 2.x.
71
72 %description -n ruby-glib2 -l pl.UTF-8
73 Ruby/Glib2 to wiązanie języka Ruby do biblioteki GLib 2.x.
74
75 %package -n ruby-glib2-devel
76 Summary:        Header files for Ruby/GLib2 library
77 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/GLib2
78 Group:          Development/Libraries
79 Requires:       glib2-devel >= 1:2.16.0
80 Requires:       ruby-devel >= 1.9
81 Requires:       ruby-glib2 = %{version}-%{release}
82 Obsoletes:      ruby-gnome2-devel
83 Obsoletes:      ruby-goocanvas-devel < 2.2.1
84
85 %description -n ruby-glib2-devel
86 Header files for Ruby/GLib2 library.
87
88 %description -n ruby-glib2-devel -l pl.UTF-8
89 Pliki nagłówkowe biblioteki Ruby/GLib2.
90
91 %package -n ruby-gobject-introspection
92 Summary:        Ruby/GObjectIntrospection - Ruby binding of GObject Introspection
93 Summary(pl.UTF-8):      Ruby/GObjectIntrospection - wiązania języka Ruby do biblioteki GObject Introspection
94 Group:          Development/Languages
95 Requires:       gobject-introspection >= 1.35.4
96 Requires:       ruby-glib2 = %{version}-%{release}
97
98 %description -n ruby-gobject-introspection
99 Ruby/GObjectIntrospection is a Ruby binding of GObject Introspection.
100
101 %description -n ruby-gobject-introspection -l pl.UTF-8
102 Ruby/GObjectIntrospection to wiązanie języka Ruby do biblioteki
103 GObject Introspection.
104
105 %package -n ruby-gobject-introspection-devel
106 Summary:        Header files for Ruby/GObjectIntrospection library
107 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/GObjectIntrospection
108 Group:          Development/Languages
109 Requires:       ruby-glib2-devel = %{version}-%{release}
110 Requires:       ruby-gobject-introspection = %{version}-%{release}
111
112 %description -n ruby-gobject-introspection-devel
113 Header files for Ruby/GObjectIntrospection library.
114
115 %description -n ruby-gobject-introspection-devel -l pl.UTF-8
116 Pliki nagłówkowe biblioteki Ruby/GObjectIntrospection.
117
118 %package -n ruby-gio2
119 Summary:        Ruby/GIO2 - Ruby binding of GIO 2.x library
120 Summary(pl.UTF-8):      Ruby/GIO2 - wiązanie języka Ruby do biblioteki GIO 2.x
121 Group:          Development/Languages
122 Requires:       glib2 >= 1:2.16.0
123 Requires:       ruby-gobject-introspection = %{version}-%{release}
124
125 %description -n ruby-gio2
126 Ruby/GIO2 is a Ruby binding of GIO 2.x library.
127
128 %description -n ruby-gio2 -l pl.UTF-8
129 Ruby/GIO2 to wiązanie języka Ruby do biblioteki GIO 2.x.
130
131 %package -n ruby-atk
132 Summary:        Ruby/ATK - Ruby binding of ATK
133 Summary(pl.UTF-8):      Ruby/ATK - wiązanie języka Ruby do biblioteki ATK
134 Group:          Development/Languages
135 Requires:       atk >= 1:1.12.0
136 Requires:       ruby-glib2 = %{version}-%{release}
137 Obsoletes:      ruby-atk-devel
138
139 %description -n ruby-atk
140 Ruby/ATK is a Ruby binding of ATK.
141
142 %description -n ruby-atk -l pl.UTF-8
143 Ruby/ATK to wiązanie języka Ruby do biblioteki ATK.
144
145 %package -n ruby-cairo-gobject
146 Summary:        Ruby/CairoGObject - Ruby binding of cairo-gobject library
147 Summary(pl.UTF-8):      Ruby/CairoGObject - wiązania języka Ruby do biblioteki cairo-gobject
148 Group:          Development/Languages
149 Requires:       cairo-gobject >= 1.12.10
150 Requires:       ruby-glib2 = %{version}-%{release}
151 Requires:       ruby-rcairo
152
153 %description -n ruby-cairo-gobject
154 Ruby/CairoGObject is a Ruby binding of cairo-gobject library.
155
156 %description -n ruby-cairo-gobject -l pl.UTF-8
157 Ruby/CairoGObject to wiązanie języka Ruby do biblioteki cairo-gobject.
158
159 %package -n ruby-pango
160 Summary:        Ruby/Pango - Ruby binding of pango 1.x
161 Summary(pl.UTF-8):      Ruby/Pango - wiązanie języka Ruby do biblioteki pango 1.x
162 Group:          Development/Languages
163 Requires:       cairo >= 1.10.0
164 Requires:       pango >= 1:1.14.0
165 Requires:       ruby-glib2 = %{version}-%{release}
166 Requires:       ruby-rcairo
167
168 %description -n ruby-pango
169 Ruby/Pango is a Ruby binding of pango 1.x.
170
171 %description -n ruby-pango -l pl.UTF-8
172 Ruby/Pango to wiązanie języka Ruby do biblioteki pango 1.x.
173
174 %package -n ruby-pango-devel
175 Summary:        Header files for Ruby/Pango library
176 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/Pango
177 Group:          Development/Libraries
178 Requires:       cairo-devel >= 1.10.0
179 Requires:       pango-devel >= 1:1.14.0
180 Requires:       ruby-glib2-devel = %{version}-%{release}
181 Requires:       ruby-pango = %{version}-%{release}
182
183 %description -n ruby-pango-devel
184 Header files for Ruby/Pango library.
185
186 %description -n ruby-pango-devel -l pl.UTF-8
187 Pliki nagłówkowe biblioteki Ruby/Pango.
188
189 %package -n ruby-gdk_pixbuf2
190 Summary:        Ruby/GdkPixbuf2 - Ruby binding of GdkPixbuf 2.x
191 Summary(pl.UTF-8):      Ruby/GdkPixbuf2 - wiązanie języka Ruby do biblioteki GdkPixbuf 2.x
192 Group:          Development/Languages
193 Requires:       gdk-pixbuf2 >= 2
194 Requires:       ruby-glib2 = %{version}-%{release}
195 Obsoletes:      ruby-gdk_pixbuf2-devel
196
197 %description -n ruby-gdk_pixbuf2
198 Ruby/GdkPixbuf2 is a Ruby binding of GdkPixbuf 2.x.
199
200 %description -n ruby-gdk_pixbuf2 -l pl.UTF-8
201 Ruby/GdkPixbuf2 to wiązanie języka Ruby do biblioteki GdkPixbuf 2.x.
202
203 %package -n ruby-gtk2
204 Summary:        Ruby/GTK2 - Ruby binding of GTK+ 2.x
205 Summary(pl.UTF-8):      Ruby/GTK2 - wiązanie języka Ruby do biblioteki GTK+ 2.x
206 Group:          Development/Languages
207 Requires:       gtk+2 >= 2:2.12.0
208 Requires:       ruby-atk = %{version}-%{release}
209 Requires:       ruby-gdk_pixbuf2 = %{version}-%{release}
210 Requires:       ruby-glib2 = %{version}-%{release}
211 Requires:       ruby-pango = %{version}-%{release}
212
213 %description -n ruby-gtk2
214 Ruby/GTK2 is a Ruby binding of GTK+ 2.x.
215
216 %description -n ruby-gtk2 -l pl.UTF-8
217 Ruby/GTK2 to wiązanie języka Ruby do biblioteki GTK+ 2.x.
218
219 %package -n ruby-gtk2-devel
220 Summary:        Header files for Ruby/GTK2 library
221 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/GTK2
222 Group:          Development/Libraries
223 Requires:       gtk+2-devel >= 2:2.12.0
224 Requires:       ruby-atk-devel = %{version}-%{release}
225 Requires:       ruby-glib2-devel = %{version}-%{release}
226 Requires:       ruby-gtk2 = %{version}-%{release}
227 Requires:       ruby-pango-devel = %{version}-%{release}
228
229 %description -n ruby-gtk2-devel
230 Header files for Ruby/GTK2 library.
231
232 %description -n ruby-gtk2-devel -l pl.UTF-8
233 Pliki nagłówkowe biblioteki Ruby/GTK2.
234
235 %package -n ruby-clutter
236 Summary:        Ruby/Clutter - Ruby binding of Clutter library
237 Summary(pl.UTF-8):      Ruby/Clutter - wiązanie języka Ruby do biblioteki Clutter
238 Group:          Development/Languages
239 Requires:       clutter >= 1.16.4
240 Requires:       ruby-cairo-gobject = %{version}-%{release}
241 Requires:       ruby-gobject-introspection = %{version}-%{release}
242
243 %description -n ruby-clutter
244 Ruby/Clutter is a Ruby binding of Clutter library.
245
246 %description -n ruby-clutter -l pl.UTF-8
247 Ruby/Clutter to wiązanie języka Ruby do biblioteki Clutter.
248
249 %package -n ruby-clutter-gstreamer
250 Summary:        Ruby/ClutterGStreamer - Ruby binding of Clutter-GStreamer library
251 Summary(pl.UTF-8):      Ruby/ClutterGStreamer - wiązanie języka Ruby do biblioteki Clutter-GStreamer
252 Group:          Development/Languages
253 Requires:       clutter-gst >= 2.0.10
254 Requires:       ruby-clutter = %{version}-%{release}
255 Requires:       ruby-gstreamer = %{version}-%{release}
256
257 %description -n ruby-clutter-gstreamer
258 Ruby/ClutterGStreamer is a Ruby binding of Clutter-GStreamer library.
259
260 %description -n ruby-clutter-gstreamer -l pl.UTF-8
261 Ruby/ClutterGStreamer to wiązanie języka Ruby do biblioteki
262 Clutter-GStreamer.
263
264 %package -n ruby-gstreamer
265 Summary:        Ruby/GStreamer - Ruby binding of GStreamer
266 Summary(pl.UTF-8):      Ruby/GStreamer - wiązanie języka Ruby do biblioteki GStreamer
267 Group:          Development/Languages
268 Requires:       gstreamer >= 0.10.35
269 Requires:       gstreamer-plugins-base >= 0.10.35
270 Requires:       ruby-gdk_pixbuf2 = %{version}-%{release}
271 Requires:       ruby-glib2 = %{version}-%{release}
272 Requires:       ruby-pango = %{version}-%{release}
273
274 %description -n ruby-gstreamer
275 Ruby/GStreamer is a Ruby binding of GStreamer.
276
277 %description -n ruby-gstreamer -l pl.UTF-8
278 Ruby/GStreamer to wiązanie języka Ruby do biblioteki GStreamer.
279
280 %package -n ruby-gstreamer-devel
281 Summary:        Header files for Ruby/GStreamer library
282 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/GStreamer
283 Group:          Development/Libraries
284 Requires:       gstreamer-devel >= 0.10.35
285 Requires:       gstreamer-plugins-base-devel >= 0.10.35
286 Requires:       ruby-glib2-devel = %{version}-%{release}
287 Requires:       ruby-pango-devel = %{version}-%{release}
288
289 %description -n ruby-gstreamer-devel
290 Header files for Ruby/GStreamer library.
291
292 %description -n ruby-gstreamer-devel -l pl.UTF-8
293 Pliki nagłówkowe biblioteki Ruby/GStreamer.
294
295 %package -n ruby-gtksourceview2
296 Summary:        Ruby/GtkSourceView2 - Ruby binding of gtksourceview 2.x
297 Summary(pl.UTF-8):      Ruby/GtkSourceView2 - wiązanie języka Ruby do biblioteki gtksourceview 2.x
298 Group:          Development/Languages
299 Requires:       gtksourceview2 >= 2.0.0
300 Requires:       ruby-gtk2 = %{version}-%{release}
301
302 %description -n ruby-gtksourceview2
303 Ruby/GtkSourceView2 is a Ruby binding of gtksourceview 2.x.
304
305 %description -n ruby-gtksourceview2 -l pl.UTF-8
306 Ruby/GtkSourceView2 to wiązanie języka Ruby do biblioteki
307 gtksourceview 2.x.
308
309 %package -n ruby-gtksourceview2-devel
310 Summary:        Header files for Ruby/GtkSourceView2 library
311 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/GtkSourceView2
312 Group:          Development/Libraries
313 Requires:       gtksourceview2-devel >= 2.0.0
314 Requires:       ruby-gtk2-devel = %{version}-%{release}
315 Requires:       ruby-gtksourceview2 = %{version}-%{release}
316
317 %description -n ruby-gtksourceview2-devel
318 Header files for Ruby/GtkSourceView2 library.
319
320 %description -n ruby-gtksourceview2-devel -l pl.UTF-8
321 Pliki nagłówkowe biblioteki Ruby/GtkSourceView2.
322
323 %package -n ruby-poppler
324 Summary:        Ruby/Poppler - Ruby binding of poppler-glib
325 Summary(pl.UTF-8):      Ruby/Poppler - wiązanie języka Ruby do biblioteki poppler-glib
326 Group:          Development/Languages
327 Requires:       poppler-glib >= 0.12.0
328 Requires:       ruby-gdk_pixbuf2 = %{version}-%{release}
329 Requires:       ruby-glib2 = %{version}-%{release}
330 Requires:       ruby-gtk2 = %{version}-%{release}
331
332 %description -n ruby-poppler
333 Ruby/Poppler is a Ruby binding of poppler-glib.
334
335 %description -n ruby-poppler -l pl.UTF-8
336 Ruby/Poppler to wiązanie języka Ruby do biblioteki poppler-glib.
337
338 %package -n ruby-poppler-devel
339 Summary:        Header files for Ruby/Poppler library
340 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/Poppler
341 Group:          Development/Libraries
342 Requires:       poppler-glib-devel >= 0.12.0
343 Requires:       ruby-glib2-devel = %{version}-%{release}
344 Requires:       ruby-gtk2-devel = %{version}-%{release}
345
346 %description -n ruby-poppler-devel
347 Header files for Ruby/Poppler library.
348
349 %description -n ruby-poppler-devel -l pl.UTF-8
350 Pliki nagłówkowe biblioteki Ruby/Poppler.
351
352 %package -n ruby-rsvg2
353 Summary:        Ruby/RSVG - Ruby binding of librsvg
354 Summary(pl.UTF-8):      Ruby/RSVG - wiązanie języka Ruby do biblioteki librsvg
355 Group:          Development/Languages
356 Requires:       librsvg >= 2.8
357 Requires:       ruby-gdk_pixbuf2 = %{version}-%{release}
358 Requires:       ruby-glib2 = %{version}-%{release}
359 Requires:       ruby-rcairo
360 Obsoletes:      ruby-rsvg2-devel
361
362 %description -n ruby-rsvg2
363 Ruby/RSVG is a Ruby binding of librsvg.
364
365 %description -n ruby-rsvg2 -l pl.UTF-8
366 Ruby/RSVG to wiązanie języka Ruby do biblioteki librsvg.
367
368 %package -n ruby-vte
369 Summary:        Ruby/VTE - Ruby binding of VTE
370 Summary(pl.UTF-8):      Ruby/VTE - wiązanie języka Ruby do biblioteki VTE
371 Group:          Development/Languages
372 Requires:       ruby-gtk2 = %{version}-%{release}
373 Requires:       vte0 >= 0.12.1
374
375 %description -n ruby-vte
376 Ruby/VTE is a Ruby binding of VTE.
377
378 %description -n ruby-vte -l pl.UTF-8
379 Ruby/VTE to wiązanie języka Ruby do biblioteki VTE.
380
381 %package -n ruby-vte-devel
382 Summary:        Header files for Ruby/VTE library
383 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/VTE
384 Group:          Development/Libraries
385 Requires:       ruby-gtk2-devel = %{version}-%{release}
386 Requires:       ruby-vte = %{version}-%{release}
387 Requires:       vte0-devel >= 0.12.1
388
389 %description -n ruby-vte-devel
390 Header files for Ruby/VTE library.
391
392 %description -n ruby-vte-devel -l pl.UTF-8
393 Pliki nagłówkowe biblioteki Ruby/VTE.
394
395 %package -n ruby-webkit-gtk2
396 Summary:        Ruby/WebKitGTK2 - Ruby binding of WebKitGTK+ (GTK+ 2.x based) library
397 Summary(pl.UTF-8):      Ruby/WebKitGTK2 - wiązanie języka Ruby do biblioteki WebKitGTK+ (dla GTK+ 2.x)
398 Group:          Development/Languages
399 Requires:       gtk-webkit >= 2.2.3
400 Requires:       ruby-gobject-introspection = %{version}-%{release}
401 Requires:       ruby-gtk2 = %{version}-%{release}
402
403 %description -n ruby-webkit-gtk2
404 Ruby/WebKitGTK2 is a Ruby binding of WebKitGTK+ library (based on GTK+
405 2.x).
406
407 %description -n ruby-webkit-gtk2 -l pl.UTF-8
408 Ruby/WebKitGTK2 to wiązanie języka Ruby do biblioteki WebKitGTK+
409 (opartej na GTK+ 2.x).
410
411 %package -n ruby-gtk3
412 Summary:        Ruby/GTK3 - Ruby binding of GTK+ 3.x
413 Summary(pl.UTF-8):      Ruby/GTK3 - wiązanie języka Ruby do bibliotek GTK+ 3.x
414 Group:          Development/Languages
415 Requires:       gtk+3 >= 3.4.2
416 Requires:       ruby >= 1.9.2
417 Requires:       ruby-atk = %{version}-%{release}
418 Requires:       ruby-gdk_pixbuf2 = %{version}-%{release}
419 Requires:       ruby-glib2 = %{version}-%{release}
420 Requires:       ruby-pango = %{version}-%{release}
421
422 %description -n ruby-gtk3
423 Ruby/GTK3 is a Ruby binding of GTK+ 3.x.
424
425 %description -n ruby-gtk3 -l pl.UTF-8
426 Ruby/GTK3 to wiązanie języka Ruby do bibliotek GTK+ 3.x.
427
428 %package -n ruby-gtk3-devel
429 Summary:        Header files for Ruby/GTK3 library
430 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/GTK3
431 Group:          Development/Libraries
432 Requires:       gtk+3-devel >= 3.4.2
433 Requires:       ruby-atk-devel = %{version}-%{release}
434 Requires:       ruby-devel >= 1.9.2
435 Requires:       ruby-glib2-devel = %{version}-%{release}
436 Requires:       ruby-gtk3 = %{version}-%{release}
437 Requires:       ruby-pango-devel = %{version}-%{release}
438
439 %description -n ruby-gtk3-devel
440 Header files for Ruby/GTK3 library.
441
442 %description -n ruby-gtk3-devel -l pl.UTF-8
443 Pliki nagłówkowe biblioteki Ruby/GTK3.
444
445 %package -n ruby-clutter-gtk
446 Summary:        Ruby/ClutterGTK - Ruby binding of Clutter-GTK library
447 Summary(pl.UTF-8):      Ruby/ClutterGTK - wiązanie języka Ruby do biblioteki Clutter-GTK
448 Group:          Development/Languages
449 Requires:       clutter-gtk >= 1.4.4
450 Requires:       ruby-clutter = %{version}-%{release}
451 Requires:       ruby-gtk3 = %{version}-%{release}
452
453 %description -n ruby-clutter-gtk
454 Ruby/ClutterGTK is a Ruby binding of Clutter-GTK library.
455
456 %description -n ruby-clutter-gtk -l pl.UTF-8
457 Ruby/ClutterGTK to wiązanie języka Ruby do biblioteki Clutter-GTK.
458
459 %package -n ruby-gtksourceview3
460 Summary:        Ruby/GtkSourceView3 - Ruby binding of gtksourceview 3.x
461 Summary(pl.UTF-8):      Ruby/GtkSourceView3 - wiązanie języka Ruby do biblioteki gtksourceview 3.x
462 Group:          Development/Languages
463 Requires:       gtksourceview3 >= 3.4.2
464 Requires:       ruby-gtk3 = %{version}-%{release}
465 Obsoletes:      ruby-gtksourceview3-devel
466
467 %description -n ruby-gtksourceview3
468 Ruby/GtkSourceView3 is a Ruby binding of gtksourceview 3.x.
469
470 %description -n ruby-gtksourceview3 -l pl.UTF-8
471 Ruby/GtkSourceView3 to wiązanie języka Ruby do biblioteki
472 gtksourceview 3.x.
473
474 %package -n ruby-vte3
475 Summary:        Ruby/VTE3 - Ruby binding of VTE on GTK+ 3.x
476 Summary(pl.UTF-8):      Ruby/VTE3 - wiązanie języka Ruby do biblioteki VTE na GTK+ 3.x
477 Group:          Development/Languages
478 Requires:       ruby-gtk3 = %{version}-%{release}
479 Requires:       vte >= 0.32.2
480 Obsoletes:      ruby-vte3-devel
481
482 %description -n ruby-vte3
483 Ruby/VTE3 is a Ruby binding of VTE on GTK+ 3.x.
484
485 %description -n ruby-vte3 -l pl.UTF-8
486 Ruby/VTE3 to wiązanie języka Ruby do biblioteki VTE opartej na GTK+
487 3.x.
488
489 %package -n ruby-webkit-gtk
490 Summary:        Ruby/WebKitGTK - Ruby binding of WebKitGTK+ (GTK+ 3.x based) library
491 Summary(pl.UTF-8):      Ruby/WebKitGTK - wiązanie języka Ruby do biblioteki WebKitGTK+ (dla GTK+ 3.x)
492 Group:          Development/Languages
493 Requires:       gtk-webkit3 >= 2.2.3
494 Requires:       ruby-gobject-introspection = %{version}-%{release}
495 Requires:       ruby-gtk3 = %{version}-%{release}
496
497 %description -n ruby-webkit-gtk
498 Ruby/WebKitGTK is a Ruby binding of WebKitGTK+ library (based on GTK+
499 3.x).
500
501 %description -n ruby-webkit-gtk -l pl.UTF-8
502 Ruby/WebKitGTK to wiązanie języka Ruby do biblioteki WebKitGTK+
503 (opartej na GTK+ 3.x).
504
505 %package doc-ri
506 Summary:        Ruby-GNOME2 ri documentation
507 Summary(pl.UTF-8):      Dokumentacja dla Ruby-GNOME2 w formacie ri
508 Group:          Documentation
509 Requires:       ruby
510
511 %description doc-ri
512 Ruby-GNOME2 ri documentation.
513
514 %description doc-ri -l pl.UTF-8
515 Dokumentacja dla Ruby-GNOME2 w formacie ri.
516
517 %package doc-html
518 Summary:        Ruby-GNOME2 HTML documentation
519 Summary(pl.UTF-8):      Dokumentacja dla Ruby-GNOME2 w formacie HTML
520 Group:          Documentation
521
522 %description doc-html
523 Ruby-GNOME2 HTML documentation.
524
525 %description doc-html -l pl.UTF-8
526 Dokumentacja dla Ruby-GNOME2 w formacie HTML.
527
528 %package examples
529 Summary:        Ruby-GNOME2 examples
530 Summary(pl.UTF-8):      Przykłady do Ruby-GNOME2
531 Group:          Development/Libraries
532
533 %description examples
534 Ruby-GNOME2 examples.
535
536 %description examples -l pl.UTF-8
537 Przykłady do Ruby-GNOME2.
538
539 %prep
540 %setup -q -n %{name}-all-%{version}
541 %patch0 -p1
542 %patch1 -p1
543 find . -name '*.rb' | xargs sed -i -e '1s,#.*local/bin/ruby,#!%{_bindir}/ruby,'
544
545 cp -p glib2/README.md README.glib2.md
546 cp -p glib2/TODO TODO.glib2
547 cp -p gdk3/README.md README.gdk3.md
548 cp -p gtk3/README.md README.gtk3.md
549
550 %build
551 # echo */extconf.rb | xargs -l1 dirname
552
553 comps="
554         atk
555         cairo-gobject
556         clutter
557         clutter-gstreamer
558         gdk_pixbuf2
559         gio2
560         glib2
561         gobject-introspection
562         gstreamer
563         gtk2
564         gtksourceview2
565         pango
566         poppler
567         rsvg2
568         vte
569         webkit-gtk2
570 %if %{with gtk3}
571         clutter-gdk
572         clutter-gtk
573         gdk3
574         gtk3
575         gtksourceview3
576 %if %{with vte3}
577         vte3
578 %endif
579         webkit-gtk
580         webkit2-gtk
581 %endif
582 "
583
584 ruby extconf.rb \
585         --vendor \
586         --enable-glib-experimental \
587         $comps
588 %{__make}
589
590 %if %{with doc}
591 exclude="-x \.(so|o|gif|png|jpg|ri|xpm|pdf|gresource)$ -x rdoc -x ri -x test"
592 rm -rf rdoc ri
593 rdoc -o rdoc $exclude
594 rdoc --ri -o ri $exclude
595 rm ri/{cache.ri,created.rid}
596 %endif
597
598 %install
599 rm -rf $RPM_BUILD_ROOT
600 install -d $RPM_BUILD_ROOT{%{ruby_archdir},%{ruby_rubylibdir}} \
601         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
602
603 %{__make} install \
604         DESTDIR=$RPM_BUILD_ROOT \
605         RUBYLIBDIR=$RPM_BUILD_ROOT%{ruby_rubylibdir} \
606         sitearchdir=$RPM_BUILD_ROOT%{ruby_archdir} \
607         pkgconfigdir=$RPM_BUILD_ROOT%{_pkgconfigdir} \
608         RUBYARCHDIR=$RPM_BUILD_ROOT%{ruby_archdir}
609
610 # omitted by make install
611 cp -p atk/lib/atk.rb $RPM_BUILD_ROOT%{ruby_rubylibdir}
612 cp -pr clutter/lib/{clutter,clutter.rb} $RPM_BUILD_ROOT%{ruby_rubylibdir}
613 cp -p clutter-gstreamer/lib/clutter-gst.rb $RPM_BUILD_ROOT%{ruby_rubylibdir}
614 cp -p webkit-gtk2/lib/webkit-gtk2.rb $RPM_BUILD_ROOT%{ruby_rubylibdir}
615 cp -pr gdk_pixbuf2/lib/{gdk_pixbuf2,gdk_pixbuf2.rb} $RPM_BUILD_ROOT%{ruby_rubylibdir}
616 cp -pr poppler/lib/{poppler,poppler.rb} $RPM_BUILD_ROOT%{ruby_rubylibdir}
617 cp -pr rsvg2/lib/{rsvg2,rsvg2.rb} $RPM_BUILD_ROOT%{ruby_rubylibdir}
618 %if %{with gtk3}
619 cp -p clutter-gtk/lib/clutter-gtk.rb $RPM_BUILD_ROOT%{ruby_rubylibdir}
620 cp -p webkit-gtk/lib/webkit-gtk.rb $RPM_BUILD_ROOT%{ruby_rubylibdir}
621 cp -pr gdk3/lib/{gdk3,gdk3.rb} $RPM_BUILD_ROOT%{ruby_rubylibdir}
622 cp -pr gtksourceview3/lib/{gtksourceview3,gtksourceview3.rb} $RPM_BUILD_ROOT%{ruby_rubylibdir}
623 %if %{with vte3}
624 cp -pr vte3/lib/{vte3,vte3.rb} $RPM_BUILD_ROOT%{ruby_rubylibdir}
625 %endif
626 %endif
627
628 cp -a clutter/sample \
629         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/clutter
630
631 cp -a clutter-gstreamer/sample \
632         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/clutter-gstreamer
633
634 cp -a gdk_pixbuf2/sample \
635         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/gdk_pixbuf2
636
637 cp -a glib2/sample \
638         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/glib2
639
640 cp -a gstreamer/sample \
641         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/gstreamer
642
643 cp -a gtk2/sample \
644         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/gtk2
645
646 cp -a gtksourceview2/sample \
647         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/gtksourceview2
648
649 cp -a poppler/sample \
650         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/poppler
651
652 cp -a rsvg2/sample \
653         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/rsvg2
654
655 cp -a vte/sample \
656         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/vte
657
658 cp -a webkit-gtk2/sample \
659         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/webkit-gtk2
660
661 %if %{with gtk3}
662 cp -a clutter-gtk/sample \
663         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/clutter-gtk
664
665 cp -a gtk3/sample \
666         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/gtk3
667
668 cp -a webkit-gtk/sample \
669         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/webkit-gtk
670 %endif
671
672 %if %{with doc}
673 install -d $RPM_BUILD_ROOT%{ruby_ridir}
674 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
675 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/{Math,Object,REXML,RbConfig,Test*,page-*}
676 %if %{without gtk3}
677 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/{ClutterGtk*,Goo*,WebKitGtk,WebKitGtkTestUtils,clutter-gtk,gdk3,gtk3,gtksourceview3,webkit-gtk}
678 %endif
679 %if %{without vte3}
680 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/vte3
681 %endif
682 %endif
683
684 %clean
685 rm -rf $RPM_BUILD_ROOT
686
687 %files -n ruby-glib2
688 %defattr(644,root,root,755)
689 %doc AUTHORS NEWS README.md README.glib2.md TODO.glib2
690 %attr(755,root,root) %{ruby_archdir}/glib2.so
691 %{ruby_rubylibdir}/glib-mkenums.rb
692 %{ruby_rubylibdir}/glib2.rb
693 %{ruby_rubylibdir}/gnome2-raketask.rb
694 %dir %{ruby_rubylibdir}/gnome2
695 %{ruby_rubylibdir}/gnome2/rake
696 %{ruby_rubylibdir}/mkmf-gnome2.rb
697 %{ruby_rubylibdir}/glib2
698
699 %files -n ruby-glib2-devel
700 %defattr(644,root,root,755)
701 %{ruby_archdir}/glib-enum-types.h
702 %{ruby_archdir}/rbgcompat.h
703 %{ruby_archdir}/rbglib.h
704 %{ruby_archdir}/rbglib2conversions.h
705 %{ruby_archdir}/rbglibdeprecated.h
706 %{ruby_archdir}/rbgobject.h
707 %{ruby_archdir}/rbgutil.h
708 %{ruby_archdir}/rbgutil_list.h
709 %{ruby_archdir}/rbgutildeprecated.h
710 %{_pkgconfigdir}/ruby-glib2.pc
711
712 %files -n ruby-gobject-introspection
713 %defattr(644,root,root,755)
714 %doc gobject-introspection/README.md
715 %attr(755,root,root) %{ruby_archdir}/gobject_introspection.so
716 %{ruby_rubylibdir}/gi.rb
717 %{ruby_rubylibdir}/gobject-introspection.rb
718 %{ruby_rubylibdir}/gobject-introspection
719
720 %files -n ruby-gobject-introspection-devel
721 %defattr(644,root,root,755)
722 %{ruby_archdir}/rb-gobject-introspection.h
723 %{_pkgconfigdir}/ruby-gobject-introspection.pc
724
725 %files -n ruby-gio2
726 %defattr(644,root,root,755)
727 %doc gio2/README.md
728 %attr(755,root,root) %{ruby_archdir}/gio2.so
729 %{ruby_rubylibdir}/gio2.rb
730 %{ruby_rubylibdir}/gio2
731 %{_pkgconfigdir}/ruby-gio2.pc
732
733 %files -n ruby-atk
734 %defattr(644,root,root,755)
735 %doc atk/README.md
736 %{ruby_rubylibdir}/atk.rb
737
738 %files -n ruby-cairo-gobject
739 %defattr(644,root,root,755)
740 %doc cairo-gobject/README.md
741 %attr(755,root,root) %{ruby_archdir}/cairo_gobject.so
742 %{ruby_rubylibdir}/cairo-gobject.rb
743
744 %files -n ruby-pango
745 %defattr(644,root,root,755)
746 %doc pango/README.md
747 %attr(755,root,root) %{ruby_archdir}/pango.so
748 %{ruby_rubylibdir}/pango
749 %{ruby_rubylibdir}/pango.rb
750
751 %files -n ruby-pango-devel
752 %defattr(644,root,root,755)
753 %{ruby_archdir}/rb-pango-conversions.h
754 %{ruby_archdir}/rb-pango.h
755 %{_pkgconfigdir}/ruby-pango.pc
756
757 %files -n ruby-gdk_pixbuf2
758 %defattr(644,root,root,755)
759 %doc gdk_pixbuf2/README.md
760 %{ruby_rubylibdir}/gdk_pixbuf2
761 %{ruby_rubylibdir}/gdk_pixbuf2.rb
762
763 %files -n ruby-gtk2
764 %defattr(644,root,root,755)
765 %doc gtk2/README
766 %attr(755,root,root) %{ruby_archdir}/gtk2.so
767 %{ruby_rubylibdir}/gtk2.rb
768 %{ruby_rubylibdir}/gtk2
769
770 %files -n ruby-gtk2-devel
771 %defattr(644,root,root,755)
772 %{ruby_archdir}/rbgdk.h
773 %{ruby_archdir}/rbgdkconversions.h
774 %{ruby_archdir}/rbgtk.h
775 %{ruby_archdir}/rbgtkconversions.h
776 %{ruby_archdir}/rbgtkmacros.h
777 %{_pkgconfigdir}/ruby-gtk2.pc
778
779 %files -n ruby-clutter
780 %defattr(644,root,root,755)
781 %doc clutter/README.md
782 %{ruby_rubylibdir}/clutter.rb
783 %{ruby_rubylibdir}/clutter
784
785 %files -n ruby-clutter-gstreamer
786 %defattr(644,root,root,755)
787 %doc clutter-gstreamer/README.md
788 %{ruby_rubylibdir}/clutter-gst.rb
789
790 %files -n ruby-gstreamer
791 %defattr(644,root,root,755)
792 %doc gstreamer/README.md
793 %attr(755,root,root) %{ruby_archdir}/gstreamer.so
794 %{ruby_rubylibdir}/gst.rb
795 %{ruby_rubylibdir}/gst
796 %{ruby_rubylibdir}/gstreamer.rb
797
798 %files -n ruby-gstreamer-devel
799 %defattr(644,root,root,755)
800 %{_pkgconfigdir}/ruby-gstreamer.pc
801
802 %files -n ruby-gtksourceview2
803 %defattr(644,root,root,755)
804 %doc gtksourceview2/README
805 %attr(755,root,root) %{ruby_archdir}/gtksourceview2.so
806 %{ruby_rubylibdir}/gtksourceview2.rb
807
808 %files -n ruby-gtksourceview2-devel
809 %defattr(644,root,root,755)
810 %{_pkgconfigdir}/ruby-gtksourceview2.pc
811
812 %files -n ruby-poppler
813 %defattr(644,root,root,755)
814 %doc poppler/README.md
815 %{ruby_rubylibdir}/poppler
816 %{ruby_rubylibdir}/poppler.rb
817
818 %files -n ruby-rsvg2
819 %defattr(644,root,root,755)
820 %doc rsvg2/README.md
821 %{ruby_rubylibdir}/rsvg2
822 %{ruby_rubylibdir}/rsvg2.rb
823
824 %files -n ruby-vte
825 %defattr(644,root,root,755)
826 %doc vte/README
827 %attr(755,root,root) %{ruby_archdir}/vte.so
828 %{ruby_rubylibdir}/vte.rb
829 %{ruby_rubylibdir}/vte
830
831 %files -n ruby-vte-devel
832 %defattr(644,root,root,755)
833 %{_pkgconfigdir}/ruby-vte.pc
834
835 %files -n ruby-webkit-gtk2
836 %defattr(644,root,root,755)
837 %doc webkit-gtk2/README.md
838 %{ruby_rubylibdir}/webkit-gtk2.rb
839
840 %if %{with gtk3}
841 %files -n ruby-gtk3
842 %defattr(644,root,root,755)
843 %doc README.gdk3.md README.gtk3.md
844 %attr(755,root,root) %{ruby_archdir}/gtk3.so
845 %{ruby_rubylibdir}/gdk3
846 %{ruby_rubylibdir}/gdk3.rb
847 %{ruby_rubylibdir}/gtk3
848 %{ruby_rubylibdir}/gtk3.rb
849
850 %files -n ruby-gtk3-devel
851 %defattr(644,root,root,755)
852 %{_pkgconfigdir}/ruby-gtk3.pc
853
854 %files -n ruby-clutter-gtk
855 %defattr(644,root,root,755)
856 %doc clutter-gtk/README.md
857 %{ruby_rubylibdir}/clutter-gtk.rb
858
859 %if %{with gtksourceview3}
860 %files -n ruby-gtksourceview3
861 %defattr(644,root,root,755)
862 %doc gtksourceview3/README.md
863 %{ruby_rubylibdir}/gtksourceview3.rb
864 %{ruby_rubylibdir}/gtksourceview3
865 %endif
866
867 %if %{with vte3}
868 %files -n ruby-vte3
869 %defattr(644,root,root,755)
870 %doc vte3/README.md
871 %{ruby_rubylibdir}/vte3.rb
872 %{ruby_rubylibdir}/vte3
873 %endif
874
875 %files -n ruby-webkit-gtk
876 %defattr(644,root,root,755)
877 %doc webkit-gtk/README.md
878 %{ruby_rubylibdir}/webkit-gtk.rb
879 %endif
880
881 %if %{with doc}
882 %files doc-html
883 %defattr(644,root,root,755)
884 %doc rdoc/*
885
886 %files doc-ri
887 %defattr(644,root,root,755)
888 %{ruby_ridir}/A
889 %{ruby_ridir}/AlphaDemo
890 %{ruby_ridir}/AssistantRunner
891 %{ruby_ridir}/Atk
892 %{ruby_ridir}/Cairo
893 %{ruby_ridir}/CairoGObject
894 %{ruby_ridir}/Canvas
895 %{ruby_ridir}/Clutter
896 %{ruby_ridir}/ClutterGst
897 %{ruby_ridir}/Demo
898 %{ruby_ridir}/DestWindow
899 %{ruby_ridir}/DraggableWidget
900 %{ruby_ridir}/GLib
901 %{ruby_ridir}/GNOME2
902 %{ruby_ridir}/GObjectIntrospection
903 %{ruby_ridir}/Gdk
904 %{ruby_ridir}/Gesture
905 %{ruby_ridir}/GestureProcessor
906 %{ruby_ridir}/GesturedWidget
907 %{ruby_ridir}/Gio
908 %{ruby_ridir}/Gst
909 %{ruby_ridir}/Gtk
910 %{ruby_ridir}/GtkSource
911 %{ruby_ridir}/Inspector
912 %{ruby_ridir}/Layout
913 %{ruby_ridir}/MultiTerm
914 %{ruby_ridir}/MyButton
915 %{ruby_ridir}/MyButton2
916 %{ruby_ridir}/MyGtkPlug
917 %{ruby_ridir}/MyGtkSocket
918 %{ruby_ridir}/Pager
919 %{ruby_ridir}/Pango
920 %{ruby_ridir}/Pong
921 %{ruby_ridir}/Poppler
922 %{ruby_ridir}/SrcWindow
923 %{ruby_ridir}/StatusIconSample
924 %{ruby_ridir}/VideoApp
925 %{ruby_ridir}/Vte
926 %{ruby_ridir}/WebKitGtk2
927 %{ruby_ridir}/atk
928 %{ruby_ridir}/cairo-gobject
929 %{ruby_ridir}/clutter
930 %{ruby_ridir}/clutter-gstreamer
931 %{ruby_ridir}/gdk_pixbuf2
932 %{ruby_ridir}/gio2
933 %{ruby_ridir}/glib2
934 %{ruby_ridir}/gobject-introspection
935 %{ruby_ridir}/gstreamer
936 %{ruby_ridir}/gtk2
937 %{ruby_ridir}/gtksourceview2
938 %{ruby_ridir}/pango
939 %{ruby_ridir}/poppler
940 %{ruby_ridir}/rsvg2
941 %{ruby_ridir}/vte
942 %{ruby_ridir}/webkit-gtk2
943 %if %{with gtk3}
944 %{ruby_ridir}/ClutterGtk
945 %{ruby_ridir}/WebKitGtk
946 %{ruby_ridir}/clutter-gtk
947 %{ruby_ridir}/gdk3
948 %{ruby_ridir}/gtk3
949 %{ruby_ridir}/gtksourceview3
950 %if %{with vte3}
951 %{ruby_ridir}/vte3
952 %endif
953 %{ruby_ridir}/webkit-gtk
954 %endif
955 %endif
956
957 %files examples
958 %defattr(644,root,root,755)
959 %{_examplesdir}/%{name}-%{version}
This page took 0.14733 seconds and 3 git commands to generate.