]> git.pld-linux.org Git - packages/fpm.git/blob - ruby-fpm.spec
up to 1.0.2
[packages/fpm.git] / ruby-fpm.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define pkgname fpm
6 Summary:        fpm - package building and mangling
7 Name:           ruby-%{pkgname}
8 Version:        1.0.2
9 Release:        1
10 License:        GPL v2+ or Ruby
11 Group:          Development/Languages
12 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
13 # Source0-md5:  d962faaf4e728bea52f3b7d0de3db29e
14 URL:            https://github.com/jordansissel/fpm
15 BuildRequires:  rpm-rubyprov
16 BuildRequires:  rpmbuild(macros) >= 1.665
17 BuildRequires:  sed >= 4.0
18 %if %{with tests}
19 BuildRequires:  ruby-insist < 0.1
20 BuildRequires:  ruby-insist >= 0.0.5
21 BuildRequires:  ruby-minitest
22 BuildRequires:  ruby-pry
23 BuildRequires:  ruby-rspec
24 BuildRequires:  ruby-stud
25 %endif
26 Requires:       ruby-arr-pm < 0.1
27 Requires:       ruby-arr-pm >= 0.0.8
28 Requires:       ruby-backports >= 2.6.2
29 Requires:       ruby-cabin >= 0.6.0
30 Requires:       ruby-childprocess
31 Requires:       ruby-clamp < 1
32 Requires:       ruby-clamp >= 0.6
33 Requires:       ruby-ffi
34 Requires:       ruby-ftw < 0.1
35 Requires:       ruby-ftw >= 0.0.30
36 Requires:       ruby-json >= 1.7.7
37 BuildArch:      noarch
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Convert directories, rpms, python eggs, rubygems, and more to rpms,
42 debs, solaris packages and more. Win at package management without
43 wasting pointless hours debugging bad rpm specs!
44
45 %prep
46 %setup -q -n %{pkgname}-%{version}
47 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
48
49 %build
50 %__gem_helper spec
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir},%{_bindir}}
55 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
56 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
57 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %attr(755,root,root) %{_bindir}/fpm
65 %{ruby_vendorlibdir}/%{pkgname}.rb
66 %{ruby_vendorlibdir}/%{pkgname}
67 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
This page took 0.080498 seconds and 3 git commands to generate.