]> git.pld-linux.org Git - packages/ruby-diff-lcs.git/blob - ruby-diff-lcs.spec
f56aa902ba2dc9b6d6984c627dbf3c18decb4693
[packages/ruby-diff-lcs.git] / ruby-diff-lcs.spec
1 %define pkgname diff-lcs
2 Summary:        a Ruby port of Algorithm::Diff
3 Summary(pl.UTF-8):      Port Algorithm::Diff dla języka Ruby
4 Name:           ruby-%{pkgname}
5 Version:        1.2.5
6 Release:        1
7 License:        GPL v2+ or MIT or Artistic
8 Group:          Development/Libraries
9 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
10 # Source0-md5:  7172cb271324fa944d9fbea5fe1f7344
11 URL:            http://diff-lcs.rubyforge.org/
12 BuildRequires:  rpm-rubyprov
13 BuildRequires:  rpmbuild(macros) >= 1.656
14 %if %{with tests}
15 BuildRequires:  ruby-hoe < 4
16 BuildRequires:  ruby-hoe >= 3.7
17 BuildRequires:  ruby-hoe-bundler < 2
18 BuildRequires:  ruby-hoe-bundler >= 1.2
19 BuildRequires:  ruby-hoe-doofus < 2
20 BuildRequires:  ruby-hoe-doofus >= 1.0
21 BuildRequires:  ruby-hoe-gemspec2 < 2
22 BuildRequires:  ruby-hoe-gemspec2 >= 1.1
23 BuildRequires:  ruby-hoe-git < 2
24 BuildRequires:  ruby-hoe-git >= 1.5
25 BuildRequires:  ruby-hoe-rubygems < 2
26 BuildRequires:  ruby-hoe-rubygems >= 1.0
27 BuildRequires:  ruby-hoe-travis < 2
28 BuildRequires:  ruby-hoe-travis >= 1.2
29 BuildRequires:  ruby-rake < 11
30 BuildRequires:  ruby-rake >= 10.0
31 BuildRequires:  ruby-rdoc < 5
32 BuildRequires:  ruby-rdoc >= 4.0
33 BuildRequires:  ruby-rspec < 3
34 BuildRequires:  ruby-rspec >= 2.0
35 BuildRequires:  ruby-rubyforge >= 2.0.4
36 %endif
37 Provides:       ruby-Diff-LCS
38 Obsoletes:      ruby-Diff-LCS
39 BuildArch:      noarch
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 Diff::LCS is a port of Algorithm::Diff that uses the McIlroy-Hunt
44 longest common subsequence (LCS) algorithm to compute intelligent
45 differences between two sequenced enumerable containers. The
46 implementation is based on Mario I. Wolczko's Smalltalk version (1.2,
47 1993) and Ned Konz's Perl version (Algorithm::Diff).
48
49 %description -l pl.UTF-8
50 Diff::LCS to port Algorithm::Diff używający algorytmu najdłuższego
51 wspólnego podciągu (LCS - longest common subsequence) McIlroya-Hunta
52 do obliczania inteligentnych różnic między dwoma uporządkowanymi
53 kontenerami. Implementacja jest oparta na wersji dla Smalltalka
54 autorstwa Mario I. Wolczko (1.2 z roku 1993) i wersji dla Perla
55 autorstwa Neda Konza (Algorithm::Diff).
56
57 %package rdoc
58 Summary:        HTML documentation for %{pkgname}
59 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla %{pkgname}
60 Group:          Documentation
61 Requires:       ruby >= 1:1.8.7-4
62
63 %description rdoc
64 HTML documentation for %{pkgname}.
65
66 %description rdoc -l pl.UTF-8
67 Dokumentacja w formacie HTML dla %{pkgname}.
68
69 %package ri
70 Summary:        ri documentation for %{pkgname}
71 Summary(pl.UTF-8):      Dokumentacja w formacie ri dla %{pkgname}
72 Group:          Documentation
73 Requires:       ruby
74
75 %description ri
76 ri documentation for %{pkgname}.
77
78 %description ri -l pl.UTF-8
79 Dokumentacji w formacie ri dla %{pkgname}.
80
81 %package -n htmldiff
82 Summary:        Tool to find differences in HTML files
83 Summary(pl.UTF-8):      Narzędzie do znajdowania różnic w plikach HTML
84 Group:          Applications/Text
85 Requires:       ruby-text-format >= 0.64
86
87 %description -n htmldiff
88 Tool to find differences in HTML files.
89
90 %description -n htmldiff -l pl.UTF-8
91 Narzędzie do znajdowania różnic w plikach HTML.
92
93 %package ldiff
94 Summary:        Ruby Diff tool
95 Summary(pl.UTF-8):      Narzędzie Ruby Diff
96 Group:          Applications/Text
97
98 %description ldiff
99 Ruby Diff tool.
100
101 %description ldiff -l pl.UTF-8
102 Narzędzie Ruby Diff.
103
104 %prep
105 %setup -q -n %{pkgname}-%{version}
106 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
107
108 %build
109 rdoc --ri --op ri lib
110 rdoc --op rdoc lib
111 rm -r ri/{Array,String}
112 rm ri/created.rid
113 rm ri/cache.ri
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 install -d $RPM_BUILD_ROOT{%{_bindir},%{ruby_vendorlibdir},%{ruby_ridir},%{ruby_rdocdir}}
118 install -p bin/* $RPM_BUILD_ROOT%{_bindir}
119 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
120 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
121 cp -a rdoc $RPM_BUILD_ROOT%{ruby_rdocdir}/%{name}-%{version}
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %files
127 %defattr(644,root,root,755)
128 %doc README.rdoc History.rdoc License.rdoc
129 %dir %{ruby_vendorlibdir}/diff
130 %{ruby_vendorlibdir}/diff-lcs.rb
131 %{ruby_vendorlibdir}/diff/lcs.rb
132 %{ruby_vendorlibdir}/diff/lcs
133
134 %files rdoc
135 %defattr(644,root,root,755)
136 %{ruby_rdocdir}/%{name}-%{version}
137
138 %files ri
139 %defattr(644,root,root,755)
140 %{ruby_ridir}/Diff
141
142 %files -n htmldiff
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_bindir}/htmldiff
145
146 %files ldiff
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_bindir}/ldiff
This page took 0.029893 seconds and 3 git commands to generate.