]> git.pld-linux.org Git - packages/ruby-diff-lcs.git/blob - ruby-diff-lcs.spec
- rebuild without versioned ruby abi dep
[packages/ruby-diff-lcs.git] / ruby-diff-lcs.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define pkgname diff-lcs
6 Summary:        a Ruby port of Algorithm::Diff
7 Summary(pl.UTF-8):      Port Algorithm::Diff dla języka Ruby
8 Name:           ruby-%{pkgname}
9 Version:        1.2.5
10 Release:        4
11 License:        GPL v2+ or MIT or Artistic
12 Group:          Development/Libraries
13 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
14 # Source0-md5:  7172cb271324fa944d9fbea5fe1f7344
15 URL:            http://diff-lcs.rubyforge.org/
16 BuildRequires:  rpm-rubyprov
17 BuildRequires:  rpmbuild(macros) >= 1.656
18 %if %{with tests}
19 BuildRequires:  ruby-hoe < 4
20 BuildRequires:  ruby-hoe >= 3.7
21 BuildRequires:  ruby-hoe-bundler < 2
22 BuildRequires:  ruby-hoe-bundler >= 1.2
23 BuildRequires:  ruby-hoe-doofus < 2
24 BuildRequires:  ruby-hoe-doofus >= 1.0
25 BuildRequires:  ruby-hoe-gemspec2 < 2
26 BuildRequires:  ruby-hoe-gemspec2 >= 1.1
27 BuildRequires:  ruby-hoe-git < 2
28 BuildRequires:  ruby-hoe-git >= 1.5
29 BuildRequires:  ruby-hoe-rubygems < 2
30 BuildRequires:  ruby-hoe-rubygems >= 1.0
31 BuildRequires:  ruby-hoe-travis < 2
32 BuildRequires:  ruby-hoe-travis >= 1.2
33 BuildRequires:  ruby-rake < 11
34 BuildRequires:  ruby-rake >= 10.0
35 BuildRequires:  ruby-rdoc < 5
36 BuildRequires:  ruby-rdoc >= 4.0
37 BuildRequires:  ruby-rspec < 3
38 BuildRequires:  ruby-rspec >= 2.0
39 BuildRequires:  ruby-rubyforge >= 2.0.4
40 %endif
41 Provides:       ruby-Diff-LCS
42 Obsoletes:      ruby-Diff-LCS
43 BuildArch:      noarch
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 Diff::LCS is a port of Algorithm::Diff that uses the McIlroy-Hunt
48 longest common subsequence (LCS) algorithm to compute intelligent
49 differences between two sequenced enumerable containers. The
50 implementation is based on Mario I. Wolczko's Smalltalk version (1.2,
51 1993) and Ned Konz's Perl version (Algorithm::Diff).
52
53 %description -l pl.UTF-8
54 Diff::LCS to port Algorithm::Diff używający algorytmu najdłuższego
55 wspólnego podciągu (LCS - longest common subsequence) McIlroya-Hunta
56 do obliczania inteligentnych różnic między dwoma uporządkowanymi
57 kontenerami. Implementacja jest oparta na wersji dla Smalltalka
58 autorstwa Mario I. Wolczko (1.2 z roku 1993) i wersji dla Perla
59 autorstwa Neda Konza (Algorithm::Diff).
60
61 %package rdoc
62 Summary:        HTML documentation for %{pkgname}
63 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla %{pkgname}
64 Group:          Documentation
65 Requires:       ruby >= 1:1.8.7-4
66
67 %description rdoc
68 HTML documentation for %{pkgname}.
69
70 %description rdoc -l pl.UTF-8
71 Dokumentacja w formacie HTML dla %{pkgname}.
72
73 %package ri
74 Summary:        ri documentation for %{pkgname}
75 Summary(pl.UTF-8):      Dokumentacja w formacie ri dla %{pkgname}
76 Group:          Documentation
77 Requires:       ruby
78
79 %description ri
80 ri documentation for %{pkgname}.
81
82 %description ri -l pl.UTF-8
83 Dokumentacji w formacie ri dla %{pkgname}.
84
85 %package -n htmldiff
86 Summary:        Tool to find differences in HTML files
87 Summary(pl.UTF-8):      Narzędzie do znajdowania różnic w plikach HTML
88 Group:          Applications/Text
89 Requires:       ruby-text-format >= 0.64
90
91 %description -n htmldiff
92 Tool to find differences in HTML files.
93
94 %description -n htmldiff -l pl.UTF-8
95 Narzędzie do znajdowania różnic w plikach HTML.
96
97 %package ldiff
98 Summary:        Ruby Diff tool
99 Summary(pl.UTF-8):      Narzędzie Ruby Diff
100 Group:          Applications/Text
101
102 %description ldiff
103 Ruby Diff tool.
104
105 %description ldiff -l pl.UTF-8
106 Narzędzie Ruby Diff.
107
108 %prep
109 %setup -q -n %{pkgname}-%{version}
110 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
111
112 %build
113 # write .gemspec
114 %__gem_helper spec
115
116 rdoc --ri --op ri lib
117 rdoc --op rdoc lib
118 rm -r ri/{Array,String}
119 rm ri/created.rid
120 rm ri/cache.ri
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124 install -d $RPM_BUILD_ROOT{%{_bindir},%{ruby_vendorlibdir},%{ruby_specdir},%{ruby_ridir},%{ruby_rdocdir}}
125 install -p bin/* $RPM_BUILD_ROOT%{_bindir}
126 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
127 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
128 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
129
130 cp -a rdoc $RPM_BUILD_ROOT%{ruby_rdocdir}/%{name}-%{version}
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %files
136 %defattr(644,root,root,755)
137 %doc README.rdoc History.rdoc License.rdoc
138 %dir %{ruby_vendorlibdir}/diff
139 %{ruby_vendorlibdir}/diff-lcs.rb
140 %{ruby_vendorlibdir}/diff/lcs.rb
141 %{ruby_vendorlibdir}/diff/lcs
142 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
143
144 %files rdoc
145 %defattr(644,root,root,755)
146 %{ruby_rdocdir}/%{name}-%{version}
147
148 %files ri
149 %defattr(644,root,root,755)
150 %{ruby_ridir}/Diff
151
152 %files -n htmldiff
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_bindir}/htmldiff
155
156 %files ldiff
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_bindir}/ldiff
This page took 0.059497 seconds and 3 git commands to generate.