]> git.pld-linux.org Git - packages/ruby-cucumber.git/blob - ruby-cucumber.spec
adcb62404bd0dd772e25a86bf6c881bc3b4b8093
[packages/ruby-cucumber.git] / ruby-cucumber.spec
1 # TODO
2 # - patch rspec to integrate cucumber rules too in autotest/discover.rb
3 %define pkgname cucumber
4 Summary:        Tool to execute plain-text documents as functional tests
5 Name:           ruby-%{pkgname}
6 Version:        1.2.1
7 Release:        2
8 License:        MIT
9 Group:          Development/Languages
10 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
11 # Source0-md5:  891940571d5ff073da27e415b2b0db31
12 URL:            http://cukes.info/
13 BuildRequires:  rpm-rubyprov
14 BuildRequires:  rpmbuild(macros) >= 1.656
15 BuildRequires:  sed >= 4.0
16 Requires:       ruby-builder >= 2.1.2
17 Requires:       ruby-diff-lcs >= 1.1.3
18 Requires:       ruby-gherkin < 2.12
19 Requires:       ruby-gherkin >= 2.11.0
20 Requires:       ruby-json >= 1.4.6
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Cucumber lets software development teams describe how software should
26 behave in plain text. The text is written in a business-readable
27 domain-specific language and serves as documentation, automated tests
28 and development-aid.
29
30 %prep
31 %setup -q -n %{pkgname}-%{version}
32 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir}}
37 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
38 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
39
40 %{__rm} $RPM_BUILD_ROOT%{ruby_vendorlibdir}/README.rdoc
41
42 # conflicts with ruby-rspec-core-2.13.1
43 %{__rm} $RPM_BUILD_ROOT%{ruby_vendorlibdir}/autotest/discover.rb
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %doc README.md History.md LICENSE
51 %attr(755,root,root) %{_bindir}/cucumber
52 %{ruby_vendorlibdir}/%{pkgname}.rb
53 %{ruby_vendorlibdir}/%{pkgname}
54
55 %{ruby_vendorlibdir}/autotest/cucumber.rb
56 %{ruby_vendorlibdir}/autotest/cucumber_mixin.rb
57 %{ruby_vendorlibdir}/autotest/cucumber_rails.rb
58 %{ruby_vendorlibdir}/autotest/cucumber_rails_rspec.rb
59 %{ruby_vendorlibdir}/autotest/cucumber_rails_rspec2.rb
60 %{ruby_vendorlibdir}/autotest/cucumber_rspec.rb
61 %{ruby_vendorlibdir}/autotest/cucumber_rspec2.rb
This page took 0.070614 seconds and 2 git commands to generate.