]> git.pld-linux.org Git - packages/ruby-compass-core.git/blob - ruby-compass-core.spec
new, version 1.0.1
[packages/ruby-compass-core.git] / ruby-compass-core.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define pkgname compass-core
6 Summary:        The Compass core stylesheet library
7 Name:           ruby-%{pkgname}
8 Version:        1.0.1
9 Release:        1
10 License:        MIT
11 Group:          Development/Languages
12 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
13 # Source0-md5:  c6fdee615aafd1e6db66cf8e349bc95e
14 URL:            http://compass-style.org/reference/compass/
15 BuildRequires:  rpm-rubyprov
16 BuildRequires:  rpmbuild(macros) >= 1.656
17 %if %{with tests}
18 BuildRequires:  ruby-rake
19 %endif
20 Requires:       ruby-multi_json < 2
21 Requires:       ruby-multi_json >= 1.0
22 Requires:       ruby-sass < 3.5
23 Requires:       ruby-sass >= 3.3.0
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 The Compass core stylesheet library and minimum required ruby
29 extensions. This library can be used stand-alone without the compass
30 ruby configuration file or compass command line tools.
31
32 %prep
33 %setup -q -n %{pkgname}-%{version}
34
35 %build
36 # write .gemspec
37 %__gem_helper spec
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir}}
42 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
43 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %{ruby_vendorlibdir}/compass-core.rb
51 %{ruby_vendorlibdir}/compass
52 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
This page took 0.087151 seconds and 3 git commands to generate.