]> git.pld-linux.org Git - packages/ruby-colored.git/blob - ruby-colored.spec
new, version 1.2
[packages/ruby-colored.git] / ruby-colored.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 %define gem_name colored
6 Summary:        Extends ruby string class in order to colorize terminal output
7 Name:           ruby-%{gem_name}
8 Version:        1.2
9 Release:        1
10 License:        MIT
11 Group:          Development/Languages
12 Source0:        http://rubygems.org/gems/%{gem_name}-%{version}.gem
13 # Source0-md5:  1b1a0f16f7c6ab57d1a2d6de53b13c42
14 URL:            http://github.com/defunkt/colored
15 BuildRequires:  rpm-rubyprov
16 BuildRequires:  rpmbuild(macros) >= 1.656
17 %if %{with tests}
18 BuildRequires:  ruby-minitest
19 %endif
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Rubygem extending the ruby string class to include methods that
25 generates colored terminal output.
26
27 %package doc
28 Summary:        Documentation for %{name}
29 Group:          Documentation
30 Requires:       %{name} = %{version}-%{release}
31
32 %description doc
33 Documentation for %{name}
34
35 %prep
36 %setup -q -n %{gem_name}-%{version}
37
38 %build
39 %if %{with tests}
40 testrb -Ilib test/colored_test.rb
41 %endif
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT%{ruby_vendorlibdir}
46 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc README LICENSE
54 %{ruby_vendorlibdir}/colored.rb
This page took 0.066991 seconds and 3 git commands to generate.