]> git.pld-linux.org Git - packages/ruby-arr-pm.git/blob - ruby-arr-pm.spec
up to 0.0.10
[packages/ruby-arr-pm.git] / ruby-arr-pm.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define pkgname arr-pm
6 Summary:        RPM reader and writer library
7 Name:           ruby-%{pkgname}
8 Version:        0.0.10
9 Release:        1
10 License:        Apache v2.0
11 Group:          Development/Languages
12 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
13 # Source0-md5:  6c23ba073b590440c37042a85e0786d3
14 URL:            https://github.com/jordansissel/ruby-arr-pm
15 BuildRequires:  rpm-rubyprov
16 BuildRequires:  rpmbuild(macros) >= 1.665
17 %if %{with tests}
18 BuildRequires:  ruby-flores
19 %endif
20 Requires:       ruby-cabin
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This library allows to you to read and write rpm packages. Written in
26 pure ruby because librpm is not available on all systems
27
28 %prep
29 %setup -q -n %{pkgname}-%{version}
30
31 %build
32 %__gem_helper spec
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir}}
37 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
38 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
39
40 %clean
41 rm -rf $RPM_BUILD_ROOT
42
43 %files
44 %defattr(644,root,root,755)
45 %{ruby_vendorlibdir}/%{pkgname}.rb
46 %{ruby_vendorlibdir}/%{pkgname}
47 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
This page took 0.08479 seconds and 3 git commands to generate.