]> git.pld-linux.org Git - packages/ruby-arel.git/blob - ruby-arel.spec
97e9741180437b462e80d95a70a9d2ee2bce5a9e
[packages/ruby-arel.git] / ruby-arel.spec
1 %define pkgname arel
2 Summary:        Relational Algebra for Ruby
3 Name:           ruby-%{pkgname}
4 Version:        3.0.3
5 Release:        2
6 License:        MIT/Ruby License
7 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
8 # Source0-md5:  c4b1aaea8c39cc58613bebcb6d56af4c
9 Group:          Development/Languages
10 URL:            http://github.com/brynary/arel
11 BuildRequires:  rpmbuild(macros) >= 1.484
12 BuildRequires:  ruby >= 1:1.8.6
13 BuildRequires:  ruby-modules
14 Requires:       ruby-hoe >= 3.7
15 Requires:       ruby-minitest >= 4.7
16 Conflicts:      ruby-hoe >= 4.0
17 Conflicts:      ruby-minitest >= 5.0
18 %{?ruby_mod_ver_requires_eq}
19 #BuildArch:     noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 # nothing to be placed there. we're not noarch only because of ruby packaging
23 %define         _enable_debug_packages  0
24
25 %description
26 Arel is a Relational Algebra for Ruby. It 1) simplifies the generation
27 complex of SQL queries and it 2) adapts to various RDBMS systems.
28 It is intended to be a framework framework; that is, you can build
29 your own ORM with it, focusing on innovative object and collection
30 modeling as opposed to database compatibility and query generation.
31
32 %package rdoc
33 Summary:        HTML documentation for %{pkgname}
34 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla %{pkgname}
35 Group:          Documentation
36 Requires:       ruby >= 1:1.8.7-4
37
38 %description rdoc
39 HTML documentation for %{pkgname}.
40
41 %description rdoc -l pl.UTF-8
42 Dokumentacja w formacie HTML dla %{pkgname}.
43
44 %package ri
45 Summary:        ri documentation for %{pkgname}
46 Summary(pl.UTF-8):      Dokumentacja w formacie ri dla %{pkgname}
47 Group:          Documentation
48 Requires:       ruby
49
50 %description ri
51 ri documentation for %{pkgname}.
52
53 %description ri -l pl.UTF-8
54 Dokumentacji w formacie ri dla %{pkgname}.
55
56 %prep
57 %setup -q -n %{pkgname}-%{version}
58
59 %build
60 # write .gemspec
61 %__gem_helper spec
62
63 rdoc --ri --op ri lib
64 rdoc --op rdoc lib
65 rm ri/created.rid
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 install -d $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{ruby_ridir},%{ruby_rdocdir}}
70
71 cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
72 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
73 cp -a rdoc $RPM_BUILD_ROOT%{ruby_rdocdir}/%{name}-%{version}
74
75 # install gemspec
76 install -d $RPM_BUILD_ROOT%{ruby_specdir}
77 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %doc History.txt README.markdown
85 %{ruby_rubylibdir}/%{pkgname}.rb
86 %{ruby_rubylibdir}/%{pkgname}
87 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
88
89 %files rdoc
90 %defattr(644,root,root,755)
91 %{ruby_rdocdir}/%{name}-%{version}
92
93 %files ri
94 %defattr(644,root,root,755)
95 %{ruby_ridir}/Arel
This page took 0.079253 seconds and 2 git commands to generate.