]> git.pld-linux.org Git - packages/ruby-arel.git/blob - ruby-arel.spec
install to vendor dir; noarch package
[packages/ruby-arel.git] / ruby-arel.spec
1 %define pkgname arel
2 Summary:        Relational Algebra for Ruby
3 Name:           ruby-%{pkgname}
4 Version:        3.0.3
5 Release:        3
6 License:        MIT/Ruby License
7 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
8 # Source0-md5:  c4b1aaea8c39cc58613bebcb6d56af4c
9 Group:          Development/Languages
10 URL:            http://github.com/brynary/arel
11 BuildRequires:  rpm-rubyprov
12 BuildRequires:  rpmbuild(macros) >= 1.665
13 Requires:       ruby-hoe >= 3.7
14 Requires:       ruby-minitest >= 4.7
15 Conflicts:      ruby-hoe >= 4.0
16 Conflicts:      ruby-minitest >= 5.0
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Arel is a Relational Algebra for Ruby. It 1) simplifies the generation
22 complex of SQL queries and it 2) adapts to various RDBMS systems. It
23 is intended to be a framework framework; that is, you can build your
24 own ORM with it, focusing on innovative object and collection modeling
25 as opposed to database compatibility and query generation.
26
27 %package rdoc
28 Summary:        HTML documentation for %{pkgname}
29 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla %{pkgname}
30 Group:          Documentation
31 Requires:       ruby >= 1:1.8.7-4
32
33 %description rdoc
34 HTML documentation for %{pkgname}.
35
36 %description rdoc -l pl.UTF-8
37 Dokumentacja w formacie HTML dla %{pkgname}.
38
39 %package ri
40 Summary:        ri documentation for %{pkgname}
41 Summary(pl.UTF-8):      Dokumentacja w formacie ri dla %{pkgname}
42 Group:          Documentation
43 Requires:       ruby
44
45 %description ri
46 ri documentation for %{pkgname}.
47
48 %description ri -l pl.UTF-8
49 Dokumentacji w formacie ri dla %{pkgname}.
50
51 %prep
52 %setup -q -n %{pkgname}-%{version}
53
54 %build
55 # write .gemspec
56 %__gem_helper spec
57
58 rdoc --ri --op ri lib
59 rdoc --op rdoc lib
60 rm ri/created.rid
61 rm ri/cache.ri
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_ridir},%{ruby_rdocdir}}
66
67 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
68 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
69 cp -a rdoc $RPM_BUILD_ROOT%{ruby_rdocdir}/%{name}-%{version}
70
71 # install gemspec
72 install -d $RPM_BUILD_ROOT%{ruby_specdir}
73 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc History.txt README.markdown
81 %{ruby_vendorlibdir}/%{pkgname}.rb
82 %{ruby_vendorlibdir}/%{pkgname}
83 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
84
85 %files rdoc
86 %defattr(644,root,root,755)
87 %{ruby_rdocdir}/%{name}-%{version}
88
89 %files ri
90 %defattr(644,root,root,755)
91 %{ruby_ridir}/Arel
This page took 0.04918 seconds and 3 git commands to generate.