]> git.pld-linux.org Git - packages/ruby-addressable.git/blob - ruby-addressable.spec
fix location of data dir
[packages/ruby-addressable.git] / ruby-addressable.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define pkgname addressable
6 Summary:        Improved URI/URL Implementation
7 Name:           ruby-%{pkgname}
8 Version:        2.3.5
9 Release:        3
10 License:        Apache v2.0
11 Group:          Development/Languages
12 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
13 # Source0-md5:  6b9a61885c3c95f912eec560f8f2e3eb
14 Patch0:         data-location.patch
15 URL:            http://addressable.rubyforge.org/
16 BuildRequires:  rpm-rubyprov
17 BuildRequires:  rpmbuild(macros) >= 1.656
18 %if %{with tests}
19 BuildRequires:  ruby-launchy >= 0.3.2
20 BuildRequires:  ruby-rake >= 0.7.3
21 BuildRequires:  ruby-rspec >= 2.9.0
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Addressable is a replacement for the URI implementation that is part
28 of Ruby's standard library. It more closely conforms to the relevant
29 RFCs and adds support for IRIs and URI templates.
30
31 %prep
32 %setup -q -n %{pkgname}-%{version}
33 %patch0 -p1
34
35 %build
36 %__gem_helper spec
37
38 %if %{with tests}
39 rspec spec/
40 %endif
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir}}
45 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
46 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
47 cp -a data/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}/%{pkgname}
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc README.md CHANGELOG.md LICENSE.txt
55 %{ruby_vendorlibdir}/%{pkgname}
56 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
This page took 0.059534 seconds and 3 git commands to generate.