]> git.pld-linux.org Git - packages/ruby-addressable.git/blob - ruby-addressable.spec
539982e32d38e9a7917e688a56a7d8dc2fa8aa88
[packages/ruby-addressable.git] / ruby-addressable.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define pkgname addressable
6 Summary:        Improved URI/URL Implementation
7 Name:           ruby-%{pkgname}
8 Version:        2.3.5
9 Release:        2
10 License:        Apache v2.0
11 Group:          Development/Languages
12 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
13 # Source0-md5:  6b9a61885c3c95f912eec560f8f2e3eb
14 URL:            http://addressable.rubyforge.org/
15 BuildRequires:  rpm-rubyprov
16 BuildRequires:  rpmbuild(macros) >= 1.656
17 %if %{with tests}
18 BuildRequires:  ruby-launchy >= 0.3.2
19 BuildRequires:  ruby-rake >= 0.7.3
20 BuildRequires:  ruby-rspec >= 2.9.0
21 %endif
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Addressable is a replacement for the URI implementation that is part
27 of Ruby's standard library. It more closely conforms to the relevant
28 RFCs and adds support for IRIs and URI templates.
29
30 %prep
31 %setup -q -n %{pkgname}-%{version}
32
33 %build
34 %__gem_helper spec
35
36 %if %{with tests}
37 rspec spec/
38 %endif
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir},%{ruby_vendordir}/data}
43 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
44 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
45 cp -a data/* $RPM_BUILD_ROOT%{ruby_vendordir}/data
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc README.md CHANGELOG.md LICENSE.txt
53 %{ruby_vendorlibdir}/%{pkgname}
54 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
55
56 # XXX move %{ruby_vendordir}/data to ruby.spec
57 %dir %{ruby_vendordir}/data
58 %{ruby_vendordir}/data/unicode.data
This page took 0.076154 seconds and 2 git commands to generate.