]> git.pld-linux.org Git - packages/rubberband.git/blob - rubberband.spec
- updated to 1.9.2
[packages/rubberband.git] / rubberband.spec
1 #
2 # Conditional build:
3 %bcond_without  java    # JNI library
4
5 Summary:        An audio time-stretching and pitch-shifting library and utility program
6 Summary(pl.UTF-8):      Biblioteka i narzędzie do rozciągania i harmonizowania dźwięku
7 Name:           rubberband
8 Version:        1.9.2
9 Release:        1
10 License:        GPL v2+
11 Group:          Applications/Sound
12 Source0:        https://breakfastquay.com/files/releases/%{name}-%{version}.tar.bz2
13 # Source0-md5:  fb433216aff9c5e396052ce0f116c11e
14 Patch0:         %{name}-pc.patch
15 URL:            https://www.breakfastquay.com/rubberband/
16 BuildRequires:  fftw3-devel >= 3.0.0
17 %{?with_jni:BuildRequires:      jdk}
18 BuildRequires:  ladspa-devel
19 BuildRequires:  libsamplerate-devel >= 0.1.8
20 BuildRequires:  libsndfile-devel >= 1.0.16
21 BuildRequires:  libstdc++-devel >= 6:5
22 BuildRequires:  meson >= 0.53.0
23 BuildRequires:  ninja >= 1.5
24 BuildRequires:  pkgconfig
25 BuildRequires:  rpmbuild(macros) >= 1.736
26 BuildRequires:  vamp-devel >= 2.9
27 Requires:       %{name}-libs = %{version}-%{release}
28 Requires:       libsndfile >= 1.0.16
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Rubber Band is a library and utility program that permits you to
33 change the tempo and pitch of an audio recording independently of one
34 another.
35
36 %description -l pl.UTF-8
37 Rubber Band to biblioteka i program narzędziowy, który pozwala na
38 zmianę tempa i wysokości tonu nagrywanego dźwięku niezależnie.
39
40 %package libs
41 Summary:        Shared rubberband library
42 Summary(pl.UTF-8):      Biblioteka współdzielona rubberband
43 Group:          Libraries
44 Requires:       libsamplerate >= 0.1.8
45
46 %description libs
47 Shared rubberband library.
48
49 %description libs -l pl.UTF-8
50 Biblioteka współdzielona rubberband.
51
52 %package devel
53 Summary:        Header files for rubberband library
54 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki rubberband
55 Group:          Development/Libraries
56 Requires:       %{name}-libs = %{version}-%{release}
57 Requires:       libsamplerate-devel >= 0.1.8
58
59 %description devel
60 Header files for rubberband library.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe biblioteki rubberband.
64
65 %package static
66 Summary:        Static rubberband library
67 Summary(pl.UTF-8):      Statyczna biblioteka rubberband
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70
71 %description static
72 Static rubberband library.
73
74 %description static -l pl.UTF-8
75 Statyczna biblioteka rubberband.
76
77 %package -n java-rubberband
78 Summary:        Java JNI interface for rubberband
79 Summary(pl.UTF-8):      Interfejs Javy JNI do rubberband
80 Group:          Libraries/Java
81 Requires:       jre
82 Requires:       libsamplerate >= 0.1.8
83
84 %description -n java-rubberband
85 Java JNI interface for rubberband.
86
87 %description -n java-rubberband -l pl.UTF-8
88 Interfejs Javy JNI do rubberband.
89
90 %package -n ladspa-rubberband-plugins
91 Summary:        rubberband LADSPA plugin
92 Summary(pl.UTF-8):      Wtyczka LADSPA rubberband
93 Group:          Applications/Sound
94 Requires:       ladspa-common
95 Requires:       libsamplerate >= 0.1.8
96
97 %description -n ladspa-rubberband-plugins
98 rubberband LADSPA plugin.
99
100 %description -n ladspa-rubberband-plugins -l pl.UTF-8
101 Wtyczka LADSPA rubberband.
102
103 %package -n vamp-plugins-rubberband
104 Summary:        rubberband Vamp plugin
105 Summary(pl.UTF-8):      Wtyczka Vamp rubberband
106 Group:          Applications/Sound
107 Requires:       libsamplerate >= 0.1.8
108 Requires:       vamp >= 2.9
109
110 %description -n vamp-plugins-rubberband
111 rubberband Vamp plugin.
112
113 %description -n vamp-plugins-rubberband -l pl.UTF-8
114 Wtyczka Vamp rubberband.
115
116 %prep
117 %setup -q
118 %patch0 -p1
119
120 %build
121 %meson build \
122         %{?with_java:-Dextra_include_dirs="%{_jvmdir}/java/include,%{_jvmdir}/java/include/linux"}
123
124 %ninja_build -C build
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128
129 %ninja_install -C build
130
131 %if %{with java}
132 install -d $RPM_BUILD_ROOT%{_javadir}
133 cp -p build/rubberband.jar $RPM_BUILD_ROOT%{_javadir}
134 %endif
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post   libs -p /sbin/ldconfig
140 %postun libs -p /sbin/ldconfig
141
142 %post   -n java-rubberband -p /sbin/ldconfig
143 %postun -n java-rubberband -p /sbin/ldconfig
144
145 %files
146 %defattr(644,root,root,755)
147 %doc CHANGELOG README.md
148 %attr(755,root,root) %{_bindir}/rubberband
149
150 %files libs
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_libdir}/librubberband.so.*.*.*
153 %attr(755,root,root) %ghost %{_libdir}/librubberband.so.2
154
155 %files devel
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_libdir}/librubberband.so
158 %{_includedir}/rubberband
159 %{_pkgconfigdir}/rubberband.pc
160
161 %files static
162 %defattr(644,root,root,755)
163 %{_libdir}/librubberband.a
164
165 %if %{with java}
166 %files -n java-rubberband
167 %defattr(644,root,root,755)
168 %attr(755,root,root) %{_libdir}/librubberband-jni.so
169 %{_javadir}/rubberband.jar
170 %endif
171
172 %files -n ladspa-rubberband-plugins
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_libdir}/ladspa/ladspa-rubberband.so
175 %{_libdir}/ladspa/ladspa-rubberband.cat
176 %{_datadir}/ladspa/rdf/ladspa-rubberband.rdf
177
178 %files -n vamp-plugins-rubberband
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_libdir}/vamp/vamp-rubberband.so
181 %{_libdir}/vamp/vamp-rubberband.cat
This page took 0.077341 seconds and 3 git commands to generate.