]> git.pld-linux.org Git - packages/rtorrent.git/blob - rtorrent.spec
837304d098b2b3353b927e0859d0c1dc5b5aceec
[packages/rtorrent.git] / rtorrent.spec
1 # TODO:
2 # - ip_filter patch is broken (doesn't handle ipv6 addresses. Also causes
3 #   "rtorrent: CommandMap::insert(...) tried to insert an already existing key." error)
4 #
5 # Conditional build:
6 %bcond_without  xmlrpc          # build xmlrpc-c support
7 %bcond_without  colors          # without color version
8 %bcond_without  ipv6            # without IPv6 support
9 #
10 Summary:        rTorrent - a console-based BitTorrent client
11 Summary(pl.UTF-8):      rTorrent - konsolowy klient BitTorrenta
12 Name:           rtorrent
13 # keep stable line, see URL below
14 Version:        0.9.2
15 Release:        3
16 Epoch:          5
17 License:        GPL v2+
18 Group:          Applications/Networking
19 Source0:        http://libtorrent.rakshasa.no/downloads/%{name}-%{version}.tar.gz
20 # Source0-md5:  72c3e9ab859bda7cc8aa96c0b508b09f
21 Source1:        rtorrent-tmux@.service
22 Patch0:         %{name}-colors.patch
23 Patch1:         %{name}-ssl-no-verify.patch
24 Patch2:         %{name}-ip_filter.patch
25 Patch3:         %{name}-build.patch
26 Patch4:         am.patch
27 URL:            http://libtorrent.rakshasa.no/
28 BuildRequires:  autoconf
29 BuildRequires:  automake
30 BuildRequires:  boost-devel >= 1.35.0
31 BuildRequires:  cppunit-devel >= 1.9.6
32 BuildRequires:  curl-devel >= 7.12
33 BuildRequires:  libstdc++-devel
34 BuildRequires:  libtool
35 BuildRequires:  libtorrent-devel = 1:0.13.2
36 BuildRequires:  ncurses-devel
37 BuildRequires:  pkgconfig
38 BuildRequires:  sqlite3-devel
39 %if %{with xmlrpc}
40 BuildRequires:  xmlrpc-c-server-devel >= 1.14.2
41 %endif
42 BuildRequires:  zlib-devel
43 Suggests:       tmux
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 rTorrent is a console-based BitTorrent client. It aims to be a
48 fully-featured and efficient client with the ability to run in the
49 background using screen. It supports fast-resume and session
50 management.
51
52 %description -l pl.UTF-8
53 rTorrent to konsolowy klient BitTorrenta. Jego celem jest być pełnym i
54 wydajnym klientem, z możliwością uruchamiania go w tle przy użyciu
55 screena. Obsługuje szybkie wznawianie i zarządzanie sesjami.
56
57 %prep
58 %setup -q
59 %if %{with colors}
60 %patch0 -p1
61 %endif
62 %patch1 -p1
63 # broke, see TODO
64 #%patch2 -p1
65 %patch3 -p1
66 %patch4 -p1
67
68 %build
69 %{__libtoolize}
70 %{__aclocal} -I scripts
71 %{__autoconf}
72 %{__autoheader}
73 %{__automake}
74 %configure \
75         CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses" \
76         --%{?debug:en}%{!?debug:dis}able-debug \
77         --%{?with_ipv6:en}%{!?with_ipv6:dis}able-ipv6 \
78         --with%{!?with_xmlrpc:out}-xmlrpc-c
79
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{systemdunitdir}}
85
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 install -p doc/rtorrent.1 $RPM_BUILD_ROOT%{_mandir}/man1
90 install -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %files
96 %defattr(644,root,root,755)
97 %doc AUTHORS README doc/rtorrent.rc
98 %attr(755,root,root) %{_bindir}/*
99 %{_mandir}/man1/rtorrent.1*
100 %{systemdunitdir}/*.service
This page took 0.076544 seconds and 2 git commands to generate.