]> git.pld-linux.org Git - packages/rtorrent.git/blob - rtorrent.spec
- up to 0.9.4
[packages/rtorrent.git] / rtorrent.spec
1 # TODO:
2 # - ip_filter patch is broken (doesn't handle ipv6 addresses. Also causes
3 #   "rtorrent: CommandMap::insert(...) tried to insert an already existing key." error)
4 #
5 # Conditional build:
6 %bcond_without  xmlrpc          # build xmlrpc-c support
7 %bcond_without  colors          # without color version
8 %bcond_without  ipv6            # without IPv6 support
9 #
10 Summary:        rTorrent - a console-based BitTorrent client
11 Summary(pl.UTF-8):      rTorrent - konsolowy klient BitTorrenta
12 Name:           rtorrent
13 # keep stable line, see URL below
14 Version:        0.9.4
15 Release:        1
16 Epoch:          5
17 License:        GPL v2+
18 Group:          Applications/Networking
19 Source0:        http://libtorrent.rakshasa.no/downloads/%{name}-%{version}.tar.gz
20 # Source0-md5:  fd9490a2ac67d0fa2a567c6267845876
21 Source1:        rtorrent-tmux@.service
22 Patch0:         %{name}-colors.patch
23 Patch1:         %{name}-ssl-no-verify.patch
24 Patch2:         %{name}-ip_filter.patch
25 Patch3:         %{name}-build.patch
26 URL:            https://github.com/rakshasa/rtorrent/wiki
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  boost-devel >= 1.35.0
30 BuildRequires:  cppunit-devel >= 1.9.6
31 BuildRequires:  curl-devel >= 7.12
32 BuildRequires:  libstdc++-devel
33 BuildRequires:  libtool
34 BuildRequires:  libtorrent-devel = 1:0.13.4
35 BuildRequires:  ncurses-devel
36 BuildRequires:  pkgconfig
37 BuildRequires:  sqlite3-devel
38 %if %{with xmlrpc}
39 BuildRequires:  xmlrpc-c-server-devel >= 1.14.2
40 %endif
41 BuildRequires:  zlib-devel
42 Suggests:       tmux
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 rTorrent is a console-based BitTorrent client. It aims to be a
47 fully-featured and efficient client with the ability to run in the
48 background using screen. It supports fast-resume and session
49 management.
50
51 %description -l pl.UTF-8
52 rTorrent to konsolowy klient BitTorrenta. Jego celem jest być pełnym i
53 wydajnym klientem, z możliwością uruchamiania go w tle przy użyciu
54 screena. Obsługuje szybkie wznawianie i zarządzanie sesjami.
55
56 %prep
57 %setup -q
58 %if %{with colors}
59 %patch0 -p1
60 %endif
61 %patch1 -p1
62 # broke, see TODO
63 #%patch2 -p1
64 %patch3 -p1
65
66 %build
67 %{__libtoolize}
68 %{__aclocal} -I scripts
69 %{__autoconf}
70 %{__autoheader}
71 %{__automake}
72 %configure \
73         CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses" \
74         --%{?debug:en}%{!?debug:dis}able-debug \
75         --%{?with_ipv6:en}%{!?with_ipv6:dis}able-ipv6 \
76         --with%{!?with_xmlrpc:out}-xmlrpc-c
77
78 %{__make}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 install -d $RPM_BUILD_ROOT%{systemdunitdir}
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 install -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files
93 %defattr(644,root,root,755)
94 %doc AUTHORS README doc/rtorrent.rc
95 %attr(755,root,root) %{_bindir}/*
96 %{systemdunitdir}/*.service
This page took 0.058853 seconds and 3 git commands to generate.