]> git.pld-linux.org Git - packages/rtl-sdr.git/blob - rtl-sdr.spec
- initial
[packages/rtl-sdr.git] / rtl-sdr.spec
1 # TODO:
2 # - some sane perm/group in udev rules
3 %define snap    20140111
4 Summary:        SDR utilities for Realtek RTL2832 based DVB-T dongles
5 Name:           rtl-sdr
6 Version:        0
7 Release:        0.%{snap}.1
8 License:        GPL v2+
9 Group:          Applications/Communications
10 URL:            http://sdr.osmocom.org/trac/wiki/rtl-sdr
11 Source0:        %{name}-%{snap}.tar.bz2
12 # Source0-md5:  137b28d8f48a3db8fa0ae7c1fc2a0522
13 BuildRequires:  cmake
14 BuildRequires:  libusb-devel
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 This package can turn your RTL2832 based DVB-T dongle into a SDR
19 receiver.
20
21 %package devel
22 Summary:        Development files for rtl-sdr
23 Group:          Applications/Communications
24 Requires:       %{name} = %{version}-%{release}
25
26 %description devel
27 Development files for rtl-sdr.
28
29 %prep
30 %setup -q -n %{name}
31 rm -rf src/getopt
32
33 %build
34 install -d build
35 cd build
36 %cmake \
37         -DINSTALL_UDEV_RULES=ON \
38         ..
39 %{__make}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 %{__make} -C build install \
45         DESTDIR=$RPM_BUILD_ROOT
46
47 # remove static libs
48 rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %post -p /sbin/ldconfig
54 %postun -p /sbin/ldconfig
55
56 %files
57 %defattr(644,root,root,755)
58 %doc AUTHORS COPYING
59 %attr(755,root,root) %{_bindir}/rtl_*
60 %attr(755,root,root) %{_libdir}/librtlsdr.so.*.*
61 %attr(755,root,root) %ghost %{_libdir}/librtlsdr.so.0
62 %{_sysconfdir}/udev/rules.d/rtl-sdr.rules
63
64 %files devel
65 %defattr(644,root,root,755)
66 %{_includedir}/rtl*.h
67 %attr(755,root,root) %{_libdir}/librtlsdr.so
68 %{_pkgconfigdir}/librtlsdr.pc
This page took 0.088254 seconds and 3 git commands to generate.