]> git.pld-linux.org Git - packages/rpmconf.git/blob - rpmconf.spec
up to 1.1.10
[packages/rpmconf.git] / rpmconf.spec
1 Summary:        Tool to handle rpmnew and rpmsave files
2 Summary(pl.UTF-8):      Narzędzie do obsługi plików rpmnew oraz rpmsave
3 Name:           rpmconf
4 Version:        1.1.10
5 Release:        1
6 License:        GPL v3+
7 Group:          Applications/System
8 Source0:        https://github.com/xsuchy/rpmconf/archive/%{name}-%{version}-1/rpmconf-%{version}.tar.gz
9 # Source0-md5:  dcb8431688726c15ae372f274e2b68a4
10 URL:            https://github.com/xsuchy/rpmconf
11 BuildRequires:  docbook-dtd31-sgml
12 BuildRequires:  docbook-utils
13 BuildRequires:  python3
14 BuildRequires:  python3-modules
15 BuildRequires:  python3-rpm
16 BuildRequires:  rpmbuild(macros) >= 1.714
17 BuildRequires:  sphinx-pdg
18 %if %{with tests}
19 BuildRequires:  python3-pylint
20 BuildRequires:  python3-six
21 %endif
22 Requires:       python3-rpm
23 Requires:       python3-rpmconf = %{version}-%{release}
24 Requires:       which
25 Suggests:       diffuse
26 Suggests:       diffutils
27 Suggests:       kdiff3
28 Suggests:       meld
29 Suggests:       vim-X11
30 Suggests:       vim-enhanced
31 # sdiff
32 Suggests:       diffutils
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 This tool search for .rpmnew, .rpmsave and .rpmorig files and ask you
38 what to do with them: Keep current version, place back old version,
39 watch the diff or merge.
40
41 %package -n python3-rpmconf
42 Summary:        Python interface for %{name}
43 Requires:       pydoc3
44
45 %description -n python3-rpmconf
46 Python interface for %{name}. Mostly useful for developers only.
47
48 %package -n python3-rpmconf-doc
49 Summary:        Documentation of python interface for %{name}
50
51 %description -n python3-rpmconf-doc
52 Documentation generated from code of python3-rpmconf.
53
54 %prep
55 %setup -q -n %{name}-%{name}-%{version}-1
56
57 %{__sed} -i -e 's/__version__ = .*/__version__ = "%{version}"/' rpmconf/rpmconf.py
58 %{__sed} -i -e 's/version = .*,/version = "%{version}",/' setup.py
59 %{__sed} -i -e 's@/usr/bin/ls@/bin/ls@' rpmconf/rpmconf.py
60
61 %build
62 %py3_build
63
64 docbook2man rpmconf.sgml
65 %{__make} -C docs html man
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 install -d $RPM_BUILD_ROOT{%{_mandir}/man{3,8},%{_datadir}/rpmconf}
70
71 %py3_install \
72         --install-scripts %{_sbindir} \
73         --root $RPM_BUILD_ROOT
74
75 cp -p rpmconf.8 $RPM_BUILD_ROOT%{_mandir}/man8/rpmconf.8
76 cp -p docs/build/man/rpmconf.3 $RPM_BUILD_ROOT%{_mandir}/man3/rpmconf.3
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc README.md
84 %attr(755,root,root) %{_sbindir}/rpmconf
85 %dir %{_datadir}/rpmconf
86 %{_mandir}/man8/rpmconf.8*
87
88 %files -n python3-rpmconf
89 %defattr(644,root,root,755)
90 %{py3_sitescriptdir}/rpmconf
91 %{py3_sitescriptdir}/rpmconf-*.egg-info
92 %{_mandir}/man3/rpmconf.3*
93
94 %files -n python3-rpmconf-doc
95 %defattr(644,root,root,755)
96 %doc docs/build/html
This page took 0.078113 seconds and 3 git commands to generate.