]> git.pld-linux.org Git - packages/rpm-getdeps.git/blob - rpm-getdeps.spec
40aabf46020419ac0d5e4b6162b9a76100fe3c5c
[packages/rpm-getdeps.git] / rpm-getdeps.spec
1 # $Revision: 1.4 $, $Date: 2005/09/12 16:46:06 $
2 Summary:        Get dependencies out of RPM spec file
3 Summary(pl):    Pobieranie zależności z pliku spec pakietu RPM
4 Name:           rpm-getdeps
5 Version:        0.0.7
6 Release:        2
7 License:        GPL
8 Vendor:         Joey Hess <joey@kitenet.net>
9 Group:          Applications/System
10 Source0:        http://www-user.tu-chemnitz.de/~ensc/getdeps.c
11 # Source0-md5:  c20a7f6a0ef86461514fbf55092ae434
12 BuildRequires:  rpm-devel
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 Get dependencies out of RPM spec file.
17
18 %description -l pl
19 Pobieranie zależności z pliku spec pakietu RPM.
20
21 %prep
22 %setup -q -c -T
23
24 %build
25 %{__cc} %{rpmcflags} %{rpmldflags} -I/usr/include/rpm -Wall -lrpm -lrpmbuild %{SOURCE0} -o %{name}
26
27 %install
28 rm -rf $RPM_BUILD_ROOT
29 install -d $RPM_BUILD_ROOT%{_bindir}
30
31 install %{name} $RPM_BUILD_ROOT%{_bindir}
32
33 %clean
34 rm -rf $RPM_BUILD_ROOT
35
36 %files
37 %defattr(644,root,root,755)
38 %attr(755,root,root) %{_bindir}/*
39
40 %define date    %(echo `LC_ALL="C" date +"%a %b %d %Y"`)
41 %changelog
42 * %{date} PLD Team <feedback@pld-linux.org>
43 All persons listed below can be reached at <cvs_login>@pld-linux.org
44
45 $Log: rpm-getdeps.spec,v $
46 Revision 1.4  2005/09/12 16:46:06  glen
47 - integer release, 2, STBR
48
49 Revision 1.3  2004/06/17 19:36:58  arekm
50 - rebuild
51
52 Revision 1.2  2004/06/06 15:33:58  qboosh
53 - pl
54
55 Revision 1.1  2004/06/06 09:56:47  arekm
56 - initial pld release
This page took 0.041567 seconds and 2 git commands to generate.