]> git.pld-linux.org Git - packages/robin-map.git/blob - robin-map.spec
b366ba5659d1a7f3e5d01869d6f3d5cba3e0f8de
[packages/robin-map.git] / robin-map.spec
1 Summary:        A C++ implementation of a fast hash map and hash set using robin hood hashing
2 Summary(pl.UTF-8):      Implementacja C++ szybkiej tablicy asocjacyjnej i zbioru wykorzytujących haszowanie robin hood
3 Name:           robin-map
4 Version:        0.6.2
5 Release:        1
6 License:        MIT
7 Group:          Libraries
8 #Source0Download: https://github.com/Tessil/robin-map/releases
9 Source0:        https://github.com/Tessil/robin-map/archive/v%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  2142db273d9bd0a274d076ad5411855d
11 URL:            https://github.com/Tessil/robin-map
12 BuildRequires:  cmake >= 3.1
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 The robin-map library is a C++ implementation of a fast hash map and
17 hash set using open-addressing and linear robin hood hashing with
18 backward shift deletion to resolve collisions.
19
20 %description -l pl.UTF-8
21 Biblioteka robin-map to implementacja C++ szybkiej tablicy
22 asocjacyjnej (mapy) i zbioru wykorzystujących adresowanie otwarte i
23 haszowanie robin hood z usuwaniem przez przesunięcie wstecz przy
24 rozwiązywaniu kolizji.
25
26 %package devel
27 Summary:        Header files for robin-map library
28 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki robin-map
29 Group:          Development/Libraries
30 Requires:       libstdc++-devel >= 6:4.8
31
32 %description devel
33 Header files for robin-map library.
34
35 The robin-map library is a C++ implementation of a fast hash map and
36 hash set using open-addressing and linear robin hood hashing with
37 backward shift deletion to resolve collisions.
38
39 %description devel -l pl.UTF-8
40 Pliki nagłówkowe biblioteki robin-map.
41
42 Biblioteka robin-map to implementacja C++ szybkiej tablicy
43 asocjacyjnej (mapy) i zbioru wykorzystujących adresowanie otwarte i
44 haszowanie robin hood z usuwaniem przez przesunięcie wstecz przy
45 rozwiązywaniu kolizji.
46
47 %prep
48 %setup -q
49
50 %build
51 mkdir -p build
52 cd build
53 %cmake ..
54 %{__make}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} -C build install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files devel
66 %defattr(644,root,root,755)
67 %doc LICENSE README.md
68 %dir %{_includedir}/tsl
69 %{_includedir}/tsl/robin*.h
70 %{_datadir}/cmake/tsl-robin-map
This page took 0.091546 seconds and 2 git commands to generate.