]> git.pld-linux.org Git - packages/rhash.git/blob - rhash.spec
serialize install
[packages/rhash.git] / rhash.spec
1 Summary:        RHash - Recursive Hasher
2 Summary(pl.UTF-8):      RHash - rekursywne obliczanie funkcji skrótu
3 Name:           rhash
4 Version:        1.4.3
5 Release:        1
6 License:        BSD Zero Clause
7 Group:          Applications/File
8 Source0:        https://downloads.sourceforge.net/rhash/%{name}-%{version}-src.tar.gz
9 # Source0-md5:  6de2d29618321e98cbb6138813b99797
10 URL:            https://rhash.sourceforge.net/
11 BuildRequires:  openssl-devel
12 BuildRequires:  sed >= 4.0
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 RHash (Recursive Hasher) is a console utility for computing and
17 verifying hash sums of files. It supports CRC32, MD4, MD5, SHA1,
18 SHA256, SHA512, Tiger, DC++ TTH, BitTorrent BTIH, ED2K, AICH, GOST R
19 34.11-94, RIPEMD-160, HAS-160, EDON-R 256/512, Whirlpool and
20 Snefru-128/256 algorithms. Hash sums are used to ensure and verify
21 integrity of large volumes of data for a long-term storing or
22 transferring.
23
24 Features:
25 - Can calculate Magnet links.
26 - Output in a predefined (SFV, BSD-like) or user defined format.
27 - Ability to process directories recursively.
28 - Updating of existing hash files (adding sums of files missing in the
29   hash file).
30 - Calculates several hash sums in one pass.
31
32 %description -l pl.UTF-8
33 RHash jest konsolowym narzędziem służącym do obliczania różnych
34 funkcji skrótu dla plików. Obsługiwane algorytmy to: CRC32, MD4, MD5,
35 SHA1, SHA256, SHA512, Tiger, DC++ TTH, BitTorrent BTIH, ED2K, AICH,
36 GOST R 34.11-94, RIPEMD-160, HAS-160, EDON-R 256/512, Whirlpool i
37 Snefru-128/256. Funkcje skrótu są wykorzystywane do zapewnienia
38 spójności danych przy długotrwałym składowaniu oraz transmisji.
39
40 Własności:
41 - Potrafi tworzyć linki typu magnet.
42 - Wynik w postaci predefiniowanej (SFV, BSD) lub zdefiniowanej przez
43   użytkownika.
44 - Rekursywne przetwarzanie katalogów.
45 - Aktualizowanie istniejących plików ze skrótami (dodaje skróty plików
46   brakujących w pliku ze skrótami).
47 - Obliczanie wielu funkcji skrótu w jednym przebiegu.
48
49 %package libs
50 Summary:        RHash (Recursive Hasher) library
51 Summary(pl.UTF-8):      RHash - biblioteka funkcji skrótu
52 Group:          Libraries
53
54 %description libs
55 RHash (Recursive Hasher) library.
56
57 %description libs -l pl.UTF-8
58 RHash - biblioteka funkcji skrótu.
59
60 %package devel
61 Summary:        Header files for RHash library
62 Summary(pl.UTF-8):      Pliki nagłówkowe do biblioteki RHash
63 Group:          Development/Libraries
64 Requires:       %{name}-libs = %{version}-%{release}
65
66 %description devel
67 Header files for RHash library.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe do biblioteki RHash.
71
72 %package static
73 Summary:        RHash - static library
74 Summary(pl.UTF-8):      RHash - biblioteka statyczna
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
77
78 %description static
79 Static version of RHash library.
80
81 %description static -l pl.UTF-8
82 RHash - statyczna wersja biblioteki funkcji skrótu.
83
84 %prep
85 %setup -q -n RHash-%{version}
86
87 # missing update in 1.4.3
88 %{__sed} -i -e 's/1\.4\.2/%{version}/' version.h
89
90 %build
91 # not ac-based configure
92 ./configure \
93         --cc="%{__cc}" \
94         --ar="%{__ar}" \
95         --extra-cflags="%{rpmcflags}" \
96         --extra-ldflags="%{rpmldflags}" \
97         --prefix="%{_prefix}" \
98         --bindir="%{_bindir}" \
99         --sysconfdir="%{_sysconfdir}" \
100         --mandir="%{_mandir}" \
101         --libdir="%{_libdir}" \
102         --pkgconfigdir="%{_pkgconfigdir}" \
103         --enable-gettext \
104         --enable-openssl \
105         --enable-openssl-runtime \
106         --enable-lib-shared \
107         --enable-lib-static
108
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %{__make} -j1 install install-pkg-config \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 # missing from top-level Makefile
118 %{__make} -C librhash install-so-link \
119         LIBDIR=$RPM_BUILD_ROOT%{_libdir} \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 %{__chmod} 755 $RPM_BUILD_ROOT%{_libdir}/librhash.so*
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   libs -p /sbin/ldconfig
128 %postun libs -p /sbin/ldconfig
129
130 %files
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_bindir}/rhash
133 %attr(755,root,root) %{_bindir}/ed2k-link
134 %attr(755,root,root) %{_bindir}/edonr256-hash
135 %attr(755,root,root) %{_bindir}/edonr512-hash
136 %attr(755,root,root) %{_bindir}/gost12-256-hash
137 %attr(755,root,root) %{_bindir}/gost12-512-hash
138 %attr(755,root,root) %{_bindir}/has160-hash
139 %attr(755,root,root) %{_bindir}/magnet-link
140 %attr(755,root,root) %{_bindir}/sfv-hash
141 %attr(755,root,root) %{_bindir}/tiger-hash
142 %attr(755,root,root) %{_bindir}/tth-hash
143 %attr(755,root,root) %{_bindir}/whirlpool-hash
144
145 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rhashrc
146 %{_mandir}/man1/ed2k-link.1*
147 %{_mandir}/man1/edonr256-hash.1*
148 %{_mandir}/man1/edonr512-hash.1*
149 %{_mandir}/man1/gost12-256-hash.1*
150 %{_mandir}/man1/gost12-512-hash.1*
151 %{_mandir}/man1/has160-hash.1*
152 %{_mandir}/man1/magnet-link.1*
153 %{_mandir}/man1/rhash.1*
154 %{_mandir}/man1/sfv-hash.1*
155 %{_mandir}/man1/tiger-hash.1*
156 %{_mandir}/man1/tth-hash.1*
157 %{_mandir}/man1/whirlpool-hash.1*
158
159 %files libs
160 %defattr(644,root,root,755)
161 %doc COPYING ChangeLog README.md
162 %attr(755,root,root) %{_libdir}/librhash.so.0
163
164 %files devel
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_libdir}/librhash.so
167 %{_includedir}/rhash.h
168 %{_includedir}/rhash_torrent.h
169 %{_pkgconfigdir}/librhash.pc
170
171 %files static
172 %defattr(644,root,root,755)
173 %{_libdir}/librhash.a
This page took 0.110529 seconds and 3 git commands to generate.