]> git.pld-linux.org Git - packages/retro-gtk.git/blob - retro-gtk.spec
06fd1a67425179e2f9327d83dc14240df478ee03
[packages/retro-gtk.git] / retro-gtk.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # API documentation
4
5 Summary:        Toolkit to write GTK+3 based frontends to libretro
6 Summary(pl.UTF-8):      Biblioteka narzędziowa do pisania opartych na GTK+3 frontendów do libretro
7 Name:           retro-gtk
8 Version:        1.0.1
9 Release:        1
10 License:        GPL v3+
11 Group:          X11/Libraries
12 Source0:        https://download.gnome.org/sources/retro-gtk/1.0/%{name}-%{version}.tar.xz
13 # Source0-md5:  c191e441fdc02e63e47e31f95923206a
14 URL:            https://gitlab.gnome.org/GNOME/retro-gtk
15 BuildRequires:  gettext-tools
16 BuildRequires:  glib2-devel >= 1:2.50
17 BuildRequires:  gobject-introspection-devel >= 0.6.7
18 BuildRequires:  gtk+3-devel >= 3.22
19 %{?with_apidocs:BuildRequires:  gtk-doc}
20 BuildRequires:  libepoxy-devel
21 BuildRequires:  meson >= 0.50.0
22 BuildRequires:  ninja >= 1.5
23 BuildRequires:  pkgconfig
24 BuildRequires:  pulseaudio-devel
25 BuildRequires:  rpmbuild(macros) >= 1.752
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  vala >= 2:0.22.0
28 BuildRequires:  xz
29 # fake dependency: retro-gtk 1.0 is for gnome-games 3.38, which use rusted librsvg
30 # and it's to avoid introducing retro-gtk incompatible with rustless gnome-games 3.34
31 # until Th gets rusted librsvg
32 BuildRequires:  librsvg-devel >= 1:2.46
33 Requires:       glib2 >= 1:2.50
34 Requires:       gtk+3 >= 3.22
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 retro-gtk wraps the libretro API for use in GTK+ applications such as
39 GNOME Games.
40
41 %description -l pl.UTF-8
42 retro-gtk obudowuje API libretro w sposób nadający się do użycia w
43 aplikacjach GTK+, takich jak GNOME Games.
44
45 %package devel
46 Summary:        Header files for retro-gtk library
47 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki retro-gtk
48 Group:          X11/Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       gdk-pixbuf2-devel >= 2.0
51 Requires:       glib2-devel >= 1:2.50
52
53 %description devel
54 Header files for retro-gtk library.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe biblioteki retro-gtk.
58
59 %package -n vala-retro-gtk
60 Summary:        retro-gtk library API for Vala language
61 Summary(pl.UTF-8):      API biblioteki retro-gtk dla języka Vala
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64 Requires:       vala >= 2:0.22.0
65 %{?noarchpackage}
66
67 %description -n vala-retro-gtk
68 retro-gtk library API for Vala language.
69
70 %description -n vala-retro-gtk -l pl.UTF-8
71 API biblioteki retro-gtk dla języka Vala.
72
73 %package apidocs
74 Summary:        API documentation for retro-gtk library
75 Summary(pl.UTF-8):      Dokumentacja API biblioteki retro-gtk
76 Group:          Documentation
77 %{?noarchpackage}
78
79 %description apidocs
80 API documentation for retro-gtk library.
81
82 %description apidocs -l pl.UTF-8
83 Dokumentacja API biblioteki retro-gtk.
84
85 %prep
86 %setup -q
87
88 %build
89 %meson build \
90 %if %{with apidocs}
91         -Dbuild-doc=true \
92         -Dinstall-doc=true
93 %endif
94
95 %ninja_build -C build
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %ninja_install -C build
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post   -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
107
108 %files
109 %defattr(644,root,root,755)
110 %doc AUTHORS NEWS README.md UNIMPLEMENTED.md
111 %attr(755,root,root) %{_bindir}/retro-demo
112 %attr(755,root,root) %{_libexecdir}/retro-runner
113 %attr(755,root,root) %{_libdir}/libretro-gtk-1.so.0
114 %{_libdir}/girepository-1.0/Retro-1.typelib
115
116 %files devel
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_libdir}/libretro-gtk-1.so
119 %{_includedir}/retro-gtk
120 %{_datadir}/gir-1.0/Retro-1.gir
121 %{_pkgconfigdir}/retro-gtk-1.pc
122
123 %files -n vala-retro-gtk
124 %defattr(644,root,root,755)
125 %{_datadir}/vala/vapi/retro-gtk-1.deps
126 %{_datadir}/vala/vapi/retro-gtk-1.vapi
127
128 %if %{with apidocs}
129 %files apidocs
130 %defattr(644,root,root,755)
131 %{_gtkdocdir}/retro-gtk
132 %endif
This page took 0.3441 seconds and 2 git commands to generate.