]> git.pld-linux.org Git - packages/rest.git/blob - rest.spec
- updated URLs, BR for noarch subpackage, note on rest1.spec with API 1.0
[packages/rest.git] / rest.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5
6 %define         apiver  0.7
7 Summary:        A library for access to RESTful web services
8 Summary(pl.UTF-8):      Biblioteka dostępu do REST-owych serwisów WWW
9 Name:           rest
10 # keep 0.8.x here, for >= 0.9.0 see rest1.spec
11 Version:        0.8.1
12 Release:        1
13 License:        LGPL v2
14 Group:          Libraries
15 Source0:        https://download.gnome.org/sources/rest/0.8/%{name}-%{version}.tar.xz
16 # Source0-md5:  ece4547298a81105f307369d73c21b9d
17 URL:            https://www.gnome.org/
18 BuildRequires:  autoconf >= 2.63
19 BuildRequires:  automake >= 1:1.11
20 BuildRequires:  glib2-devel >= 1:2.24
21 BuildRequires:  gobject-introspection-devel >= 0.6.7
22 BuildRequires:  gtk-doc >= 1.13
23 BuildRequires:  libsoup-gnome-devel >= 2.26.0
24 BuildRequires:  libtool >= 2:2.2.6
25 BuildRequires:  libxml2-devel >= 2
26 BuildRequires:  pkgconfig
27 BuildRequires:  rpm-build >= 4.6
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  xz
30 Requires:       glib2 >= 1:2.24
31 Requires:       libsoup-gnome >= 2.26.0
32 Suggests:       ca-certificates
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 This library was designed to make it easier to access web services
37 that claim to be "RESTful". A RESTful service should have URLs that
38 represent remote objects, which methods can then be called on. The
39 majority of services don't actually adhere to this strict definition.
40 Instead, their RESTful end point usually has an API that is just
41 simpler to use compared to other types of APIs they may support
42 (XML-RPC, for instance). It is this kind of API that this library is
43 attempting to support.
44
45 %description -l pl.UTF-8
46 Ta biblioteka została zaprojektowana, aby ułatwić dostęp do serwisów
47 WWW, które uznają się za "REST-owe". Serwis REST-owy powinien mieć
48 URL-e reprezentujące zdalne obiekty, na których można wywoływać
49 metody. Większość serwisów nie jest w pełni zgodna z tą definicją, ale
50 ich REST-owy interfejs zwykle ma API prostsze od innych (np. XML-RPC).
51 Ten rodzaj API próbuje obsłużyć ta biblioteka.
52
53 %package devel
54 Summary:        Header files for rest library
55 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki rest
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       glib2-devel >= 1:2.24
59 Requires:       libsoup-devel >= 2.26.0
60 Requires:       libxml2-devel >= 2
61
62 %description devel
63 Header files for rest library.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe biblioteki rest.
67
68 %package static
69 Summary:        Static rest library
70 Summary(pl.UTF-8):      Statyczna biblioteka rest
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 Static rest library.
76
77 %description static -l pl.UTF-8
78 Statyczna biblioteka rest.
79
80 %package apidocs
81 Summary:        rest API documentation
82 Summary(pl.UTF-8):      Dokumentacja API biblioteki rest
83 Group:          Documentation
84 BuildArch:      noarch
85
86 %description apidocs
87 API documentation for rest library.
88
89 %description apidocs -l pl.UTF-8
90 Dokumentacja API biblioteki rest.
91
92 %prep
93 %setup -q
94
95 %build
96 %{__libtoolize}
97 %{__aclocal}
98 %{__autoconf}
99 %{__autoheader}
100 %{__automake}
101 %configure \
102         --disable-silent-rules \
103         %{__enable_disable apidocs gtk-doc} \
104         %{__enable_disable static_libs static} \
105         --with-html-dir=%{_gtkdocdir} \
106         --with-ca-certificates=/etc/certs/ca-certificates.crt
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 %{!?with_apidocs:%{__rm} -r $RPM_BUILD_ROOT%{_gtkdocdir}}
115 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post   -p /sbin/ldconfig
121 %postun -p /sbin/ldconfig
122
123 %files
124 %defattr(644,root,root,755)
125 %doc AUTHORS README
126 %attr(755,root,root) %{_libdir}/librest-%{apiver}.so.*.*.*
127 %attr(755,root,root) %ghost %{_libdir}/librest-%{apiver}.so.0
128 %attr(755,root,root) %{_libdir}/librest-extras-%{apiver}.so.*.*.*
129 %attr(755,root,root) %ghost %{_libdir}/librest-extras-%{apiver}.so.0
130 %{_libdir}/girepository-1.0/Rest-0.7.typelib
131 %{_libdir}/girepository-1.0/RestExtras-0.7.typelib
132
133 %files devel
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{_libdir}/librest-%{apiver}.so
136 %attr(755,root,root) %{_libdir}/librest-extras-%{apiver}.so
137 %{_datadir}/gir-1.0/Rest-%{apiver}.gir
138 %{_datadir}/gir-1.0/RestExtras-%{apiver}.gir
139 %{_includedir}/rest-%{apiver}
140 %{_pkgconfigdir}/rest-%{apiver}.pc
141 %{_pkgconfigdir}/rest-extras-%{apiver}.pc
142
143 %if %{with static_libs}
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/librest-%{apiver}.a
147 %{_libdir}/librest-extras-%{apiver}.a
148 %endif
149
150 %if %{with apidocs}
151 %files apidocs
152 %defattr(644,root,root,755)
153 %{_gtkdocdir}/rest-%{apiver}
154 %endif
This page took 0.114695 seconds and 3 git commands to generate.