]> git.pld-linux.org Git - packages/rest1.git/blob - rest.spec
- unconditional noarch subpackages
[packages/rest1.git] / rest.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5
6 %define         apiver  0.7
7 Summary:        A library for access to RESTful web services
8 Summary(pl.UTF-8):      Biblioteka dostępu do REST-owych serwisów WWW
9 Name:           rest
10 Version:        0.8.1
11 Release:        1
12 License:        LGPL v2
13 Group:          Libraries
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/rest/0.8/%{name}-%{version}.tar.xz
15 # Source0-md5:  ece4547298a81105f307369d73c21b9d
16 URL:            http://www.gnome.org/
17 BuildRequires:  autoconf >= 2.63
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  glib2-devel >= 1:2.24
20 BuildRequires:  gobject-introspection-devel >= 0.6.7
21 BuildRequires:  gtk-doc >= 1.13
22 BuildRequires:  libsoup-gnome-devel >= 2.26.0
23 BuildRequires:  libtool >= 2:2.2.6
24 BuildRequires:  libxml2-devel >= 2
25 BuildRequires:  pkgconfig
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 Requires:       glib2 >= 1:2.24
29 Requires:       libsoup-gnome >= 2.26.0
30 Suggests:       ca-certificates
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 This library was designed to make it easier to access web services
35 that claim to be "RESTful". A RESTful service should have URLs that
36 represent remote objects, which methods can then be called on. The
37 majority of services don't actually adhere to this strict definition.
38 Instead, their RESTful end point usually has an API that is just
39 simpler to use compared to other types of APIs they may support
40 (XML-RPC, for instance). It is this kind of API that this library is
41 attempting to support.
42
43 %description -l pl.UTF-8
44 Ta biblioteka została zaprojektowana, aby ułatwić dostęp do serwisów
45 WWW, które uznają się za "REST-owe". Serwis REST-owy powinien mieć
46 URL-e reprezentujące zdalne obiekty, na których można wywoływać
47 metody. Większość serwisów nie jest w pełni zgodna z tą definicją, ale
48 ich REST-owy interfejs zwykle ma API prostsze od innych (np. XML-RPC).
49 Ten rodzaj API próbuje obsłużyć ta biblioteka.
50
51 %package devel
52 Summary:        Header files for rest library
53 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki rest
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       glib2-devel >= 1:2.24
57 Requires:       libsoup-devel >= 2.26.0
58 Requires:       libxml2-devel >= 2
59
60 %description devel
61 Header files for rest library.
62
63 %description devel -l pl.UTF-8
64 Pliki nagłówkowe biblioteki rest.
65
66 %package static
67 Summary:        Static rest library
68 Summary(pl.UTF-8):      Statyczna biblioteka rest
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{version}-%{release}
71
72 %description static
73 Static rest library.
74
75 %description static -l pl.UTF-8
76 Statyczna biblioteka rest.
77
78 %package apidocs
79 Summary:        rest API documentation
80 Summary(pl.UTF-8):      Dokumentacja API biblioteki rest
81 Group:          Documentation
82 BuildArch:      noarch
83
84 %description apidocs
85 API documentation for rest library.
86
87 %description apidocs -l pl.UTF-8
88 Dokumentacja API biblioteki rest.
89
90 %prep
91 %setup -q
92
93 %build
94 %{__libtoolize}
95 %{__aclocal}
96 %{__autoconf}
97 %{__autoheader}
98 %{__automake}
99 %configure \
100         --disable-silent-rules \
101         %{__enable_disable apidocs gtk-doc} \
102         %{__enable_disable static_libs static} \
103         --with-html-dir=%{_gtkdocdir} \
104         --with-ca-certificates=/etc/certs/ca-certificates.crt
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 %{!?with_apidocs:%{__rm} -r $RPM_BUILD_ROOT%{_gtkdocdir}}
113 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %files
122 %defattr(644,root,root,755)
123 %doc AUTHORS README
124 %attr(755,root,root) %{_libdir}/librest-%{apiver}.so.*.*.*
125 %attr(755,root,root) %ghost %{_libdir}/librest-%{apiver}.so.0
126 %attr(755,root,root) %{_libdir}/librest-extras-%{apiver}.so.*.*.*
127 %attr(755,root,root) %ghost %{_libdir}/librest-extras-%{apiver}.so.0
128 %{_libdir}/girepository-1.0/Rest-0.7.typelib
129 %{_libdir}/girepository-1.0/RestExtras-0.7.typelib
130
131 %files devel
132 %defattr(644,root,root,755)
133 %attr(755,root,root) %{_libdir}/librest-%{apiver}.so
134 %attr(755,root,root) %{_libdir}/librest-extras-%{apiver}.so
135 %{_datadir}/gir-1.0/Rest-%{apiver}.gir
136 %{_datadir}/gir-1.0/RestExtras-%{apiver}.gir
137 %{_includedir}/rest-%{apiver}
138 %{_pkgconfigdir}/rest-%{apiver}.pc
139 %{_pkgconfigdir}/rest-extras-%{apiver}.pc
140
141 %if %{with static_libs}
142 %files static
143 %defattr(644,root,root,755)
144 %{_libdir}/librest-%{apiver}.a
145 %{_libdir}/librest-extras-%{apiver}.a
146 %endif
147
148 %if %{with apidocs}
149 %files apidocs
150 %defattr(644,root,root,755)
151 %{_gtkdocdir}/rest-%{apiver}
152 %endif
This page took 0.067902 seconds and 3 git commands to generate.