]> git.pld-linux.org Git - packages/redland.git/blob - redland.spec
- removed %%include /usr/lib/rpm/macros.python
[packages/redland.git] / redland.spec
1 # TODO: various language support (java, perl, php, ruby, tcl)
2 Summary:        Redland - a library that provides a high-level interface for RDF
3 Summary(pl):    Redland - biblioteka udostêpniaj±ca wysokopoziomowy interfejs do RDF
4 Name:           redland
5 Version:        0.9.16
6 Release:        0.1
7 License:        LGPL v2 or MPL 1.1
8 Group:          Libraries
9 Source0:        http://www.redland.opensource.ac.uk/dist/source/%{name}-%{version}.tar.gz
10 # Source0-md5:  d78c768825df2727aec8336fe9772d8d
11 Patch0:         %{name}-system-raptor.patch
12 URL:            http://www.redland.opensource.ac.uk/
13 BuildRequires:  autoconf >= 2.53
14 BuildRequires:  automake >= 1.6
15 BuildRequires:  db-devel
16 BuildRequires:  libraptor-devel >= 1.2.0
17 BuildRequires:  libtool
18 BuildRequires:  mysql-devel >= 3.23.58
19 BuildRequires:  openssl-devel >= 0.9.7d
20 BUildRequires:  rpm-pythonprov
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Redland is a library that provides a high-level interface for RDF
25 allowing the RDF graph to be parsed from XML, stored, queried and
26 manipulated. Redland implements each of the RDF concepts in its own
27 class via an object based API, reflected into the other language APIs:
28 Perl, Python, Tcl, Java and Ruby. Some of the classes providing the
29 parsers, storage mechanisms and other elements are built as modules
30 that can be added or removed as required.
31
32 %description -l pl
33 Redland to biblioteka udostêpniaj±ca wysokopoziomowy interfejs do RDF,
34 pozwalaj±ca na analizê grafu RDF z XML-a, jego przechowywanie,
35 odpytywanie i obróbkê. Redland zawiera implementacje ka¿dego pojêcia z
36 RDF w odobnej klasie poprzez obiekt oparty na API, maj±cy
37 odzwierciedlenie w API dla innych jêzyków: Perla, Pythona, Tcl-a, Javy
38 i Ruby'ego. Czê¶æ klas udostêpniaj±cych analizatory, mechanizmy
39 przechowywania i inne elementy jest zbudowana jako modu³y, które mog±
40 byæ dodawane lub usuwane w razie potrzeby.
41
42 %package devel
43 Summary:        Headers for Redland RDF library
44 Summary(pl):    Pliki nag³ówkowe biblioteki Redland RDF
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       db-devel
48 Requires:       libraptor-devel >= 1.2.0
49 Requires:       mysql-devel >= 3.23.58
50
51 %description devel
52 Headers for Redland RDF library.
53
54 %description devel -l pl
55 Pliki nag³ówkowe biblioteki Redland RDF.
56
57 %package static
58 Summary:        Static Redland RDF library
59 Summary(pl):    Statyczna biblioteka Redland RDF
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static Redland RDF library.
65
66 %description static -l pl
67 Statyczna biblioteka Redland RDF.
68
69 %package rapper
70 Summary:        Raptor RDF parser test program with Redland RDF support
71 Summary(pl):    Testowy program parsera Raptor RDF ze wsparciem dla Redland RDF
72 Group:          Applications
73 Requires:       %{name} = %{version}-%{release}
74
75 %description rapper
76 Raptor RDF parser test program with Redland RDF support.
77
78 %description rapper -l pl
79 Testowy program parsera Raptor RDF ze wsparciem dla Redland RDF.
80
81 %package -n python-redland
82 Summary:        Python bindings for Redland RDF library
83 Summary(pl):    Pythonowy interfejs do biblioteki Redland RDF
84 Group:          Libraries/Python
85 Requires:       %{name} = %{version}-%{release}
86 %pyrequires_eq  python
87
88 %description -n python-redland
89 Python bindings for Redland RDF library
90
91 %description -n python-redland -l pl
92 Pythonowy interfejs do biblioteki Redland RDF
93
94 %prep
95 %setup -q
96 %patch0 -p1
97
98 %build
99 %{__libtoolize}
100 %{__aclocal}
101 %{__autoconf}
102 %{__autoheader}
103 %{__automake}
104 cd raptor
105 %{__aclocal}
106 %{__autoconf}
107 %{__autoheader}
108 # don't use -f here
109 automake -a -c --foreign
110 cd ..
111 %configure \
112         --with-raptor=system \
113         --with-python
114
115 #       --with-java --with-jdk=/usr/lib/java  -- builds, but can be only optional
116 #       --with-perl  -- needs INSTALLDIRS=vendor in perl/Makefile.am
117 #       --with-ruby  -- missing install -d before installing *.so
118 #       --with-tcl  -- missing install -d before installing *.so
119 #       --with-php  -- cannot find config.h
120 #       --with-ecma-cli=mono  -- TODO
121
122 %{__make}
123
124 # build rapper with Redland/RDF support
125 %{__make} -C raptor
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129
130 %{__make} install \
131         DESTDIR=$RPM_BUILD_ROOT
132
133 %{__make} install -C raptor \
134         DESTDIR=$RPM_BUILD_ROOT
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post   -p /sbin/ldconfig
140 %postun -p /sbin/ldconfig
141
142 %files
143 %defattr(644,root,root,755)
144 %doc AUTHORS ChangeLog FAQS.html LICENSE.html NEWS.html README.html RELEASE.html TODO.html
145 %attr(755,root,root) %{_bindir}/rdfproc
146 %attr(755,root,root) %{_bindir}/redland-db-upgrade
147 %attr(755,root,root) %{_libdir}/librdf.so.*.*.*
148 %{_mandir}/man1/rdfproc.1*
149 %{_mandir}/man1/redland-db-upgrade.1*
150
151 %files devel
152 %defattr(644,root,root,755)
153 %doc docs/{README.html,overview.png,api}
154 %attr(755,root,root) %{_bindir}/redland-config
155 %attr(755,root,root) %{_libdir}/librdf.so
156 %{_libdir}/librdf.la
157 %{_includedir}/librdf.h
158 %{_includedir}/rdf_*.h
159 %{_includedir}/redland.h
160 %{_pkgconfigdir}/redland.pc
161 %{_mandir}/man1/redland-config.1*
162 %{_mandir}/man3/redland.3*
163
164 %files static
165 %defattr(644,root,root,755)
166 %{_libdir}/librdf.a
167
168 %files rapper
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_bindir}/rapper
171 %{_mandir}/man1/rapper.1*
172
173 %files -n python-redland
174 %defattr(644,root,root,755)
175 %{py_sitedir}/RDF.py
176 %attr(755,root,root) %{py_sitedir}/Redland.so
This page took 0.09671 seconds and 3 git commands to generate.