]> git.pld-linux.org Git - packages/recordmydesktop.git/blob - recordmydesktop.spec
BR python-PyQt4 with qt build
[packages/recordmydesktop.git] / recordmydesktop.spec
1 #
2 # Conditional build
3 %bcond_without  gtk     # don't build GTK+ frontend
4 %bcond_without  qt      # don't build Qt frontend
5 %bcond_without  x       # don't build for X Window System frontends
6
7 %define ver 0.3.8.1
8 %define gtk_ver 0.3.8
9 %define qt_ver 0.3.8
10 Summary:        Desktop session recorder
11 Summary(pl.UTF-8):      Rejestrator pulpitu
12 Name:           recordmydesktop
13 Version:        %{ver}
14 # do not decrease Release, as subpackages Version is not in sync with main Version
15 Release:        6
16 License:        GPL v2+
17 Group:          X11/Applications
18 Source0:        http://downloads.sourceforge.net/recordmydesktop/%{name}-%{ver}.tar.gz
19 # Source0-md5:  6998b165540598965499bd99d8aa0eef
20 Source1:        http://downloads.sourceforge.net/recordmydesktop/gtk-%{name}-%{gtk_ver}.tar.gz
21 # Source1-md5:  2637b9be9801e0b2c3b6dae8f86a8b59
22 Source2:        http://downloads.sourceforge.net/recordmydesktop/qt-%{name}-%{qt_ver}.tar.gz
23 # Source2-md5:  bf1525740755615ae172ae27fef68fb5
24 Patch0:         cache_fix.patch
25 Patch1:         x11_build_fix.patch
26 Patch2:         %{name}-ALSA-default.patch
27 Patch3:         %{name}-sane-theora-defaults.patch
28 Patch4:         %{name}-fix-configure-ac-jack-support.patch
29 URL:            http://recordmydesktop.sourceforge.net/
30 %if %{with qt}
31 BuildRequires:  QtCore-devel
32 BuildRequires:  QtGui-devel
33 %endif
34 BuildRequires:  alsa-lib-devel
35 BuildRequires:  autoconf
36 BuildRequires:  automake
37 BuildRequires:  gettext-devel
38 BuildRequires:  jack-audio-connection-kit-devel
39 BuildRequires:  libogg-devel
40 BuildRequires:  libtheora-devel
41 BuildRequires:  libvorbis-devel
42 BuildRequires:  pkgconfig
43 %{?with_qt:BuildRequires:      python-PyQt4}
44 BuildRequires:  python-devel
45 %{?with_gtk:BuildRequires:      python-pygtk-devel}
46 BuildRequires:  rpm-pythonprov
47 BuildRequires:  xorg-lib-libICE-devel
48 BuildRequires:  xorg-lib-libSM-devel
49 BuildRequires:  xorg-lib-libXdamage-devel
50 BuildRequires:  xorg-lib-libXext-devel
51 BuildRequires:  xorg-lib-libXfixes-devel
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 Simple command line tool that performs the basic tasks of capturing
56 and encoding desktop session. It produces files using only open
57 formats like Theora for video and Vorbis for audio, using the Ogg
58 container.
59
60 %description -l pl.UTF-8
61 Proste narzędzie linii poleceń, które wykonuje podstawowe zadanie
62 zrzucania i kodowania bieżącej sesji pulpitu. Wytwarza on pliki
63 używając tylko otwartych formatów takich jak Theora do zapisu obrazu i
64 Vorbis do zapisu dźwięku, wykorzystując kontener Ogg.
65
66 %package gtk
67 Summary:        GTK+ frontend for recordmydesktop
68 Summary(pl.UTF-8):      Frontend do recordmydesktop oparty na GTK+
69 Version:        %{gtk_ver}
70 Group:          X11/Applications
71 Requires:       %{name} >= %{gtk_ver}
72 Requires:       python-%{name} >= %{gtk_ver}
73
74 %description gtk
75 GTK+ frontend for recordmydesktop.
76
77 %description gtk -l pl.UTF-8
78 Frontend do recordmydesktop oparty na GTK+.
79
80 %package qt
81 Summary:        Qt frontend for recordmydesktop
82 Summary(pl.UTF-8):      Frontend do recordmydesktop oparty na Qt
83 Version:        %{qt_ver}
84 Group:          X11/Applications
85 Requires:       %{name} >= %{qt_ver}
86 Requires:       /usr/bin/jack_lsp
87 Requires:       python-PyQt4
88
89 %description qt
90 Qt frontend for recordmydesktop.
91
92 %description qt -l pl.UTF-8
93 Frontend do recordmydesktop oparty na Qt.
94
95 %package -n python-%{name}
96 Summary:        X Window System resource for recordmydesktop
97 Summary(pl.UTF-8):      Zasoby X Window System do recordmydesktop
98 Group:          X11/Applications
99 Requires:       %{name} = %{ver}-%{release}
100
101 %description -n python-%{name}
102 X Window System resource for recordmydesktop.
103
104 %description -n python-%{name} -l pl.UTF-8
105 Zasoby X Window System do recordmydesktop.
106
107 %prep
108 %setup -q -a 1 -a 2
109 %patch0 -p1
110 %patch1 -p1
111 %patch2 -p1
112 %patch3 -p1
113 %patch4 -p1
114
115 %build
116 %{__aclocal}
117 %{__autoconf}
118 %{__automake}
119 %configure \
120         --with-x
121 %{__make}
122
123 %if %{with gtk}
124 cd gtk-%{name}-%{gtk_ver}
125 %configure
126 %{__make}
127 cd ..
128 %endif
129
130 %if %{with qt}
131 cd qt-%{name}-%{qt_ver}
132 sed -i -e 's@#! /bin/sh@#!/bin/bash@' configure
133 %configure
134 %{__make}
135 cd ..
136 %endif
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140 %{__make} install \
141         INSTALL="%{__install} -c -p" \
142         DESTDIR=$RPM_BUILD_ROOT
143
144 %py_postclean %{py_sitescriptdir}/recordMyDesktop
145
146 %if %{with gtk}
147 %{__make} -C gtk-%{name}-%{gtk_ver} install \
148         INSTALL="%{__install} -c -p" \
149         DESTDIR=$RPM_BUILD_ROOT
150 rm -f __find.*
151 %find_lang gtk-recordMyDesktop
152 %endif
153
154 %if %{with qt}
155 %{__make} -C qt-%{name}-%{qt_ver} install \
156         INSTALL="%{__install} -c -p" \
157         DESTDIR=$RPM_BUILD_ROOT
158
159 rm -f __find.*
160 %find_lang qt-recordMyDesktop
161
162 %py_postclean %{py_sitescriptdir}/qt_recordMyDesktop
163 %endif
164
165 %clean
166 rm -rf $RPM_BUILD_ROOT
167
168 %files
169 %defattr(644,root,root,755)
170 %doc AUTHORS ChangeLog
171 %attr(755,root,root) %{_bindir}/%{name}
172 %{_mandir}/man1/%{name}.1*
173
174 %if %{with x}
175 %files -n python-%{name}
176 %defattr(644,root,root,755)
177 %{py_sitescriptdir}/recordMyDesktop
178 %endif
179
180 %if %{with gtk}
181 %files gtk -f gtk-recordMyDesktop.lang
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{_bindir}/gtk-recordMyDesktop
184 %{_desktopdir}/gtk-%{name}.desktop
185 %{_pixmapsdir}/gtk-%{name}.png
186 %endif
187
188 %if %{with qt}
189 %files qt -f qt-recordMyDesktop.lang
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_bindir}/qt-recordMyDesktop
192 %{_desktopdir}/qt-%{name}.desktop
193 %{_pixmapsdir}/qt-%{name}*.png
194 %{_pixmapsdir}/*.svg
195 %{py_sitescriptdir}/qt_recordMyDesktop
196 %endif
This page took 0.087392 seconds and 3 git commands to generate.