]> git.pld-linux.org Git - packages/recoil.git/blob - recoil.spec
ImageMagick 7.1 rebuild
[packages/recoil.git] / recoil.spec
1 # TODO:
2 # - finish html5 (BR: vnu.jar)
3 # - webapp config for -html5? (optional, may be used also locally)
4 #
5 # Conditional build:
6 %bcond_with     html5   # HTML5 viewer
7 %bcond_without  magick  # ImageMagick coder
8 #
9 # html5 requires cito that requires mono that is not available yet on x32
10 %ifarch x32
11 %undefine       with_html5
12 %endif
13
14 Summary:        RECOIL - Retro Computer Image Library
15 Summary(pl.UTF-8):      RECOIL (Retro Computer Image Library) - biblioteka do obrazów w formatach komputerów retro
16 Name:           recoil
17 Version:        6.1.1
18 Release:        2
19 License:        GPL v2+
20 Group:          Applications/Graphics
21 Source0:        https://downloads.sourceforge.net/recoil/%{name}-%{version}.tar.gz
22 # Source0-md5:  844d34c62064c8123a4179133493246e
23 URL:            http://recoil.sourceforge.net/
24 %{?with_magick:BuildRequires:   ImageMagick-devel >= 1:6.8}
25 %{?with_html5:BuildRequires:    asciidoc}
26 %{?with_html5:BuildRequires:    cito}
27 BuildRequires:  libpng-devel
28 BuildRequires:  libxslt-progs
29 BuildRequires:  zlib-devel
30 #Obsoletes:     fail < 3
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %if %{with magick}
34 %define         im_coders_dir   %(pkg-config --variable moduledir MagickCore)/coders
35 %endif
36
37 %description
38 RECOIL is a viewer of pictures in native formats of vintage computers:
39 Amiga, Amstrad CPC, Apple II, Atari 8-bit, Atari Portfolio, Atari
40 ST/TT/Falcon, BBC Micro, Commodore VIC-20, Commodore 16, Commodore 64,
41 Commodore 128, Electronika BK, FM Towns, Macintosh 128K, MSX,
42 NEC PC-80/88/98, Oric, Psion Series 3, SAM Coupe, Sharp X68000, Tandy
43 1000, Timex 2048, TRS-80, TRS-80 Color Computer, ZX81 and ZX Spectrum.
44
45 %description -l pl.UTF-8
46 RECOIL to przeglądarka obrazów w natywnych formatach klasycznych
47 komputerów: Amiga, Amstrad CPC, Apple II, Atari 8-bitowe, Atari
48 Portfolio, Atari ST/TT/Falcon, BBC Micro, Commodore VIC-20, Commodore
49 16, Commodore 64, Commodore 128, Electronika BK, FM Towns, Macintosh
50 128K, MSX, NEC PC-80/88/98, Oric, Psion Series 3, SAM Coupé, Sharp
51 X68000, Tandy 1000, Timex 2048, TRS-80, TRS-80 Color Computer, ZX81
52 oraz ZX Spectrum.
53
54 %package gnome
55 Summary:        RECOIL support for viewing retro computer files in GNOME
56 Summary(pl.UTF-8):      Wsparcie RECOIL do oglądania plików z komputerów retro w GNOME
57 Group:          X11/Applications/Graphics
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       shared-mime-info
60 Obsoletes:      fail-gnome < 3
61
62 %description gnome
63 RECOIL support for viewing retro computer files in GNOME.
64
65 %description gnome -l pl.UTF-8
66 Wsparcie RECOIL do oglądania plików z komputerów retro w GNOME.
67
68 %package html5
69 Summary:        HTML5 RECOIL viewer for retro computer files
70 Summary(pl.UTF-8):      Przeglądarka RECOIL do plików z komputerów retro w HTML5
71 Group:          Applications/WWW
72 #Obsoletes:     fail-html5 < 3
73
74 %description html5
75 HTML5 RECOIL viewer for retro computer files.
76
77 %description html5 -l pl.UTF-8
78 Przeglądarka RECOIL do plików z komputerów retro w HTML5.
79
80 %package -n ImageMagick-coder-recoil
81 Summary:        RECOIL coder for ImageMagick
82 Summary(pl.UTF-8):      Koder RECOIL dla ImageMagicka
83 Group:          Libraries
84 %requires_ge_to ImageMagick ImageMagick-devel
85 #Obsoletes:     ImageMagick-coder-fail < 3
86
87 %description -n ImageMagick-coder-recoil
88 RECOIL coder for ImageMagick to read retro computer formats.
89
90 %description -n ImageMagick-coder-recoil -l pl.UTF-8
91 Koder RECOIL dla ImageMagicka, czytający formaty komputerów retro.
92
93 %prep
94 %setup -q
95
96 %build
97 %{__make} \
98         CC="%{__cc}" \
99         CFLAGS="%{rpmcflags} -Wall -I. -DMAGICK7" \
100 %if %{with magick}
101         MAGICK_INCLUDE_PATH=/usr/include/ImageMagick-7/private \
102         CAN_INSTALL_MAGICK=1
103 %endif
104
105 %if %{with html5}
106 %{__make} -C www
107 %endif
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %{__make} install-recoil2png install-mime install-thumbnailer \
113         BUILDING_PACKAGE=1 \
114         PREFIX=$RPM_BUILD_ROOT%{_prefix}
115
116 # install-thumbnailer is ugly; for now, install only this one
117 #install -D recoil-mime.xml $RPM_BUILD_ROOT%{_datadir}/mime/packages/recoil-mime.xml
118
119 %if %{with magick}
120 install -D imagemagick/recoil.so $RPM_BUILD_ROOT%{im_coders_dir}/recoil.so
121 echo "dlname='recoil.so'" >$RPM_BUILD_ROOT%{im_coders_dir}/recoil.la
122 %endif
123
124 %if %{with html5}
125 install -d $RPM_BUILD_ROOT%{_datadir}/recoil-html5
126 cp -p www/*.{js,html} $RPM_BUILD_ROOT%{_datadir}/recoil-html5
127 %endif
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post   gnome
133 %update_mime_database
134
135 %postun gnome
136 %update_mime_database
137
138 %files
139 %defattr(644,root,root,755)
140 %doc README
141 %attr(755,root,root) %{_bindir}/recoil2png
142 %{_mandir}/man1/recoil2png.1*
143
144 %files gnome
145 %defattr(644,root,root,755)
146 %{_datadir}/mime/packages/recoil-mime.xml
147 %{_datadir}/thumbnailers/recoil.thumbnailer
148
149 %if %{with html5}
150 %files html5
151 %defattr(644,root,root,755)
152 %{_datadir}/recoil-html5
153 %endif
154
155 %if %{with magick}
156 %files -n ImageMagick-coder-recoil
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{im_coders_dir}/recoil.so
159 %{im_coders_dir}/recoil.la
160 %endif
This page took 0.090617 seconds and 3 git commands to generate.