]> git.pld-linux.org Git - packages/recoil.git/blob - recoil.spec
- updated to 6.3.3
[packages/recoil.git] / recoil.spec
1 # TODO:
2 # - finish html5 (BR: vnu.jar)
3 # - webapp config for -html5? (optional, may be used also locally)
4 #
5 # Conditional build:
6 %bcond_without  gimp    # GIMP plugin
7 %bcond_with     html5   # HTML5 viewer
8 %bcond_without  magick  # ImageMagick coder
9 #
10 # html5 requires cito that requires mono that is not available yet on x32
11 %ifarch x32
12 %undefine       with_html5
13 %endif
14
15 Summary:        RECOIL - Retro Computer Image Library
16 Summary(pl.UTF-8):      RECOIL (Retro Computer Image Library) - biblioteka do obrazów w formatach komputerów retro
17 Name:           recoil
18 Version:        6.3.3
19 Release:        1
20 License:        GPL v2+
21 Group:          Applications/Graphics
22 Source0:        https://downloads.sourceforge.net/recoil/%{name}-%{version}.tar.gz
23 # Source0-md5:  8a0947e7f8a87045ae2187f477b02b92
24 URL:            http://recoil.sourceforge.net/
25 %{?with_magick:BuildRequires:   ImageMagick-devel >= 1:6.8}
26 %{?with_html5:BuildRequires:    asciidoc}
27 %{?with_html5:BuildRequires:    cito}
28 %{?with_gimp:BuildRequires:     gimp-devel >= 1:2.0}
29 BuildRequires:  libpng-devel
30 BuildRequires:  libxslt-progs
31 BuildRequires:  zlib-devel
32 #Obsoletes:     fail < 3
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %if %{with magick}
36 %define         im_coders_dir   %(pkg-config --variable moduledir MagickCore)/coders
37 %endif
38
39 %description
40 RECOIL is a viewer of pictures in native formats of vintage computers:
41 Amiga, Amstrad CPC, Apple II, Atari 8-bit, Atari Portfolio, Atari
42 ST/TT/Falcon, BBC Micro, Commodore VIC-20, Commodore 16, Commodore 64,
43 Commodore 128, Electronika BK, FM Towns, Macintosh 128K, MSX,
44 NEC PC-80/88/98, Oric, Psion Series 3, SAM Coupe, Sharp X68000, Tandy
45 1000, Timex 2048, TRS-80, TRS-80 Color Computer, ZX81 and ZX Spectrum.
46
47 %description -l pl.UTF-8
48 RECOIL to przeglądarka obrazów w natywnych formatach klasycznych
49 komputerów: Amiga, Amstrad CPC, Apple II, Atari 8-bitowe, Atari
50 Portfolio, Atari ST/TT/Falcon, BBC Micro, Commodore VIC-20, Commodore
51 16, Commodore 64, Commodore 128, Electronika BK, FM Towns, Macintosh
52 128K, MSX, NEC PC-80/88/98, Oric, Psion Series 3, SAM Coupé, Sharp
53 X68000, Tandy 1000, Timex 2048, TRS-80, TRS-80 Color Computer, ZX81
54 oraz ZX Spectrum.
55
56 %package gnome
57 Summary:        RECOIL support for viewing retro computer files in GNOME
58 Summary(pl.UTF-8):      Wsparcie RECOIL do oglądania plików z komputerów retro w GNOME
59 Group:          X11/Applications/Graphics
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       shared-mime-info
62 Obsoletes:      fail-gnome < 3
63
64 %description gnome
65 RECOIL support for viewing retro computer files in GNOME.
66
67 %description gnome -l pl.UTF-8
68 Wsparcie RECOIL do oglądania plików z komputerów retro w GNOME.
69
70 %package html5
71 Summary:        HTML5 RECOIL viewer for retro computer files
72 Summary(pl.UTF-8):      Przeglądarka RECOIL do plików z komputerów retro w HTML5
73 Group:          Applications/WWW
74 #Obsoletes:     fail-html5 < 3
75
76 %description html5
77 HTML5 RECOIL viewer for retro computer files.
78
79 %description html5 -l pl.UTF-8
80 Przeglądarka RECOIL do plików z komputerów retro w HTML5.
81
82 %package -n ImageMagick-coder-recoil
83 Summary:        RECOIL coder for ImageMagick
84 Summary(pl.UTF-8):      Koder RECOIL dla ImageMagicka
85 Group:          Libraries
86 %requires_ge_to ImageMagick ImageMagick-devel
87 #Obsoletes:     ImageMagick-coder-fail < 3
88
89 %description -n ImageMagick-coder-recoil
90 RECOIL coder for ImageMagick to read retro computer formats.
91
92 %description -n ImageMagick-coder-recoil -l pl.UTF-8
93 Koder RECOIL dla ImageMagicka, czytający formaty komputerów retro.
94
95 %package -n gimp-plugin-recoil
96 Summary:        RECOIL plugin for GIMP
97 Summary(pl.UTF-8):      Wtyczka RECOIL dla GIMP-a
98 Group:          X11/Applications/Graphics
99 Requires:       gimp >= 1:2.0
100
101 %description -n gimp-plugin-recoil
102 RECOIL plugin for GIMP to read retro computer formats.
103
104 %description -n gimp-plugin-recoil -l pl.UTF-8
105 Wtyczka RECOIL dla GIMP-a, czytająca formaty komputerów retro.
106
107 %prep
108 %setup -q
109
110 %build
111 %{__make} all %{?with_gimp:file-recoil} \
112         CC="%{__cc}" \
113         CFLAGS="%{rpmcflags} -Wall -I. -DMAGICK7" \
114 %if %{with magick}
115         MAGICK_INCLUDE_PATH=/usr/include/ImageMagick-7/private \
116         CAN_INSTALL_MAGICK=1
117 %endif
118
119 %if %{with html5}
120 %{__make} -C www
121 %endif
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125
126 %{__make} install-recoil2png install-mime install-thumbnailer %{?with_gimp:install-gimp} \
127         BUILDING_PACKAGE=1 \
128         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
129         libdir=$RPM_BUILD_ROOT%{_libdir}
130
131 # install-thumbnailer is ugly; for now, install only this one
132 #install -D recoil-mime.xml $RPM_BUILD_ROOT%{_datadir}/mime/packages/recoil-mime.xml
133
134 %if %{with magick}
135 install -D imagemagick/recoil.so $RPM_BUILD_ROOT%{im_coders_dir}/recoil.so
136 echo "dlname='recoil.so'" >$RPM_BUILD_ROOT%{im_coders_dir}/recoil.la
137 %endif
138
139 %if %{with html5}
140 install -d $RPM_BUILD_ROOT%{_datadir}/recoil-html5
141 cp -p www/*.{js,html} $RPM_BUILD_ROOT%{_datadir}/recoil-html5
142 %endif
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post   gnome
148 %update_mime_database
149
150 %postun gnome
151 %update_mime_database
152
153 %files
154 %defattr(644,root,root,755)
155 %doc README
156 %attr(755,root,root) %{_bindir}/recoil2png
157 %{_mandir}/man1/recoil2png.1*
158
159 %files gnome
160 %defattr(644,root,root,755)
161 %{_datadir}/mime/packages/recoil-mime.xml
162 %{_datadir}/thumbnailers/recoil.thumbnailer
163
164 %if %{with html5}
165 %files html5
166 %defattr(644,root,root,755)
167 %{_datadir}/recoil-html5
168 %endif
169
170 %if %{with magick}
171 %files -n ImageMagick-coder-recoil
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{im_coders_dir}/recoil.so
174 %{im_coders_dir}/recoil.la
175 %endif
176
177 %if %{with gimp}
178 %files -n gimp-plugin-recoil
179 %defattr(644,root,root,755)
180 %dir %{_libdir}/gimp/2.0/plug-ins/file-recoil
181 %attr(755,root,root) %{_libdir}/gimp/2.0/plug-ins/file-recoil/file-recoil
182 %endif
This page took 0.108499 seconds and 3 git commands to generate.