]> git.pld-linux.org Git - packages/rbenv.git/blob - rbenv.spec
up to 0.4.0
[packages/rbenv.git] / rbenv.spec
1 Summary:        Simple per-user Ruby version manager
2 Name:           rbenv
3 Version:        0.4.0
4 Release:        1
5 License:        MIT
6 Group:          Development/Tools
7 Source0:        https://github.com/sstephenson/rbenv/archive/v%{version}/%{name}-%{version}.tar.gz
8 # Source0-md5:  c4a15a4dccf3dc1d28d08e87fb7c7789
9 URL:            https://github.com/sstephenson/rbenv
10 Requires:       bash
11 BuildArch:      noarch
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %define         _appdir                 %{_datadir}/%{name}
15
16 %description
17 rbenv lets you easily switch between multiple versions of Ruby. It's
18 simple, unobtrusive, and follows the UNIX tradition of single-purpose
19 tools that do one thing well.
20
21 %prep
22 %setup -q
23
24 %install
25 rm -rf $RPM_BUILD_ROOT
26 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
27 cp -a bin libexec completions $RPM_BUILD_ROOT%{_datadir}/%{name}
28
29 install -d $RPM_BUILD_ROOT%{_bindir}
30 ln -s %{_datadir}/%{name}/bin/%{name} $RPM_BUILD_ROOT%{_bindir}/rbenv
31
32 %post
33 %banner %{name} -e -o <<'EOF'
34 You probably want to execute the following line to add rbenv to your shell:
35
36 echo 'eval "$(rbenv init -)"' >> ~/.bash_profile
37 EOF
38
39 %clean
40 rm -rf $RPM_BUILD_ROOT
41
42 %files
43 %defattr(644,root,root,755)
44 %doc README.md LICENSE
45 %attr(755,root,root) %{_bindir}/rbenv
46 %dir %{_datadir}/%{name}
47 %dir %{_datadir}/%{name}/bin
48 %attr(755,root,root) %{_datadir}/%{name}/bin/rbenv
49 %attr(755,root,root) %{_datadir}/%{name}/bin/ruby-local-exec
50 %dir %{_datadir}/%{name}/libexec
51 %attr(755,root,root) %{_datadir}/%{name}/libexec/rbenv*
52 %{_datadir}/%{name}/completions
This page took 0.038858 seconds and 3 git commands to generate.