]> git.pld-linux.org Git - packages/rav1e.git/blob - rav1e.spec
- updated to 0.4.1
[packages/rav1e.git] / rav1e.spec
1 Summary:        The fastest and safest AV1 encoder
2 Summary(pl.UTF-8):      Najszybszy i najbezpieczniejszy koder AV1
3 Name:           rav1e
4 Version:        0.4.1
5 Release:        1
6 License:        BSD
7 Group:          Libraries
8 #Source0Download: https://github.com/xiph/rav1e/releases
9 Source0:        https://github.com/xiph/rav1e/archive/v%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  e9c3c833c33bcf1bbafbdf1dcc170e10
11 # cd %{name}-%{version}
12 # cargo vendor
13 # cd ..
14 # tar cJf rav1e-crates-%{version}.tar.xz %{name}-%{version}/{vendor,Cargo.lock}
15 Source1:        %{name}-crates-%{version}.tar.xz
16 # Source1-md5:  cb04c9255da1a4b5caca116652a7781e
17 URL:            https://github.com/xiph/rav1e
18 BuildRequires:  cargo
19 BuildRequires:  cargo-c
20 %ifarch %{x8664}
21 BuildRequires:  nasm
22 %endif
23 BuildRequires:  rust
24 # for tests only?
25 #BuildRequires: aom-devel
26 #BuildRequires: dav1d-devel
27 ExclusiveArch:  %{ix86} %{x8664} aarch64
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 rav1e is an AV1 video encoder. It is designed to eventually cover all
32 use cases, though in its current form it is most suitable for cases
33 where libaom (the reference encoder) is too slow.
34
35 %description -l pl.UTF-8
36 rav1e to koder obrazu AV1. Jest projektowany, aby ewentualnie pokrywać
37 wszystkie przypadki użycia, ale w obecnej postaci nadaje się najlepiej
38 tam, gdzie libaom (koder referencyjny) jest zbyt wolny.
39
40 %package libs
41 Summary:        Shared rav1e library
42 Summary(pl.UTF-8):      Biblioteka współdzielona rav1e
43 Group:          Libraries
44
45 %description libs
46 Shared rav1e library.
47
48 %description libs -l pl.UTF-8
49 Biblioteka współdzielona rav1e.
50
51 %package devel
52 Summary:        Header files for rav1e library
53 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki rav1e
54 Group:          Development/Libraries
55 Requires:       %{name}-libs = %{version}-%{release}
56
57 %description devel
58 Header files for rav1e library.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe biblioteki rav1e.
62
63 %package static
64 Summary:        Static rav1e library
65 Summary(pl.UTF-8):      Statyczna biblioteka rav1e
66 Group:          Development/Libraries
67 Requires:       %{name}-devel = %{version}-%{release}
68
69 %description static
70 Static rav1e library.
71
72 %description static -l pl.UTF-8
73 Statyczna biblioteka rav1e.
74
75 %prep
76 %setup -q -b1
77
78 # use our offline registry
79 export CARGO_HOME="$(pwd)/.cargo"
80
81 mkdir -p "$CARGO_HOME"
82 cat >.cargo/config <<EOF
83 [source.crates-io]
84 replace-with = 'vendored-sources'
85
86 [source.vendored-sources]
87 directory = '$PWD/vendor'
88 EOF
89
90 %build
91 export CARGO_HOME="$(pwd)/.cargo"
92
93 cargo -v build --release --frozen
94
95 cargo -v cbuild --release --frozen
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 cargo -v install --frozen --path . --root $RPM_BUILD_ROOT%{_prefix}
101
102 cargo -v cinstall --frozen --release \
103         --destdir $RPM_BUILD_ROOT \
104         --prefix %{_prefix} \
105         --bindir %{_bindir} \
106         --includedir %{_includedir} \
107         --libdir %{_libdir}
108
109 %{__rm} $RPM_BUILD_ROOT%{_prefix}/.crates*
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   libs -p /sbin/ldconfig
115 %postun libs -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %doc LICENSE PATENTS README.md
120 %attr(755,root,root) %{_bindir}/rav1e
121
122 %files libs
123 %defattr(644,root,root,755)
124 %doc LICENSE PATENTS README.md doc/GLOSSARY.md
125 %attr(755,root,root) %{_libdir}/librav1e.so.*.*.*
126 %attr(755,root,root) %ghost %{_libdir}/librav1e.so.0
127
128 %files devel
129 %defattr(644,root,root,755)
130 %attr(755,root,root) %{_libdir}/librav1e.so
131 %{_includedir}/rav1e
132 %{_pkgconfigdir}/rav1e.pc
133
134 %files static
135 %defattr(644,root,root,755)
136 %{_libdir}/librav1e.a
This page took 0.043772 seconds and 3 git commands to generate.