]> git.pld-linux.org Git - packages/raft.git/blob - raft.spec
77b9352f196b9b7196a6232d47525ad2cfe6b7ae
[packages/raft.git] / raft.spec
1 Summary:        Raft consensus protocol library
2 Name:           raft
3 Version:        0.9.25
4 Release:        1
5 License:        LGPLv3
6 Group:          Libraries
7 Source0:        https://github.com/canonical/raft/archive/v%{version}/%{name}-%{version}.tar.gz
8 # Source0-md5:  2da527e4d935d94b84a7e6c0487c7f00
9 URL:            https://github.com/canonical/raft
10 BuildRequires:  autoconf >= 2.50
11 BuildRequires:  automake
12 BuildRequires:  libtool
13 BuildRequires:  libuv-devel
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Fully asynchronous C implementation of the Raft consensus protocol.
18
19 The library has modular design: its core part implements only the core
20 Raft algorithm logic, in a fully platform independent way. On top of
21 that, a pluggable interface defines the I/O implementation for
22 networking (send/receive RPC messages) and disk persistence (store log
23 entries and snapshots).
24
25 %package devel
26 Summary:        Header files for %{name} development
27 Summary(pl.UTF-8):      Pliki nagłówkowe %{name}
28 Group:          Development/Libraries
29 Requires:       %{name} = %{version}-%{release}
30
31 %description devel
32 This package contains development files for the %{name} library.
33
34 %package static
35 Summary:        Static libraries for %{name} development
36 Summary(pl.UTF-8):      Statyczne biblioteki %{name}
37 Group:          Development/Libraries
38 Requires:       %{name}-devel = %{version}-%{release}
39
40 %description static
41 This package contains static %{name} library.
42
43 %prep
44 %setup -q
45
46 %build
47 %{__libtoolize}
48 %{__aclocal}
49 %{__autoconf}
50 %{__automake}
51
52 %configure \
53         --disable-silent-rules
54 %{__make}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %post   -p /sbin/ldconfig
66 %postun -p /sbin/ldconfig
67
68 %files
69 %defattr(644,root,root,755)
70 %doc README.md
71 %attr(755,root,root) %{_libdir}/libraft.so.*.*.*
72 %attr(755,root,root) %ghost %{_libdir}/libraft.so.0
73
74 %files devel
75 %defattr(644,root,root,755)
76 %attr(755,root,root) %{_libdir}/libraft.so
77 %{_libdir}/libraft.la
78 %{_includedir}/raft.h
79 %dir %{_includedir}/raft
80 %{_includedir}/raft/*.h
81 %{_pkgconfigdir}/raft.pc
82
83 %files static
84 %defattr(644,root,root,755)
85 %{_libdir}/libraft.a
This page took 0.060027 seconds and 2 git commands to generate.