]> git.pld-linux.org Git - packages/quazip.git/blob - quazip.spec
- renamed base packages to -qt4* for symmetry
[packages/quazip.git] / quazip.spec
1 #
2 # Conditional build:
3 %bcond_without  qt4             # Qt 4 version
4 %bcond_without  qt5             # Qt 5 version
5 %bcond_without  static_libs     # static libraries
6
7 Summary:        Qt/C++ wrapper for the minizip library
8 Summary(pl.UTF-8):      Obudowanie Qt/C++ do biblioteki minizip
9 Name:           quazip
10 Version:        1.3
11 Release:        1
12 License:        GPL v2+ or LGPL v2+
13 Group:          X11/Libraries
14 #Source0Download: https://github.com/stachenov/quazip/releases
15 Source0:        https://github.com/stachenov/quazip/archive/v%{version}/%{name}-%{version}.tar.gz
16 # Source0-md5:  52b45020f8153a45920cd572d777c6a7
17 Patch0:         cmake.patch
18 URL:            https://stachenov.github.io/quazip/
19 BuildRequires:  cmake >= 3.15
20 BuildRequires:  doxygen
21 BuildRequires:  graphviz
22 BuildRequires:  libstdc++-devel >= 6:5
23 BuildRequires:  rpm-build >= 4.6
24 BuildRequires:  zlib-devel
25 %if %{with qt4}
26 BuildRequires:  QtCore-devel >= 4.5.0
27 BuildRequires:  qt4-build >= 4.5.0
28 BuildRequires:  qt4-qmake >= 4.5.0
29 %endif
30 %if %{with qt5}
31 BuildRequires:  Qt5Core-devel >= 5
32 BuildRequires:  qt5-build >= 5
33 BuildRequires:  qt5-qmake >= 5
34 %endif
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 QuaZIP is a simple C++ wrapper over Gilles Vollant's ZIP/UNZIP package
39 that can be used to access ZIP archives. It uses Trolltech's Qt
40 toolkit.
41
42 QuaZIP allows you to access files inside ZIP archives using QIODevice
43 API, and - yes! - that means that you can also use QTextStream,
44 QDataStream or whatever you would like to use on your zipped files.
45
46 QuaZIP provides complete abstraction of the ZIP/UNZIP API, for both
47 reading from and writing to ZIP archives.
48
49 %description -l pl.UTF-8
50 QuaZIP to proste obudowanie C++ dla pakietu ZIP/UNZIP Gillesa
51 Vollanta, który może być używany do dostępu do archiwów ZIP. QuaZIP
52 wykorzystuje bibliotekę narzędziową Qt firmy Trolltech.
53
54 QuaZIP pozwala na dostęp do plików wewnątrz archiwów ZIP przy użyciu
55 API QIODevice, co oznacza, że można używać QTextStream, QDataStream,
56 jak i innych na zzipowanych plikach.
57
58 QuaZIP udostępnia pełną abstrakcję API ZIP/UNZIP, zarówno dla odczytu,
59 jak i zapisu plikówZIP.
60
61 %package qt4
62 Summary:        Qt 4/C++ wrapper for the minizip library
63 Summary(pl.UTF-8):      Obudowanie Qt 4/C++ do biblioteki minizip
64 Group:          X11/Libraries
65 Requires:       QtCore >= 4.5.0
66 Provides:       quazip = %{version}-%{release}
67 Obsoletes:      quazip < 1.3
68
69 %description qt4
70 QuaZIP is a simple C++ wrapper over Gilles Vollant's ZIP/UNZIP package
71 that can be used to access ZIP archives. It uses Trolltech's Qt
72 toolkit.
73
74 QuaZIP allows you to access files inside ZIP archives using QIODevice
75 API, and - yes! - that means that you can also use QTextStream,
76 QDataStream or whatever you would like to use on your zipped files.
77
78 QuaZIP provides complete abstraction of the ZIP/UNZIP API, for both
79 reading from and writing to ZIP archives.
80
81 %description qt4 -l pl.UTF-8
82 QuaZIP to proste obudowanie C++ dla pakietu ZIP/UNZIP Gillesa
83 Vollanta, który może być używany do dostępu do archiwów ZIP. QuaZIP
84 wykorzystuje bibliotekę narzędziową Qt firmy Trolltech.
85
86 QuaZIP pozwala na dostęp do plików wewnątrz archiwów ZIP przy użyciu
87 API QIODevice, co oznacza, że można używać QTextStream, QDataStream,
88 jak i innych na zzipowanych plikach.
89
90 QuaZIP udostępnia pełną abstrakcję API ZIP/UNZIP, zarówno dla odczytu,
91 jak i zapisu plikówZIP.
92
93 %package qt4-devel
94 Summary:        Development files for QuaZIP (Qt 4 version)
95 Summary(pl.UTF-8):      Pliki programistyczne biblioteki QuaZIP (wersja dla Qt 4)
96 Group:          Development/Libraries
97 Requires:       %{name}-qt4 = %{version}-%{release}
98 Requires:       QtCore-devel >= 4.5.0
99 Requires:       zlib-devel
100 Provides:       quazip-devel = %{version}-%{release}
101 Obsoletes:      quazip-devel < 1.3
102
103 %description qt4-devel
104 This package contains the header files and documentation for
105 developing applications that use QuaZIP with Qt 4.
106
107 %description qt4-devel -l pl.UTF-8
108 Ten pakiet zawiera pliki nagłówkowe oraz dokumentację do tworzenia
109 aplikacji wykorzystujących QuaZIP wraz z Qt 4.
110
111 %package qt4-static
112 Summary:        Static QuaZIP library (Qt 4 version)
113 Summary(pl.UTF-8):      Statyczna biblioteka QuaZIP (wersja dla Qt 4)
114 Group:          Development/Libraries
115 Requires:       %{name}-qt4-devel = %{version}-%{release}
116 Provides:       quazip-static = %{version}-%{release}
117 Obsoletes:      quazip-static < 1.3
118
119 %description qt4-static
120 Static QuaZIP library (Qt 4 version).
121
122 %description qt4-static -l pl.UTF-8
123 Statyczna biblioteka QuaZIP (wersja dla Qt 4).
124
125 %package qt5
126 Summary:        Qt 5/C++ wrapper for the minizip library
127 Summary(pl.UTF-8):      Obudowanie Qt 5/C++ do biblioteki minizip
128 Group:          X11/Libraries
129
130 %description qt5
131 QuaZIP is a simple C++ wrapper over Gilles Vollant's ZIP/UNZIP package
132 that can be used to access ZIP archives. It uses Trolltech's Qt
133 toolkit.
134
135 QuaZIP allows you to access files inside ZIP archives using QIODevice
136 API, and - yes! - that means that you can also use QTextStream,
137 QDataStream or whatever you would like to use on your zipped files.
138
139 QuaZIP provides complete abstraction of the ZIP/UNZIP API, for both
140 reading from and writing to ZIP archives.
141
142 %description qt5 -l pl.UTF-8
143 QuaZIP to proste obudowanie C++ dla pakietu ZIP/UNZIP Gillesa
144 Vollanta, który może być używany do dostępu do archiwów ZIP. QuaZIP
145 wykorzystuje bibliotekę narzędziową Qt firmy Trolltech.
146
147 QuaZIP pozwala na dostęp do plików wewnątrz archiwów ZIP przy użyciu
148 API QIODevice, co oznacza, że można używać QTextStream, QDataStream,
149 jak i innych na zzipowanych plikach.
150
151 QuaZIP udostępnia pełną abstrakcję API ZIP/UNZIP, zarówno dla odczytu,
152 jak i zapisu plikówZIP.
153
154 %package qt5-devel
155 Summary:        Development files for QuaZIP (Qt 5 version)
156 Summary(pl.UTF-8):      Pliki programistyczne biblioteki QuaZIP (wersja dla Qt 5)
157 Group:          Development/Libraries
158 Requires:       %{name}-qt5 = %{version}-%{release}
159 Requires:       Qt5Core-devel >= 5
160 Requires:       zlib-devel
161
162 %description qt5-devel
163 This package contains the header files and documentation for
164 developing applications that use QuaZIP with Qt 5.
165
166 %description qt5-devel -l pl.UTF-8
167 Ten pakiet zawiera pliki nagłówkowe oraz dokumentację do tworzenia
168 aplikacji wykorzystujących QuaZIP wraz z Qt 5.
169
170 %package qt5-static
171 Summary:        Static QuaZIP library (Qt 5 version)
172 Summary(pl.UTF-8):      Statyczna biblioteka QuaZIP (wersja dla Qt 5)
173 Group:          Development/Libraries
174 Requires:       %{name}-qt5-devel = %{version}-%{release}
175
176 %description qt5-static
177 Static QuaZIP library (Qt 5 version).
178
179 %description qt5-static -l pl.UTF-8
180 Statyczna biblioteka QuaZIP (wersja dla Qt 5).
181
182 %package apidocs
183 Summary:        API documentation for QuaZIP libraries
184 Summary(pl.UTF-8):      Dokumentacja API bibliotek QuaZIP
185 Group:          Documentation
186 BuildArch:      noarch
187
188 %description apidocs
189 API documentation for QuaZIP libraries.
190
191 %description apidocs -l pl.UTF-8
192 Dokumentacja API bibliotek QuaZIP.
193
194 %prep
195 %setup -q
196 %patch0 -p1
197
198 %build
199 export CXXFLAGS="%{rpmcxxflags} -fPIC"
200 %if %{with qt4}
201 %cmake -B build-qt4 \
202         -DQUAZIP_QT_MAJOR_VERSION=4
203
204 %{__make} -C build-qt4
205
206 %if %{with static_libs}
207 %cmake -B build-qt4-static \
208         -DBUILD_SHARED_LIBS=OFF \
209         -DQUAZIP_QT_MAJOR_VERSION=4
210
211 %{__make} -C build-qt4-static
212 %endif
213 %endif
214
215 %if %{with qt5}
216 %cmake -B build-qt5 \
217         -DQUAZIP_QT_MAJOR_VERSION=5
218
219 %{__make} -C build-qt5
220
221 %if %{with static_libs}
222 %cmake -B build-qt5-static \
223         -DBUILD_SHARED_LIBS=OFF \
224         -DQUAZIP_QT_MAJOR_VERSION=5
225
226 %{__make} -C build-qt5-static
227 %endif
228 %endif
229
230 doxygen Doxyfile
231 for file in doc/html/*; do
232         touch -r Doxyfile $file
233 done
234
235 %install
236 rm -rf $RPM_BUILD_ROOT
237
238 %if %{with qt4}
239 %{__make} -C build-qt4 install/fast \
240         DESTDIR=$RPM_BUILD_ROOT
241
242 %if %{with static_libs}
243 %{__make} -C build-qt4-static install/fast \
244         DESTDIR=$RPM_BUILD_ROOT
245 %endif
246 %endif
247
248 %if %{with qt5}
249 %{__make} -C build-qt5 install/fast \
250         DESTDIR=$RPM_BUILD_ROOT
251
252 %if %{with static_libs}
253 %{__make} -C build-qt5-static install/fast \
254         DESTDIR=$RPM_BUILD_ROOT
255 %endif
256 %endif
257
258 %clean
259 rm -rf $RPM_BUILD_ROOT
260
261 %post   qt4 -p /sbin/ldconfig
262 %postun qt4 -p /sbin/ldconfig
263
264 %post   qt5 -p /sbin/ldconfig
265 %postun qt5 -p /sbin/ldconfig
266
267 %if %{with qt4}
268 %files qt4
269 %defattr(644,root,root,755)
270 %doc COPYING NEWS.txt README.md
271 %attr(755,root,root) %{_libdir}/libquazip1-qt4.so.*.*.*
272 %attr(755,root,root) %ghost %{_libdir}/libquazip1-qt4.so.1.3
273
274 %files qt4-devel
275 %defattr(644,root,root,755)
276 %attr(755,root,root) %{_libdir}/libquazip1-qt4.so
277 %{_includedir}/QuaZip-Qt4-1.3
278 %{_libdir}/cmake/QuaZip-Qt4-1.3
279 %{_pkgconfigdir}/quazip1-qt4.pc
280
281 %if %{with static_libs}
282 %files qt4-static
283 %defattr(644,root,root,755)
284 %{_libdir}/libquazip1-qt4.a
285 %endif
286 %endif
287
288 %if %{with qt5}
289 %files qt5
290 %defattr(644,root,root,755)
291 %doc COPYING NEWS.txt README.md
292 %attr(755,root,root) %{_libdir}/libquazip1-qt5.so.*.*.*
293 %attr(755,root,root) %ghost %{_libdir}/libquazip1-qt5.so.1.3
294
295 %files qt5-devel
296 %defattr(644,root,root,755)
297 %attr(755,root,root) %{_libdir}/libquazip1-qt5.so
298 %{_includedir}/QuaZip-Qt5-1.3
299 %{_libdir}/cmake/QuaZip-Qt5-1.3
300 %{_pkgconfigdir}/quazip1-qt5.pc
301
302 %if %{with static_libs}
303 %files qt5-static
304 %defattr(644,root,root,755)
305 %{_libdir}/libquazip1-qt5.a
306 %endif
307 %endif
308
309 %files apidocs
310 %defattr(644,root,root,755)
311 %doc doc/html/*.{css,html,js,png}
This page took 0.498098 seconds and 3 git commands to generate.