]> git.pld-linux.org Git - packages/qt5-qtx11extras.git/blob - qt5-qtx11extras.spec
- up to 5.8.0
[packages/qt5-qtx11extras.git] / qt5-qtx11extras.spec
1 #
2 # Conditional build:
3 %bcond_without  qch     # documentation in QCH format
4
5 %define         orgname         qtx11extras
6 %define         qtbase_ver      %{version}
7 %define         qttools_ver     %{version}
8 Summary:        The Qt5 X11 Extras library
9 Summary(pl.UTF-8):      Biblioteka Qt5 X11 Extras
10 Name:           qt5-%{orgname}
11 Version:        5.8.0
12 Release:        1
13 License:        LGPL v2.1 with Digia Qt LGPL Exception v1.1 or GPL v3.0
14 Group:          X11/Libraries
15 Source0:        http://download.qt.io/official_releases/qt/5.8/%{version}/submodules/%{orgname}-opensource-src-%{version}.tar.xz
16 # Source0-md5:  a29256a11122e68e8507433d34d9f9ae
17 URL:            http://www.qt.io/
18 BuildRequires:  Qt5Core-devel >= %{qtbase_ver}
19 BuildRequires:  Qt5Gui-devel >= %{qtbase_ver}
20 %if %{with qch}
21 BuildRequires:  qt5-assistant >= %{qttools_ver}
22 %endif
23 BuildRequires:  qt5-build >= %{qtbase_ver}
24 BuildRequires:  qt5-qmake >= %{qtbase_ver}
25 BuildRequires:  rpmbuild(macros) >= 1.654
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         specflags       -fno-strict-aliasing
31 %define         qt5dir          %{_libdir}/qt5
32
33 %description
34 Qt is a cross-platform application and UI framework. Using Qt, you can
35 write web-enabled applications once and deploy them across desktop,
36 mobile and embedded systems without rewriting the source code.
37
38 This package contains Qt5 X11 Extras library.
39
40 %description -l pl.UTF-8
41 Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
42 Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
43 systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
44 źródłowego.
45
46 Ten pakiet zawiera bibliotekę Qt5 X11 Extras.
47
48 %package -n Qt5X11Extras
49 Summary:        The Qt5 X11 Extras library
50 Summary(pl.UTF-8):      Biblioteka Qt5 X11 Extras
51 Group:          Libraries
52 Requires:       Qt5Core >= %{qtbase_ver}
53 Requires:       Qt5Gui >= %{qtbase_ver}
54 Obsoletes:      qt5-qtx11extas
55
56 %description -n Qt5X11Extras
57 Qt5 X11 Extras library provides classes for developing for the X11
58 platform.
59
60 %description -n Qt5X11Extras -l pl.UTF-8
61 Biblioteka Qt5 X11 Extras dostarcza klasy do tworzenia oprogramowania
62 dla platformy X11.
63
64 %package -n Qt5X11Extras-devel
65 Summary:        Qt5 X11 Extras - development files
66 Summary(pl.UTF-8):      Biblioteka Qt5 X11 Extras - pliki programistyczne
67 Group:          X11/Development/Libraries
68 Requires:       OpenGL-devel
69 Requires:       Qt5Core-devel >= %{qtbase_ver}
70 Requires:       Qt5Gui-devel >= %{qtbase_ver}
71 Requires:       Qt5X11Extras = %{version}-%{release}
72 Obsoletes:      qt5-qtx11extas-devel
73
74 %description -n Qt5X11Extras-devel
75 Qt5 X11 Extras - development files.
76
77 %description -n Qt5X11Extras-devel -l pl.UTF-8
78 Biblioteka Qt5 X11 Extras - pliki programistyczne.
79
80 %package doc
81 Summary:        Qt5 X11 Extras documentation in HTML format
82 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 X11 Extras w formacie HTML
83 Group:          Documentation
84 Requires:       qt5-doc-common >= %{qtbase_ver}
85 %if "%{_rpmversion}" >= "5"
86 BuildArch:      noarch
87 %endif
88
89 %description doc
90 Qt5 X11 Extras documentation in HTML format.
91
92 %description doc -l pl.UTF-8
93 Dokumentacja do biblioteki Qt5 X11 Extras w formacie HTML.
94
95 %package doc-qch
96 Summary:        Qt5 X11 Extras documentation in QCH format
97 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 X11 Extras w formacie QCH
98 Group:          Documentation
99 Requires:       qt5-doc-common >= %{qtbase_ver}
100 %if "%{_rpmversion}" >= "5"
101 BuildArch:      noarch
102 %endif
103
104 %description doc-qch
105 Qt5 X11 Extras documentation in QCH format.
106
107 %description doc-qch -l pl.UTF-8
108 Dokumentacja do biblioteki Qt5 X11 Extras w formacie QCH.
109
110 %prep
111 %setup -q -n %{orgname}-opensource-src-%{version}
112
113 %build
114 qmake-qt5
115 %{__make}
116 %{__make} %{!?with_qch:html_}docs
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 %{__make} install \
121         INSTALL_ROOT=$RPM_BUILD_ROOT
122
123 %{__make} install_%{!?with_qch:html_}docs \
124         INSTALL_ROOT=$RPM_BUILD_ROOT
125
126 # useless symlinks
127 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.?
128 # actually drop *.la, follow policy of not packaging them when *.pc exist
129 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post   -n Qt5X11Extras -p /sbin/ldconfig
135 %postun -n Qt5X11Extras -p /sbin/ldconfig
136
137 %files -n Qt5X11Extras
138 %defattr(644,root,root,755)
139 %doc LGPL_EXCEPTION.txt dist/changes-*
140 %attr(755,root,root) %{_libdir}/libQt5X11Extras.so.*.*.*
141 %attr(755,root,root) %ghost %{_libdir}/libQt5X11Extras.so.5
142
143 %files -n Qt5X11Extras-devel
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_libdir}/libQt5X11Extras.so
146 %{_libdir}/libQt5X11Extras.prl
147 %{_includedir}/qt5/QtX11Extras
148 %{_pkgconfigdir}/Qt5X11Extras.pc
149 %{_libdir}/cmake/Qt5X11Extras
150 %{qt5dir}/mkspecs/modules/qt_lib_x11extras.pri
151 %{qt5dir}/mkspecs/modules/qt_lib_x11extras_private.pri
152
153 %files doc
154 %defattr(644,root,root,755)
155 %{_docdir}/qt5-doc/qtx11extras
156
157 %if %{with qch}
158 %files doc-qch
159 %defattr(644,root,root,755)
160 %{_docdir}/qt5-doc/qtx11extras.qch
161 %endif
This page took 0.072681 seconds and 3 git commands to generate.