]> git.pld-linux.org Git - packages/qt5-qtwayland.git/blob - qt5-qtwayland.spec
a3b454ecbef6d373a00031add263842168c4c264
[packages/qt5-qtwayland.git] / qt5-qtwayland.spec
1 # TODO:
2 # - brcm_egl, libhybris_egl_server
3 # - enable docs & examples when ready upstream
4 # - QtCompositor API (CONFIG+=wayland-compositor)?
5 #
6 # Conditional build:
7 %bcond_with     qch     # documentation in QCH format [TODO: enable when docs exist]
8
9 %define         orgname         qtwayland
10 %define         qtbase_ver              %{version}
11 %define         qtdeclarative_ver       %{version}
12 %define         qttools_ver             %{version}
13 Summary:        The Qt5 Wayland libraries
14 Summary(pl.UTF-8):      Biblioteki Qt5 Wayland
15 Name:           qt5-%{orgname}
16 Version:        5.4.1
17 Release:        1
18 License:        LGPL v2.1 with Digia Qt LGPL Exception v1.1 or GPL v3.0
19 Group:          Libraries
20 Source0:        http://download.qt.io/official_releases/qt/5.4/%{version}/submodules/%{orgname}-opensource-src-%{version}.tar.xz
21 # Source0-md5:  a132295b896062d21ded0937a56d22a3
22 URL:            http://qt-project.org/
23 BuildRequires:  EGL-devel
24 BuildRequires:  Mesa-libwayland-egl-devel
25 BuildRequires:  OpenGL-GLX-devel
26 BuildRequires:  Qt5Core-devel >= %{qtbase_ver}
27 BuildRequires:  Qt5PlatformSupport-devel >= %{qtbase_ver}
28 BuildRequires:  Qt5Gui-devel >= %{qtbase_ver}
29 BuildRequires:  pkgconfig
30 %if %{with qch}
31 BuildRequires:  qt5-assistant >= %{qttools_ver}
32 %endif
33 BuildRequires:  qt5-build >= %{qtbase_ver}
34 BuildRequires:  qt5-qmake >= %{qtbase_ver}
35 BuildRequires:  rpmbuild(macros) >= 1.654
36 BuildRequires:  tar >= 1:1.22
37 BuildRequires:  wayland-devel >= 1.2.0
38 BuildRequires:  xorg-lib-libXcomposite-devel
39 BuildRequires:  xorg-lib-libxkbcommon-devel >= 0.2.0
40 BuildRequires:  xz
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         specflags       -fno-strict-aliasing
44 %define         qt5dir          %{_libdir}/qt5
45
46 %description
47 Qt is a cross-platform application and UI framework. Using Qt, you can
48 write web-enabled applications once and deploy them across desktop,
49 mobile and embedded systems without rewriting the source code.
50
51 This package contains Qt5 Wayland libraries.
52
53 %description -l pl.UTF-8
54 Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
55 Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
56 systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
57 źródłowego.
58
59 Ten pakiet zawiera biblioteki Qt5 Wayland.
60
61 %package -n Qt5WaylandClient
62 Summary:        The Qt5 WaylandClient library
63 Summary(pl.UTF-8):      Biblioteka Qt5 WaylandClient
64 Group:          Libraries
65 Requires:       Qt5Core >= %{qtbase_ver}
66 Requires:       Qt5Gui >= %{qtbase_ver}
67
68 %description -n Qt5WaylandClient
69 Qt5 WaylandClient library enables Qt applications to be run as Wayland
70 clients.
71
72 %description -n Qt5WaylandClient -l pl.UTF-8
73 Biblioteka Qt5 WaylandClient pozwala na uruchamianie aplikacji Qt jako
74 klientów Wayland.
75
76 %package -n Qt5WaylandClient-devel
77 Summary:        Qt5 WaylandClient library - development files
78 Summary(pl.UTF-8):      Biblioteka Qt5 WaylandClient - pliki programistyczne
79 Group:          Development/Libraries
80 Requires:       Qt5Core-devel >= %{qtbase_ver}
81 Requires:       Qt5DBus-devel >= %{qtbase_ver}
82 Requires:       Qt5Gui-devel >= %{qtbase_ver}
83 Requires:       Qt5PlatformSupport-devel >= %{qtbase_ver}
84 Requires:       Qt5WaylandClient = %{version}-%{release}
85 Requires:       wayland-devel
86 Requires:       xorg-lib-libxkbcommon-devel
87
88 %description -n Qt5WaylandClient-devel
89 Qt5 WaylandClient library - development files.
90
91 %description -n Qt5WaylandClient-devel -l pl.UTF-8
92 Biblioteka Qt5 WaylandClient - pliki programistyczne.
93
94 %package doc
95 Summary:        Qt5 Wayland documentation in HTML format
96 Summary(pl.UTF-8):      Dokumentacja do bibliotek Qt5 Wayland w formacie HTML
97 Group:          Documentation
98 Requires:       qt5-doc-common >= %{qtbase_ver}
99 %if "%{_rpmversion}" >= "5"
100 BuildArch:      noarch
101 %endif
102
103 %description doc
104 Qt5 Wayland documentation in HTML format.
105
106 %description doc -l pl.UTF-8
107 Dokumentacja do bibliotek Qt5 Wayland w formacie HTML.
108
109 %package doc-qch
110 Summary:        Qt5 Wayland documentation in QCH format
111 Summary(pl.UTF-8):      Dokumentacja do bibliotek Qt5 Wayland w formacie QCH
112 Group:          Documentation
113 Requires:       qt5-doc-common >= %{qtbase_ver}
114 %if "%{_rpmversion}" >= "5"
115 BuildArch:      noarch
116 %endif
117
118 %description doc-qch
119 Qt5 Wayland documentation in QCH format.
120
121 %description doc-qch -l pl.UTF-8
122 Dokumentacja do bibliotek Qt5 Wayland w formacie QCH.
123
124 %package examples
125 Summary:        Qt5 Wayland examples
126 Summary(pl.UTF-8):      Przykłady do bibliotek Qt5 Wayland
127 Group:          X11/Development/Libraries
128 %if "%{_rpmversion}" >= "5"
129 BuildArch:      noarch
130 %endif
131
132 %description examples
133 Qt5 Wayland examples.
134
135 %description examples -l pl.UTF-8
136 Przykłady do bibliotek Qt5 Wayland.
137
138 %prep
139 %setup -q -n %{orgname}-opensource-src-%{version}
140
141 %build
142 qmake-qt5
143 %{__make}
144 %{__make} %{!?with_qch:html_}docs
145
146 %install
147 rm -rf $RPM_BUILD_ROOT
148 %{__make} install \
149         INSTALL_ROOT=$RPM_BUILD_ROOT
150
151 %{__make} install_%{!?with_qch:html_}docs \
152         INSTALL_ROOT=$RPM_BUILD_ROOT
153
154 # useless symlinks
155 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5WaylandClient.so.5.?
156 # actually drop *.la, follow policy of not packaging them when *.pc exist
157 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5WaylandClient.la
158
159 # no proper cmake support as of 5.4.1
160 %{__rm} $RPM_BUILD_ROOT%{_libdir}/cmake/{Qt5Gui/Qt5Gui_,Qt5WaylandClient/Qt5WaylandClient_}.cmake
161
162 # Prepare some files list
163 ifecho() {
164         r="$RPM_BUILD_ROOT$2"
165         if [ -d "$r" ]; then
166                 echo "%%dir $2" >> $1.files
167         elif [ -x "$r" ] ; then
168                 echo "%%attr(755,root,root) $2" >> $1.files
169         elif [ -f "$r" ]; then
170                 echo "$2" >> $1.files
171         else
172                 echo "Error generation $1 files list!"
173                 echo "$r: no such file or directory!"
174                 return 1
175         fi
176 }
177 ifecho_tree() {
178         ifecho $1 $2
179         for f in `find $RPM_BUILD_ROOT$2 -printf "%%P "`; do
180                 ifecho $1 $2/$f
181         done
182 }
183
184 # examples not enabled in sources as of 5.4.1
185 #echo "%defattr(644,root,root,755)" > examples.files
186 #ifecho_tree examples %{_examplesdir}/qt5/enginio
187
188 %clean
189 rm -rf $RPM_BUILD_ROOT
190
191 %post   -n Qt5WaylandClient -p /sbin/ldconfig
192 %postun -n Qt5WaylandClient -p /sbin/ldconfig
193
194 %files -n Qt5WaylandClient
195 %defattr(644,root,root,755)
196 %doc LGPL_EXCEPTION.txt README
197 # dist/changes-*
198 %attr(755,root,root) %{_libdir}/libQt5WaylandClient.so.*.*.*
199 %attr(755,root,root) %ghost %{_libdir}/libQt5WaylandClient.so.5
200 %attr(755,root,root) %{qt5dir}/bin/qtwaylandscanner
201 %attr(755,root,root) %{qt5dir}/plugins/platforms/libqwayland-egl.so
202 %attr(755,root,root) %{qt5dir}/plugins/platforms/libqwayland-generic.so
203 %dir %{qt5dir}/plugins/wayland-decoration-client
204 %attr(755,root,root) %{qt5dir}/plugins/wayland-decoration-client/libbradient.so
205 %dir %{qt5dir}/plugins/wayland-graphics-integration-client
206 %attr(755,root,root) %{qt5dir}/plugins/wayland-graphics-integration-client/libdrm-egl-server.so
207 %attr(755,root,root) %{qt5dir}/plugins/wayland-graphics-integration-client/libwayland-egl.so
208 %attr(755,root,root) %{qt5dir}/plugins/wayland-graphics-integration-client/libxcomposite-egl.so
209 %attr(755,root,root) %{qt5dir}/plugins/wayland-graphics-integration-client/libxcomposite-glx.so
210
211 %files -n Qt5WaylandClient-devel
212 %defattr(644,root,root,755)
213 %attr(755,root,root) %{_libdir}/libQt5WaylandClient.so
214 %{_libdir}/libQt5WaylandClient.prl
215 %{_includedir}/qt5/QtWaylandClient
216 %{_pkgconfigdir}/Qt5WaylandClient.pc
217 # FIXME (see above)
218 #%{_libdir}/cmake/Qt5Gui/Qt5Gui_???.cmake
219 #%{_libdir}/cmake/Qt5WaylandClient
220 %{qt5dir}/mkspecs/modules/qt_lib_waylandclient.pri
221 %{qt5dir}/mkspecs/modules/qt_lib_waylandclient_private.pri
222
223 # not finished
224 %if 0
225 %files doc
226 %defattr(644,root,root,755)
227 %{_docdir}/qt5-doc/qtenginio
228 %{_docdir}/qt5-doc/qtenginiooverview
229 %{_docdir}/qt5-doc/qtenginioqml
230
231 %if %{with qch}
232 %files doc-qch
233 %defattr(644,root,root,755)
234 %{_docdir}/qt5-doc/qtenginio.qch
235 %{_docdir}/qt5-doc/qtenginiooverview.qch
236 %{_docdir}/qt5-doc/qtenginioqml.qch
237 %endif
238 %endif
239
240 # not finished
241 %if 0
242 %files examples -f examples.files
243 %defattr(644,root,root,755)
244 # XXX: dir shared with qt5-qtbase-examples
245 %dir %{_examplesdir}/qt5
246 %endif
This page took 0.0914740000000001 seconds and 2 git commands to generate.