]> git.pld-linux.org Git - packages/qt5-qtsvg.git/blob - qt5-qtsvg.spec
noarch -doc, -examples; tar.xz deps
[packages/qt5-qtsvg.git] / qt5-qtsvg.spec
1 # TODO:
2 # - cleanup
3
4 %define         orgname         qtsvg
5 Summary:        The Qt5 Svg
6 Name:           qt5-%{orgname}
7 Version:        5.2.0
8 Release:        0.1
9 License:        LGPL v2.1 or GPL v3.0
10 Group:          X11/Libraries
11 Source0:        http://download.qt-project.org/official_releases/qt/5.2/%{version}/submodules/%{orgname}-opensource-src-%{version}.tar.xz
12 # Source0-md5:  3f6132475f6edcd7b6cfb57650846185
13 URL:            http://qt-project.org/
14 BuildRequires:  qt5-qtbase-devel = %{version}
15 BuildRequires:  qt5-qttools-devel = %{version}
16 BuildRequires:  rpmbuild(macros) >= 1.654
17 BuildRequires:  tar >= 1:1.22
18 BuildRequires:  xz
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
22 %define         _noautostrip    '.*_debug\\.so*'
23
24 %define         specflags       -fno-strict-aliasing
25 %define         _qtdir          %{_libdir}/qt5
26
27 %description
28 Qt5 Svg libraries.
29
30 %package devel
31 Summary:        The Qt5 Svg - development files
32 Group:          X11/Development/Libraries
33 Requires:       %{name} = %{version}-%{release}
34
35 %description devel
36 Qt5 Svg - development files.
37
38 %package doc
39 Summary:        The Qt5 Svg - docs
40 Group:          Documentation
41 %if "%{_rpmversion}" >= "5"
42 BuildArch:      noarch
43 %endif
44
45 %description doc
46 Qt5 Svg - documentation.
47
48 %package examples
49 Summary:        Qt5 Svg examples
50 Group:          X11/Development/Libraries
51 %if "%{_rpmversion}" >= "5"
52 BuildArch:      noarch
53 %endif
54
55 %description examples
56 Qt5 Svg - examples.
57
58 %prep
59 %setup -q -n %{orgname}-opensource-src-%{version}
60
61 %build
62 qmake-qt5
63 %{__make}
64 %{__make} docs
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 %{__make} install \
69         INSTALL_ROOT=$RPM_BUILD_ROOT
70
71 %{__make} install_docs \
72         INSTALL_ROOT=$RPM_BUILD_ROOT
73
74 # Prepare some files list
75 ifecho() {
76         RESULT=`echo $RPM_BUILD_ROOT$2 2>/dev/null`
77         [ "$RESULT" == "" ] && return # XXX this is never true due $RPM_BUILD_ROOT being set
78         r=`echo $RESULT | awk '{ print $1 }'`
79
80         if [ -d "$r" ]; then
81                 echo "%%dir $2" >> $1.files
82         elif [ -x "$r" ] ; then
83                 echo "%%attr(755,root,root) $2" >> $1.files
84         elif [ -f "$r" ]; then
85                 echo "$2" >> $1.files
86         else
87                 echo "Error generation $1 files list!"
88                 echo "$r: no such file or directory!"
89                 return 1
90         fi
91 }
92
93 echo "%defattr(644,root,root,755)" > examples.files
94 ifecho examples %{_examplesdir}/qt5
95 for f in `find $RPM_BUILD_ROOT%{_examplesdir}/qt5 -printf "%%P "`; do
96         ifecho examples %{_examplesdir}/qt5/$f
97 done
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post           -p /sbin/ldconfig
103 %postun         -p /sbin/ldconfig
104
105 %files
106 %defattr(644,root,root,755)
107 %attr(755,root,root) %ghost %{_libdir}/libQt5Svg.so.?
108 %attr(755,root,root) %{_libdir}/libQt5Svg.so.*.*
109 %attr(755,root,root) %{_qtdir}/plugins
110
111 %files devel
112 %defattr(644,root,root,755)
113 %attr(755,root,root) %{_libdir}/libQt5Svg.so
114 %{_libdir}/libQt5Svg.la
115 %{_libdir}/libQt5Svg.prl
116 %{_libdir}/cmake/Qt5Gui
117 %{_libdir}/cmake/Qt5Svg
118 %{_includedir}/qt5/QtSvg
119 %{_pkgconfigdir}/*.pc
120 %{_qtdir}/mkspecs
121
122 %files doc
123 %defattr(644,root,root,755)
124 %{_docdir}/qt5-doc
125
126 %files examples -f examples.files
This page took 0.104961 seconds and 3 git commands to generate.