]> git.pld-linux.org Git - packages/qt5-qtsvg.git/blob - qt5-qtsvg.spec
- up to 5.11.1
[packages/qt5-qtsvg.git] / qt5-qtsvg.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Documentation
4
5 %define         orgname         qtsvg
6 %define         qtbase_ver      %{version}
7 %define         qttools_ver     %{version}
8 Summary:        The Qt5 Svg library
9 Summary(pl.UTF-8):      Biblioteka Qt5 Svg
10 Name:           qt5-%{orgname}
11 Version:        5.11.1
12 Release:        1
13 License:        LGPL v2.1 with Digia Qt LGPL Exception v1.1 or GPL v3.0
14 Group:          X11/Libraries
15 Source0:        http://download.qt.io/official_releases/qt/5.11/%{version}/submodules/%{orgname}-everywhere-src-%{version}.tar.xz
16 # Source0-md5:  c7dfa4b3504105ec45f888c9012d1969
17 URL:            http://www.qt.io/
18 BuildRequires:  Qt5Core-devel >= %{qtbase_ver}
19 BuildRequires:  Qt5Gui-devel >= %{qtbase_ver}
20 BuildRequires:  Qt5OpenGL-devel >= %{qtbase_ver}
21 BuildRequires:  Qt5Widgets-devel >= %{qtbase_ver}
22 BuildRequires:  Qt5Xml-devel >= %{qtbase_ver}
23 %if %{with doc}
24 BuildRequires:  qt5-assistant >= %{qttools_ver}
25 %endif
26 BuildRequires:  qt5-build >= %{qtbase_ver}
27 BuildRequires:  qt5-qmake >= %{qtbase_ver}
28 BuildRequires:  rpmbuild(macros) >= 1.654
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  xz
31 BuildRequires:  zlib-devel
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         specflags       -fno-strict-aliasing
35 %define         qt5dir          %{_libdir}/qt5
36
37 %description
38 Qt is a cross-platform application and UI framework. Using Qt, you can
39 write web-enabled applications once and deploy them across desktop,
40 mobile and embedded systems without rewriting the source code.
41
42 This package contains Qt5 Svg library.
43
44 %description -l pl.UTF-8
45 Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
46 Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
47 systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
48 źródłowego.
49
50 Ten pakiet zawiera bibliotekę Qt5 Svg.
51
52 %package -n Qt5Svg
53 Summary:        The Qt5 Svg library
54 Summary(pl.UTF-8):      Biblioteka Qt5 Svg
55 Group:          Libraries
56 Requires:       Qt5Core >= %{qtbase_ver}
57 Requires:       Qt5Gui >= %{qtbase_ver}
58 Requires:       Qt5Widgets >= %{qtbase_ver}
59 Obsoletes:      qt5-qtsvg
60
61 %description -n Qt5Svg
62 Qt5 Svg library provides functionality for handling SVG images.
63
64 %description -n Qt5Svg -l pl.UTF-8
65 Biblioteka Qt5 Svg udostępnia obsługę obrazów SVG.
66
67 %package -n Qt5Svg-devel
68 Summary:        Qt5 Svg library - development files
69 Summary(pl.UTF-8):      Biblioteka Qt5 Svg - pliki programistyczne
70 Group:          X11/Development/Libraries
71 Requires:       OpenGL-devel
72 Requires:       Qt5Core-devel >= %{qtbase_ver}
73 Requires:       Qt5Gui-devel >= %{qtbase_ver}
74 Requires:       Qt5Svg = %{version}-%{release}
75 Requires:       Qt5Widgets-devel >= %{qtbase_ver}
76 Requires:       zlib-devel
77 Obsoletes:      qt5-qtsvg-devel
78
79 %description -n Qt5Svg-devel
80 Qt5 Svg library - development files.
81
82 %description -n Qt5Svg-devel -l pl.UTF-8
83 Biblioteka Qt5 Svg - pliki programistyczne.
84
85 %package doc
86 Summary:        Qt5 Svg documentation in HTML format
87 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 Svg w formacie HTML
88 Group:          Documentation
89 Requires:       qt5-doc-common >= %{qtbase_ver}
90 %if "%{_rpmversion}" >= "5"
91 BuildArch:      noarch
92 %endif
93
94 %description doc
95 Qt5 Svg documentation in HTML format.
96
97 %description doc -l pl.UTF-8
98 Dokumentacja do biblioteki Qt5 Svg w formacie HTML.
99
100 %package doc-qch
101 Summary:        Qt5 Svg documentation in QCH format
102 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 Svg w formacie QCH
103 Group:          Documentation
104 Requires:       qt5-doc-common >= %{qtbase_ver}
105 %if "%{_rpmversion}" >= "5"
106 BuildArch:      noarch
107 %endif
108
109 %description doc-qch
110 Qt5 Svg documentation in QCH format.
111
112 %description doc-qch -l pl.UTF-8
113 Dokumentacja do biblioteki Qt5 Svg w formacie QCH.
114
115 %package examples
116 Summary:        Qt5 Svg examples
117 Summary(pl.UTF-8):      Przykłady do biblioteki Qt5 Svg
118 Group:          X11/Development/Libraries
119 %if "%{_rpmversion}" >= "5"
120 BuildArch:      noarch
121 %endif
122
123 %description examples
124 Qt5 Svg examples.
125
126 %description examples -l pl.UTF-8
127 Przykłady do biblioteki Qt5 Svg.
128
129 %prep
130 %setup -q -n %{orgname}-everywhere-src-%{version}
131
132 %build
133 qmake-qt5
134 %{__make}
135 %{?with_doc:%{__make} docs}
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139 %{__make} install \
140         INSTALL_ROOT=$RPM_BUILD_ROOT
141
142 %if %{with doc}
143 %{__make} install_docs \
144         INSTALL_ROOT=$RPM_BUILD_ROOT
145 %endif
146
147 # useless symlinks
148 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.??
149 # actually drop *.la, follow policy of not packaging them when *.pc exist
150 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
151
152 # Prepare some files list
153 ifecho() {
154         r="$RPM_BUILD_ROOT$2"
155         if [ -d "$r" ]; then
156                 echo "%%dir $2" >> $1.files
157         elif [ -x "$r" ] ; then
158                 echo "%%attr(755,root,root) $2" >> $1.files
159         elif [ -f "$r" ]; then
160                 echo "$2" >> $1.files
161         else
162                 echo "Error generation $1 files list!"
163                 echo "$r: no such file or directory!"
164                 return 1
165         fi
166 }
167 ifecho_tree() {
168         ifecho $1 $2
169         for f in `find $RPM_BUILD_ROOT$2 -printf "%%P "`; do
170                 ifecho $1 $2/$f
171         done
172 }
173
174 echo "%defattr(644,root,root,755)" > examples.files
175 ifecho_tree examples %{_examplesdir}/qt5/svg
176
177 %clean
178 rm -rf $RPM_BUILD_ROOT
179
180 %post   -n Qt5Svg -p /sbin/ldconfig
181 %postun -n Qt5Svg -p /sbin/ldconfig
182
183 %files -n Qt5Svg
184 %defattr(644,root,root,755)
185 %doc LGPL_EXCEPTION.txt dist/changes-*
186 %attr(755,root,root) %{_libdir}/libQt5Svg.so.*.*.*
187 %attr(755,root,root) %ghost %{_libdir}/libQt5Svg.so.5
188 %attr(755,root,root) %{qt5dir}/plugins/iconengines/libqsvgicon.so
189 %attr(755,root,root) %{qt5dir}/plugins/imageformats/libqsvg.so
190
191 %files -n Qt5Svg-devel
192 %defattr(644,root,root,755)
193 %attr(755,root,root) %{_libdir}/libQt5Svg.so
194 %{_libdir}/libQt5Svg.prl
195 %{_includedir}/qt5/QtSvg
196 %{_pkgconfigdir}/Qt5Svg.pc
197 %dir %{_libdir}/cmake/Qt5Svg
198 %{_libdir}/cmake/Qt5Svg/Qt5SvgConfig*.cmake
199 %{_libdir}/cmake/Qt5Svg/Qt5Svg_QSvgIconPlugin.cmake
200 %{_libdir}/cmake/Qt5Svg/Qt5Svg_QSvgPlugin.cmake
201 %{qt5dir}/mkspecs/modules/qt_lib_svg.pri
202 %{qt5dir}/mkspecs/modules/qt_lib_svg_private.pri
203
204 %if %{with doc}
205 %files doc
206 %defattr(644,root,root,755)
207 %{_docdir}/qt5-doc/qtsvg
208
209 %files doc-qch
210 %defattr(644,root,root,755)
211 %{_docdir}/qt5-doc/qtsvg.qch
212 %endif
213
214 %files examples -f examples.files
215 %defattr(644,root,root,755)
216 # XXX: dir shared with qt5-qtbase-examples
217 %dir %{_examplesdir}/qt5
This page took 0.085733 seconds and 3 git commands to generate.