]> git.pld-linux.org Git - packages/qt5-qtsvg.git/blob - qt5-qtsvg.spec
24f8128237108c128cbfbd83bba9300f80233e1e
[packages/qt5-qtsvg.git] / qt5-qtsvg.spec
1 # TODO:
2 # - cleanup
3
4 %define         orgname         qtsvg
5 Summary:        The Qt5 Svg
6 Name:           qt5-%{orgname}
7 Version:        5.2.0
8 Release:        0.1
9 License:        LGPL v2.1 or GPL v3.0
10 Group:          X11/Libraries
11 Source0:        http://download.qt-project.org/official_releases/qt/5.2/%{version}/submodules/%{orgname}-opensource-src-%{version}.tar.xz
12 # Source0-md5:  3f6132475f6edcd7b6cfb57650846185
13 URL:            http://qt-project.org/
14 BuildRequires:  qt5-qtbase-devel = %{version}
15 BuildRequires:  qt5-qttools-devel = %{version}
16 BuildRequires:  rpmbuild(macros) >= 1.654
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
20 %define         _noautostrip    '.*_debug\\.so*'
21
22 %define         specflags       -fno-strict-aliasing
23 %define         _qtdir          %{_libdir}/qt5
24
25 %description
26 Qt5 Svg libraries.
27
28 %package devel
29 Summary:        The Qt5 Svg - development files
30 Group:          X11/Development/Libraries
31 Requires:       %{name} = %{version}-%{release}
32
33 %description devel
34 Qt5 Svg - development files.
35
36 %package doc
37 Summary:        The Qt5 Svg - docs
38 Group:          Documentation
39
40 %description doc
41 Qt5 Svg - documentation.
42
43 %package examples
44 Summary:        Qt5 Svg examples
45 Group:          X11/Development/Libraries
46
47 %description examples
48 Qt5 Svg - examples.
49
50 %prep
51 %setup -q -n %{orgname}-opensource-src-%{version}
52
53 %build
54 qmake-qt5
55 %{__make}
56 %{__make} docs
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 %{__make} install \
61         INSTALL_ROOT=$RPM_BUILD_ROOT
62
63 %{__make} install_docs \
64         INSTALL_ROOT=$RPM_BUILD_ROOT
65
66 # Prepare some files list
67 ifecho() {
68         RESULT=`echo $RPM_BUILD_ROOT$2 2>/dev/null`
69         [ "$RESULT" == "" ] && return # XXX this is never true due $RPM_BUILD_ROOT being set
70         r=`echo $RESULT | awk '{ print $1 }'`
71
72         if [ -d "$r" ]; then
73                 echo "%%dir $2" >> $1.files
74         elif [ -x "$r" ] ; then
75                 echo "%%attr(755,root,root) $2" >> $1.files
76         elif [ -f "$r" ]; then
77                 echo "$2" >> $1.files
78         else
79                 echo "Error generation $1 files list!"
80                 echo "$r: no such file or directory!"
81                 return 1
82         fi
83 }
84
85 echo "%defattr(644,root,root,755)" > examples.files
86 ifecho examples %{_examplesdir}/qt5
87 for f in `find $RPM_BUILD_ROOT%{_examplesdir}/qt5 -printf "%%P "`; do
88         ifecho examples %{_examplesdir}/qt5/$f
89 done
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post           -p /sbin/ldconfig
95 %postun         -p /sbin/ldconfig
96
97 %files
98 %defattr(644,root,root,755)
99 %attr(755,root,root) %ghost %{_libdir}/libQt5Svg.so.?
100 %attr(755,root,root) %{_libdir}/libQt5Svg.so.*.*
101 %attr(755,root,root) %{_qtdir}/plugins
102
103 %files devel
104 %defattr(644,root,root,755)
105 %attr(755,root,root) %{_libdir}/libQt5Svg.so
106 %{_libdir}/libQt5Svg.la
107 %{_libdir}/libQt5Svg.prl
108 %{_libdir}/cmake/Qt5Gui
109 %{_libdir}/cmake/Qt5Svg
110 %{_includedir}/qt5/QtSvg
111 %{_pkgconfigdir}/*.pc
112 %{_qtdir}/mkspecs
113
114 %files doc
115 %defattr(644,root,root,755)
116 %{_docdir}/qt5-doc
117
118 %files examples -f examples.files
This page took 0.075698 seconds and 2 git commands to generate.