]> git.pld-linux.org Git - packages/qt5-qtspeech.git/blob - qt5-qtspeech.spec
683b748feee81e15a7b41c7b52bb3290bce5293f
[packages/qt5-qtspeech.git] / qt5-qtspeech.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Documentation
4 %bcond_with     flite   # Flite plugin
5
6 %define         orgname         qtspeech
7 %define         qtbase_ver      %{version}
8 %define         qttools_ver     %{version}
9 Summary:        The Qt5 Speech library
10 Summary(pl.UTF-8):      Biblioteka Qt5 Speech
11 Name:           qt5-%{orgname}
12 Version:        5.13.1
13 Release:        1
14 License:        FDL or GPL v2.0 or LGPL v3.0
15 Group:          Libraries
16 Source0:        http://download.qt.io/official_releases/qt/5.13/%{version}/submodules/%{orgname}-everywhere-src-%{version}.tar.xz
17 # Source0-md5:  f87ad3a70a41da0b96de882c390ea8f3
18 URL:            http://www.qt.io/
19 BuildRequires:  Qt5Core-devel >= %{qtbase_ver}
20 BuildRequires:  Qt5Gui-devel >= %{qtbase_ver}
21 BuildRequires:  Qt5Multimedia-devel >= %{qtbase_ver}
22 BuildRequires:  Qt5Widgets-devel >= %{qtbase_ver}
23 BuildRequires:  Qt5XmlPatterns-devel >= %{qtbase_ver}
24 %if %{with flite}
25 BuildRequires:  flite-devel >= 2.1
26 %endif
27 %if %{with doc}
28 BuildRequires:  qt5-assistant >= %{qttools_ver}
29 %endif
30 BuildRequires:  qt5-build >= %{qtbase_ver}
31 BuildRequires:  qt5-qmake >= %{qtbase_ver}
32 BuildRequires:  rpmbuild(macros) >= 1.654
33 BuildRequires:  speech-dispatcher-devel
34 BuildRequires:  tar >= 1:1.22
35 BuildRequires:  xz
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         specflags       -fno-strict-aliasing
39 %define         qt5dir          %{_libdir}/qt5
40
41 %description
42 Qt is a cross-platform application and UI framework. Using Qt, you can
43 write web-enabled applications once and deploy them across desktop,
44 mobile and embedded systems without rewriting the source code.
45
46 This package contains Qt5 Speech library.
47
48 %description -l pl.UTF-8
49 Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
50 Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
51 systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
52 źródłowego.
53
54 Ten pakiet zawiera bibliotekę Qt5 Speech.
55
56 %package -n Qt5Speech
57 Summary:        The Qt5 Speech library
58 Summary(pl.UTF-8):      Biblioteka Qt5 Speech
59 Group:          Libraries
60 Requires:       Qt5Core >= %{qtbase_ver}
61
62 %description -n Qt5Speech
63 Qt5 Speech library.
64
65 %description -n Qt5Speech -l pl.UTF-8
66 Biblioteka Qt5 Speech.
67
68 %package -n Qt5Speech-devel
69 Summary:        Qt5 Speech library - development files
70 Summary(pl.UTF-8):      Biblioteka Qt5 Speech - pliki programistyczne
71 Group:          Development/Libraries
72 Requires:       Qt5Core-devel >= %{qtbase_ver}
73 Requires:       Qt5Speech = %{version}-%{release}
74
75 %description -n Qt5Speech-devel
76 Qt5 Speech library - development files.
77
78 %description -n Qt5Speech-devel -l pl.UTF-8
79 Biblioteka Qt5 Speech - pliki programistyczne.
80
81 %package -n Qt5Speech-plugin-flite
82 Summary:        flite plugin for Qt5 Speech library
83 Summary(pl.UTF-8):      Wtyczka flite do biblioteki Qt5 Speech
84 Group:          Libraries
85 Requires:       Qt5Speech = %{version}-%{release}
86 Requires:       flite >= 2.1
87
88 %description -n Qt5Speech-plugin-flite
89 flite plugin for Qt5 Speech library.
90
91 %description -n Qt5Speech-plugin-flite -l pl.UTF-8
92 Wtyczka flite do biblioteki Qt5 Speech
93
94 %package doc
95 Summary:        Qt5 Speech documentation in HTML format
96 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 Speech w formacie HTML
97 Group:          Documentation
98 Requires:       qt5-doc-common >= %{qtbase_ver}
99 %if "%{_rpmversion}" >= "5"
100 BuildArch:      noarch
101 %endif
102
103 %description doc
104 Qt5 Speech documentation in HTML format.
105
106 %description doc -l pl.UTF-8
107 Dokumentacja do biblioteki Qt5 Speech w formacie HTML.
108
109 %package doc-qch
110 Summary:        Qt5 Speech documentation in QCH format
111 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 Speech w formacie QCH
112 Group:          Documentation
113 Requires:       qt5-doc-common >= %{qtbase_ver}
114 %if "%{_rpmversion}" >= "5"
115 BuildArch:      noarch
116 %endif
117
118 %description doc-qch
119 Qt5 Speech documentation in QCH format.
120
121 %description doc-qch -l pl.UTF-8
122 Dokumentacja do biblioteki Qt5 Speech w formacie QCH.
123
124 %package examples
125 Summary:        Qt5 Speech examples
126 Summary(pl.UTF-8):      Przykłady do biblioteki Qt5 Speech
127 Group:          Development/Libraries
128 %if "%{_rpmversion}" >= "5"
129 BuildArch:      noarch
130 %endif
131
132 %description examples
133 Qt5 Speech examples.
134
135 %description examples -l pl.UTF-8
136 Przykłady do biblioteki Qt5 Speech.
137
138 %prep
139 %setup -q -n %{orgname}-everywhere-src-%{version}
140
141 %build
142 qmake-qt5
143 %{__make}
144 %{?with_doc:%{__make} docs}
145
146 %install
147 rm -rf $RPM_BUILD_ROOT
148 %{__make} install \
149         INSTALL_ROOT=$RPM_BUILD_ROOT
150
151 %if %{with doc}
152 %{__make} install_docs \
153         INSTALL_ROOT=$RPM_BUILD_ROOT
154 %endif
155
156 # useless symlinks
157 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.??
158 # actually drop *.la, follow policy of not packaging them when *.pc exist
159 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
160
161 # Prepare some files list
162 ifecho() {
163         r="$RPM_BUILD_ROOT$2"
164         if [ -d "$r" ]; then
165                 echo "%%dir $2" >> $1.files
166         elif [ -x "$r" ] ; then
167                 echo "%%attr(755,root,root) $2" >> $1.files
168         elif [ -f "$r" ]; then
169                 echo "$2" >> $1.files
170         else
171                 echo "Error generation $1 files list!"
172                 echo "$r: no such file or directory!"
173                 return 1
174         fi
175 }
176 ifecho_tree() {
177         ifecho $1 $2
178         for f in `find $RPM_BUILD_ROOT$2 -printf "%%P "`; do
179                 ifecho $1 $2/$f
180         done
181 }
182
183 echo "%defattr(644,root,root,755)" > examples.files
184 ifecho_tree examples %{_examplesdir}/qt5/speech
185
186 %clean
187 rm -rf $RPM_BUILD_ROOT
188
189 %post   -n Qt5Speech -p /sbin/ldconfig
190 %postun -n Qt5Speech -p /sbin/ldconfig
191
192 %files -n Qt5Speech
193 %defattr(644,root,root,755)
194 %doc LICENSE.* dist/changes-*
195 %attr(755,root,root) %{_libdir}/libQt5TextToSpeech.so.*.*.*
196 %attr(755,root,root) %ghost %{_libdir}/libQt5TextToSpeech.so.5
197 %dir %{_libdir}/qt5/plugins/texttospeech
198 %attr(755,root,root) %{_libdir}/qt5/plugins/texttospeech/libqtexttospeech_speechd.so
199
200 %files -n Qt5Speech-devel
201 %defattr(644,root,root,755)
202 %attr(755,root,root) %{_libdir}/libQt5TextToSpeech.so
203 %{_libdir}/libQt5TextToSpeech.prl
204 %{_includedir}/qt5/QtTextToSpeech
205 %{_pkgconfigdir}/Qt5TextToSpeech.pc
206 %{_libdir}/cmake/Qt5TextToSpeech
207 %{qt5dir}/mkspecs/modules/qt_lib_texttospeech.pri
208 %{qt5dir}/mkspecs/modules/qt_lib_texttospeech_private.pri
209
210 %if %{with flite}
211 %files -n Qt5Speech-plugin-flite
212 %defattr(644,root,root,755)
213 %attr(755,root,root) %{_libdir}/qt5/plugins/texttospeech/libqttexttospeech_flite.so
214 %endif
215
216 %if %{with doc}
217 %files doc
218 %defattr(644,root,root,755)
219 %{_docdir}/qt5-doc/qtspeech
220
221 %files doc-qch
222 %defattr(644,root,root,755)
223 %{_docdir}/qt5-doc/qtspeech.qch
224 %endif
225
226 %files examples -f examples.files
227 %defattr(644,root,root,755)
228 # XXX: dir shared with qt5-qtbase-examples
229 %dir %{_examplesdir}/qt5
This page took 0.103978 seconds and 2 git commands to generate.