]> git.pld-linux.org Git - packages/qt5-qtserialport.git/blob - qt5-qtserialport.spec
9b16827e4164d0fb9b8486a46b7a35e9b7166bc1
[packages/qt5-qtserialport.git] / qt5-qtserialport.spec
1 # TODO:
2 # - cleanup
3
4 %define         orgname         qtserialport
5 Summary:        The Qt5 Serialport
6 Name:           qt5-%{orgname}
7 Version:        5.2.0
8 Release:        0.1
9 License:        LGPL v2.1 or GPL v3.0
10 Group:          Libraries
11 Source0:        http://download.qt-project.org/official_releases/qt/5.2/%{version}/submodules/%{orgname}-opensource-src-%{version}.tar.xz
12 # Source0-md5:  7b90e0707b698331226e662bd39945e9
13 URL:            http://qt-project.org/
14 BuildRequires:  qt5-qtbase-devel = %{version}
15 BuildRequires:  qt5-qttools-devel = %{version}
16 BuildRequires:  rpmbuild(macros) >= 1.654
17 BuildRequires:  tar >= 1:1.22
18 BuildRequires:  xz
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
22 %define         _noautostrip    '.*_debug\\.so*'
23
24 %define         specflags       -fno-strict-aliasing
25 %define         _qtdir          %{_libdir}/qt5
26
27 %description
28 Qt5 Serial Port library.
29
30 %package devel
31 Summary:        The Qt5 Serial Port - development files
32 Group:          Development/Libraries
33 Requires:       %{name} = %{version}-%{release}
34
35 %description devel
36 Qt5 Serial Port - development files.
37
38 %package doc
39 Summary:        The Qt5 Serial Port - docs
40 Group:          Documentation
41 %if "%{_rpmversion}" >= "5"
42 BuildArch:      noarch
43 %endif
44
45 %description doc
46 Qt5 Serial Port - documentation.
47
48 %package examples
49 Summary:        Qt5 Serial Port examples
50 Group:          Development/Libraries
51 %if "%{_rpmversion}" >= "5"
52 BuildArch:      noarch
53 %endif
54
55 %description examples
56 Qt5 Serial Port - examples.
57
58 %prep
59 %setup -q -n %{orgname}-opensource-src-%{version}
60
61 %build
62 qmake-qt5
63 %{__make}
64 %{__make} docs
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 %{__make} install \
69         INSTALL_ROOT=$RPM_BUILD_ROOT
70
71 %{__make} install_docs \
72         INSTALL_ROOT=$RPM_BUILD_ROOT
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post           -p /sbin/ldconfig
78 %postun         -p /sbin/ldconfig
79
80 %files
81 %defattr(644,root,root,755)
82 %attr(755,root,root) %ghost %{_libdir}/libQt5SerialPort.so.?
83 %attr(755,root,root) %{_libdir}/libQt5SerialPort.so.*.*
84 #%attr(755,root,root) %{_qtdir}/plugins
85
86 %files devel
87 %defattr(644,root,root,755)
88 %attr(755,root,root) %{_libdir}/libQt5SerialPort.so
89 %{_libdir}/libQt5SerialPort.la
90 %{_libdir}/libQt5SerialPort.prl
91 %{_libdir}/cmake/Qt5SerialPort
92 %{_includedir}/qt5/QtSerialPort
93 %{_pkgconfigdir}/*.pc
94 %{_qtdir}/mkspecs
95
96 %files doc
97 %defattr(644,root,root,755)
98 %{_docdir}/qt5-doc
99
100 #%files examples -f examples.files
This page took 0.063129 seconds and 2 git commands to generate.