]> git.pld-linux.org Git - packages/qt5-qtserialport.git/blob - qt5-qtserialport.spec
816ea995fb3f2b60057a941498174ae314581e98
[packages/qt5-qtserialport.git] / qt5-qtserialport.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Documentation
4
5 %define         orgname         qtserialport
6 %define         qtbase_ver      %{version}
7 %define         qttools_ver     %{version}
8 Summary:        The Qt5 SerialPort library
9 Summary(pl.UTF-8):      Biblioteka Qt5 SerialPort
10 Name:           qt5-%{orgname}
11 Version:        5.15.0
12 Release:        1
13 License:        LGPL v2.1 with Digia Qt LGPL Exception v1.1 or GPL v3.0
14 Group:          Libraries
15 Source0:        http://download.qt.io/official_releases/qt/5.15/%{version}/submodules/%{orgname}-everywhere-src-%{version}.tar.xz
16 # Source0-md5:  07dd5a0c9c30feb896a59631b88ce21c
17 URL:            http://www.qt.io/
18 BuildRequires:  Qt5Core-devel >= %{qtbase_ver}
19 BuildRequires:  Qt5Gui-devel >= %{qtbase_ver}
20 BuildRequires:  Qt5Widgets-devel >= %{qtbase_ver}
21 %if %{with doc}
22 BuildRequires:  qt5-assistant >= %{qttools_ver}
23 %endif
24 BuildRequires:  qt5-build >= %{qtbase_ver}
25 BuildRequires:  qt5-qmake >= %{qtbase_ver}
26 BuildRequires:  rpmbuild(macros) >= 1.654
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  udev-devel
29 BuildRequires:  xz
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         specflags       -fno-strict-aliasing
33 %define         qt5dir          %{_libdir}/qt5
34
35 %description
36 Qt is a cross-platform application and UI framework. Using Qt, you can
37 write web-enabled applications once and deploy them across desktop,
38 mobile and embedded systems without rewriting the source code.
39
40 This package contains Qt5 SerialPort library.
41
42 %description -l pl.UTF-8
43 Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
44 Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
45 systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
46 źródłowego.
47
48 Ten pakiet zawiera bibliotekę Qt5 SerialPort.
49
50 %package -n Qt5SerialPort
51 Summary:        The Qt5 SerialPort library
52 Summary(pl.UTF-8):      Biblioteka Qt5 SerialPort
53 Group:          Libraries
54 Requires:       Qt5Core >= %{qtbase_ver}
55 Obsoletes:      qt5-qtserialport
56
57 %description -n Qt5SerialPort
58 Qt5 SerialPort library provides classes that enable access to a serial
59 port.
60
61 %description -n Qt5SerialPort -l pl.UTF-8
62 Biblioteka Qt5 SerialPort udostępnia klasy pozwalające na dostęp do
63 portu szeregowego.
64
65 %package -n Qt5SerialPort-devel
66 Summary:        Qt5 SerialPort library - development files
67 Summary(pl.UTF-8):      Biblioteka Qt5 SerialPort - pliki programistyczne
68 Group:          Development/Libraries
69 Requires:       Qt5Core-devel >= %{qtbase_ver}
70 Requires:       Qt5SerialPort = %{version}-%{release}
71 Requires:       udev-devel
72 Obsoletes:      qt5-qtserialport-devel
73
74 %description -n Qt5SerialPort-devel
75 Qt5 SerialPort library - development files.
76
77 %description -n Qt5SerialPort-devel -l pl.UTF-8
78 Biblioteka Qt5 SerialPort - pliki programistyczne.
79
80 %package doc
81 Summary:        Qt5 SerialPort documentation in HTML format
82 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 SerialPort w formacie HTML
83 Group:          Documentation
84 Requires:       qt5-doc-common >= %{qtbase_ver}
85 %if "%{_rpmversion}" >= "5"
86 BuildArch:      noarch
87 %endif
88
89 %description doc
90 Qt5 SerialPort documentation in HTML format.
91
92 %description doc -l pl.UTF-8
93 Dokumentacja do biblioteki Qt5 SerialPort w formacie HTML.
94
95 %package doc-qch
96 Summary:        Qt5 SerialPort documentation in QCH format
97 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 SerialPort w formacie QCH
98 Group:          Documentation
99 Requires:       qt5-doc-common >= %{qtbase_ver}
100 %if "%{_rpmversion}" >= "5"
101 BuildArch:      noarch
102 %endif
103
104 %description doc-qch
105 Qt5 SerialPort documentation in QCH format.
106
107 %description doc-qch -l pl.UTF-8
108 Dokumentacja do biblioteki Qt5 SerialPort w formacie QCH.
109
110 %package examples
111 Summary:        Qt5 SerialPort examples
112 Summary(pl.UTF-8):      Przykłady do biblioteki Qt5 SerialPort
113 Group:          Development/Libraries
114 %if "%{_rpmversion}" >= "5"
115 BuildArch:      noarch
116 %endif
117
118 %description examples
119 Qt5 SerialPort examples.
120
121 %description examples -l pl.UTF-8
122 Przykłady do biblioteki Qt5 SerialPort.
123
124 %prep
125 %setup -q -n %{orgname}-everywhere-src-%{version}
126
127 %build
128 qmake-qt5
129 %{__make}
130 %{?with_doc:%{__make} docs}
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134 %{__make} install \
135         INSTALL_ROOT=$RPM_BUILD_ROOT
136
137 %if %{with doc}
138 %{__make} install_docs \
139         INSTALL_ROOT=$RPM_BUILD_ROOT
140 %endif
141
142 # useless symlinks
143 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.??
144 # actually drop *.la, follow policy of not packaging them when *.pc exist
145 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post   -n Qt5SerialPort -p /sbin/ldconfig
151 %postun -n Qt5SerialPort -p /sbin/ldconfig
152
153 %files -n Qt5SerialPort
154 %defattr(644,root,root,755)
155 %doc LICENSE.GPL3-EXCEPT dist/changes-*
156 %attr(755,root,root) %{_libdir}/libQt5SerialPort.so.*.*.*
157 %attr(755,root,root) %ghost %{_libdir}/libQt5SerialPort.so.5
158
159 %files -n Qt5SerialPort-devel
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_libdir}/libQt5SerialPort.so
162 %{_libdir}/libQt5SerialPort.prl
163 %{_includedir}/qt5/QtSerialPort
164 %{_pkgconfigdir}/Qt5SerialPort.pc
165 %{_libdir}/cmake/Qt5SerialPort
166 %{qt5dir}/mkspecs/modules/qt_lib_serialport.pri
167 %{qt5dir}/mkspecs/modules/qt_lib_serialport_private.pri
168
169 %if %{with doc}
170 %files doc
171 %defattr(644,root,root,755)
172 %{_docdir}/qt5-doc/qtserialport
173
174 %files doc-qch
175 %defattr(644,root,root,755)
176 %{_docdir}/qt5-doc/qtserialport.qch
177 %endif
178
179 # examples not installed
180 #%files examples -f examples.files
This page took 0.087647 seconds and 2 git commands to generate.