]> git.pld-linux.org Git - packages/qt5-qtserialport.git/blob - qt5-qtserialport.spec
5dde2d0f04ac4e4457e94db447d8ce39f88c4f20
[packages/qt5-qtserialport.git] / qt5-qtserialport.spec
1 #
2 # Conditional build:
3 %bcond_without  qch     # documentation in QCH format
4
5 %define         orgname         qtserialport
6 %define         qtbase_ver      %{version}
7 %define         qttools_ver     %{version}
8 Summary:        The Qt5 SerialPort library
9 Summary(pl.UTF-8):      Biblioteka Qt5 SerialPort
10 Name:           qt5-%{orgname}
11 Version:        5.3.1
12 Release:        1
13 License:        LGPL v2.1 with Digia Qt LGPL Exception v1.1 or GPL v3.0
14 Group:          Libraries
15 Source0:        http://download.qt-project.org/official_releases/qt/5.3/%{version}/submodules/%{orgname}-opensource-src-%{version}.tar.xz
16 # Source0-md5:  d9557391a3ab696089d657cb3a2b608e
17 URL:            http://qt-project.org/
18 BuildRequires:  Qt5Core-devel >= %{qtbase_ver}
19 BuildRequires:  Qt5Gui-devel >= %{qtbase_ver}
20 BuildRequires:  Qt5Widgets-devel >= %{qtbase_ver}
21 %if %{with qch}
22 BuildRequires:  qt5-assistant >= %{qttools_ver}
23 %endif
24 BuildRequires:  qt5-build >= %{qtbase_ver}
25 BuildRequires:  qt5-qmake >= %{qtbase_ver}
26 BuildRequires:  rpmbuild(macros) >= 1.654
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  udev-devel
29 BuildRequires:  xz
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         specflags       -fno-strict-aliasing
33 %define         qt5dir          %{_libdir}/qt5
34
35 %description
36 Qt is a cross-platform application and UI framework. Using Qt, you can
37 write web-enabled applications once and deploy them across desktop,
38 mobile and embedded systems without rewriting the source code.
39
40 This package contains Qt5 SerialPort library.
41
42 %description -l pl.UTF-8
43 Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
44 Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
45 systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
46 źródłowego.
47
48 Ten pakiet zawiera bibliotekę Qt5 SerialPort.
49
50 %package -n Qt5SerialPort
51 Summary:        The Qt5 SerialPort library
52 Summary(pl.UTF-8):      Biblioteka Qt5 SerialPort
53 Group:          Libraries
54 Requires:       Qt5Core >= %{qtbase_ver}
55 Obsoletes:      qt5-qtserialport
56
57 %description -n Qt5SerialPort
58 Qt5 SerialPort library provides classes that enable access to a serial
59 port.
60
61 %description -n Qt5SerialPort -l pl.UTF-8
62 Biblioteka Qt5 SerialPort udostępnia klasy pozwalające na dostęp do
63 portu szeregowego.
64
65 %package -n Qt5SerialPort-devel
66 Summary:        Qt5 SerialPort library - development files
67 Summary(pl.UTF-8):      Biblioteka Qt5 SerialPort - pliki programistyczne
68 Group:          Development/Libraries
69 Requires:       Qt5Core-devel >= %{qtbase_ver}
70 Requires:       Qt5SerialPort = %{version}-%{release}
71 Requires:       udev-devel
72 Obsoletes:      qt5-qtserialport-devel
73
74 %description -n Qt5SerialPort-devel
75 Qt5 SerialPort library - development files.
76
77 %description -n Qt5SerialPort-devel -l pl.UTF-8
78 Biblioteka Qt5 SerialPort - pliki programistyczne.
79
80 %package doc
81 Summary:        Qt5 SerialPort documentation in HTML format
82 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 SerialPort w formacie HTML
83 Group:          Documentation
84 Requires:       qt5-doc-common >= %{qtbase_ver}
85 %if "%{_rpmversion}" >= "5"
86 BuildArch:      noarch
87 %endif
88
89 %description doc
90 Qt5 SerialPort documentation in HTML format.
91
92 %description doc -l pl.UTF-8
93 Dokumentacja do biblioteki Qt5 SerialPort w formacie HTML.
94
95 %package doc-qch
96 Summary:        Qt5 SerialPort documentation in QCH format
97 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 SerialPort w formacie QCH
98 Group:          Documentation
99 Requires:       qt5-doc-common >= %{qtbase_ver}
100 %if "%{_rpmversion}" >= "5"
101 BuildArch:      noarch
102 %endif
103
104 %description doc-qch
105 Qt5 SerialPort documentation in QCH format.
106
107 %description doc-qch -l pl.UTF-8
108 Dokumentacja do biblioteki Qt5 SerialPort w formacie QCH.
109
110 %package examples
111 Summary:        Qt5 SerialPort examples
112 Summary(pl.UTF-8):      Przykłady do biblioteki Qt5 SerialPort
113 Group:          Development/Libraries
114 %if "%{_rpmversion}" >= "5"
115 BuildArch:      noarch
116 %endif
117
118 %description examples
119 Qt5 SerialPort examples.
120
121 %description examples -l pl.UTF-8
122 Przykłady do biblioteki Qt5 SerialPort.
123
124 %prep
125 %setup -q -n %{orgname}-opensource-src-%{version}
126
127 %build
128 qmake-qt5
129 %{__make}
130 %{__make} %{!?with_qch:html_}docs
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134 %{__make} install \
135         INSTALL_ROOT=$RPM_BUILD_ROOT
136
137 %{__make} install_%{!?with_qch:html_}docs \
138         INSTALL_ROOT=$RPM_BUILD_ROOT
139
140 # useless symlinks
141 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.?
142 # actually drop *.la, follow policy of not packaging them when *.pc exist
143 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post   -n Qt5SerialPort -p /sbin/ldconfig
149 %postun -n Qt5SerialPort -p /sbin/ldconfig
150
151 %files -n Qt5SerialPort
152 %defattr(644,root,root,755)
153 %doc LGPL_EXCEPTION.txt dist/changes-*
154 %attr(755,root,root) %{_libdir}/libQt5SerialPort.so.*.*.*
155 %attr(755,root,root) %ghost %{_libdir}/libQt5SerialPort.so.5
156
157 %files -n Qt5SerialPort-devel
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_libdir}/libQt5SerialPort.so
160 %{_libdir}/libQt5SerialPort.prl
161 %{_includedir}/qt5/QtSerialPort
162 %{_pkgconfigdir}/Qt5SerialPort.pc
163 %{_libdir}/cmake/Qt5SerialPort
164 %{qt5dir}/mkspecs/modules/qt_lib_serialport.pri
165 %{qt5dir}/mkspecs/modules/qt_lib_serialport_private.pri
166
167 %files doc
168 %defattr(644,root,root,755)
169 %{_docdir}/qt5-doc/qtserialport
170
171 %if %{with qch}
172 %files doc-qch
173 %defattr(644,root,root,755)
174 %{_docdir}/qt5-doc/qtserialport.qch
175 %endif
176
177 # examples not installed
178 #%files examples -f examples.files
This page took 0.077358 seconds and 2 git commands to generate.